8.х Форма Документа-->Форма Списка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем zayaroslava, 14 май 2010.

  1. TopicStarter Overlay
    zayaroslava
    Offline

    zayaroslava Опытный в 1С

    Регистрация:
    27 янв 2010
    Сообщения:
    329
    Симпатии:
    1
    Баллы:
    26
    Всем привет,нужна ваша помощь!

    Есть Форма Списка и Форма документа с одноимеными реквезитами: Реквезит "Название" и в ТаблчинаяЧасть1-->Реквезит "Название".
    Необходимо выгрузить ПОСТРОЧНО из ТаблчинаяЧасть1-->Реквезит "Название" формы документа в Реквезит "Название" Формы Списка.
    Т.е в форме списка создавать новый документ и вставлять строку из табличной части реквезита "Название".
    как это сделать и возможно ли это?
    Получилось написать следующие:
    массив = ТабличнаяЧасть1.ВыгрузитьКолонку("Название");
    НомерстрокиТч = ЭтотОбъект.ТабличнаяЧасть1.Количество();
    к=0;
    Пока к <> НомерстрокиТч цикл
    //Название = массив[к];
    // Сюда надо вставить загрузку каждого элемента массива в новый документ(строку) формы списка.Как это сделать?
    к=к+1;

    КонецЦикла;

    P.S.Скриншот прилагается...Возможно идея не правильная,но так необходимо сделать

    Вложения:

    • 1c.JPG
      1c.JPG
      Размер файла:
      98,7 КБ
      Просмотров:
      9
  2. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.644
    Симпатии:
    948
    Баллы:
    204
    Т.е вы хотите открвыть документ нажимать на кнопку и у Вас бы создавались Новые документы с таким же названием что и в ТЧ открытого документа?

    в чем проблема

    В обрабботчики такой кнопки

    Код:
    Для каждого стр из ТабличнаяЧасть1 Цикл
    
    ДокОбъект=Документы.ИмяВашегоДокумента.СоздатьДокумент();
    ДокОбъект.Наименование=стр.Наименование;
    ДокОбъект.Записать();
    КонецЦикла;
    
  3. TopicStarter Overlay
    zayaroslava
    Offline

    zayaroslava Опытный в 1С

    Регистрация:
    27 янв 2010
    Сообщения:
    329
    Симпатии:
    1
    Баллы:
    26
    ======
    Это необходимо сделать один раз чтобы выгрузить табличную часть в форму списка.В иотоге нужно вызгрузить все клолнки из ТЧ в Форму Списка.

    Попробывал ваш код,пишет:
    Ошибка при вызове метода контекста (Записать): Не задана дата документа
    ДокОбъект.Записать();

    ? ? ?
  4. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.644
    Симпатии:
    948
    Баллы:
    204
    Ну я так образдно написал Даты и номера вы сами проставьте

    ну например так

    Код:
    Для каждого стр из ТабличнаяЧасть1 Цикл
    ДокОбъект=Документы.ИмяВашегоДокумента.СоздатьДокумент();
    ДокОбъект.Наименование=стр.Наименование;
    ДокОбъект.УстановитьНовыйНомер();
    ДокОбъект.УстановитьВремя();
    ДокОбъект.Записать();
    КонецЦикла;
    
  5. TopicStarter Overlay
    zayaroslava
    Offline

    zayaroslava Опытный в 1С

    Регистрация:
    27 янв 2010
    Сообщения:
    329
    Симпатии:
    1
    Баллы:
    26
    ======
    Все получилось,спасибо! =)

Поделиться этой страницей