8.х флажок "услуга" в справочнике "номенклатура"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем DDRON, 12 ноя 2008.

  1. TopicStarter Overlay
    DDRON
    Offline

    DDRON Опытный в 1С

    Регистрация:
    26 авг 2008
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Конфа - Бухгалтерия предприятия.
    Справочник - Номенклатура.
    В свойствах элементов этого справочника есть галка "услуга".
    От наличия/отсутствия этой галки зависит то, куда конкретная номенкрутура попадает в реализации (либо во вкладку услуги, либо во вкладку товары).

    Эту галку, можно поставить/убрать только если товар не участвует в товаропроведении.
    У меня куча номенклатур которым надо поставить эту галку. И почти все они задействованы в товаропроведении (вроде так называется).

    Как в конфигураторе отключить контроль присутствия номенклатуры в товаропроведении при изменении значенияч галки?
    Потом эту проверку верну.
  2. DmitryS
    Offline

    DmitryS Опытный в 1С

    Регистрация:
    20 июл 2007
    Сообщения:
    119
    Симпатии:
    0
    Баллы:
    26
    Смотри в модуле объекта справочника "Номенклатура", процедурка "ПередЗаписью".
  3. TopicStarter Overlay
    DDRON
    Offline

    DDRON Опытный в 1С

    Регистрация:
    26 авг 2008
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Да, при нажатии на "Записать", вызавается процедура "ПередЗаписью".
    Вот она:

    Код:
    Процедура ПередЗаписью(Отказ)
    
    СтрокиДляЗаписи = ЦеныНоменклатуры.НайтиСтроки(Новый Структура("Записать", Истина));
    ТекстСообщения = "";
    НачалоПредупреждения = "Не указано значение цены для записи (тип цен ";
    Для Каждого Строка Из СтрокиДляЗаписи Цикл        
    Если Не ЗначениеЗаполнено(Строка.Цена) Тогда
    ТекстСообщения = ТекстСообщения + НачалоПредупреждения + Строка.ТипЦен + ")
    |";
    КонецЕсли;         
    КонецЦикла;
    Если ЗначениеЗаполнено(ТекстСообщения) Тогда
    Предупреждение(ТекстСообщения);
    Отказ = Истина;    
    КонецЕсли;
    КонецПроцедуры
    
    
    
    При этом масиив "СтрокиДляЗаписи" - пустой.
    В цикл "если - конецесли" - тоже не попадаем.

    Далее вываливается ошибка
    Код:
    Номенклатура "РогаКопыта" участвует в товародвижении.
    Признак услуги <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не может быть изменен!</span>
    
    
    Куда дальше копать? Процедура При записи в этом случае не вызывается. Проверял.
  4. TopicStarter Overlay
    DDRON
    Offline

    DDRON Опытный в 1С

    Регистрация:
    26 авг 2008
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Задача решена
  5. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    В следующий раз за подобный итоговй комментарий забаним.

    Вы мало того, что запутали всех каким-то не тем кодом (надо проверять ПередЗаписью и ПриЗаписи у справочника Номенклатуры), так еще и не описали полученного вами решения.

Поделиться этой страницей