7.7 Флаг в справочнике

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Kugelfangg, 17 апр 2008.

  1. TopicStarter Overlay
    Kugelfangg
    Offline

    Kugelfangg Опытный в 1С

    Регистрация:
    13 фев 2008
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    здравствуйте.
    столкнулся с траблом:
    не работает обработка.смысл в том, чтоб во всех элементах справочника номенклатуры находящихся в папке "старая номенклатура" стафился флаг.

    попробовал 2 варианта,оба работают криво, ставит галки не во все позиции.=((некоторые пропускает)
    Код:
    Процедура Сформировать()
    спр=создатьобъект("справочник.номенклатура"); 
    ффф=спр.найтипокоду("000199");
    Спр.ИСпользоватьВладельца(ффф);
    спр.ВыбратьЭлементы();
    пока спр.ПолучитьЭлемент()=1 цикл
    спр.Флаг=1;
    спр.записать();
    КонецЦикла;
    КонецПроцедуры
    
    
    Код:
    Процедура Сформировать()
    спр=создатьобъект("справочник.номенклатура"); 
    Если спр.найтипокоду("000199",0) = 0 тогда   ///пробовал и с 1 и с 2
    возврат;
    Конецесли;
    Родитель = спр.текущийЭлемент();
    Спр.ИСпользоватьродителя(родитель);
    спр.ВыбратьЭлементы();
    пока спр.ПолучитьЭлемент()=1 цикл
    спр.Флаг=1;
    спр.записать();
    КонецЦикла;
    КонецПроцедуры
    
    
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Код:
    СпрНоменклатуры = СоздатьОбъект("Справочник.Номенклатура"); 
    СпрНоменклатуры.ИспользоватьРодителя(Группа);
    СпрНоменклатуры.ВыбратьЭлементы();
    Пока СпрНоменклатуры.ПолучитьЭлемент() = 1 Цикл    
    СпрНоменклатуры.Флаг=1;
    Если СпрНоменклатуры.Блокировка() = 1 Тогда
    Сообщить("Справочник " + СпрНоменклатуры + " заблокирован");
    Иначе
    СпрНоменклатуры.Записать();
    КонецЕсли;
    КонецЦикла;
    
    
    а элемент "Группа" разумеется с типом справочник.номенклатура выбери лучше как реквизит обработки... получится более универсально... а то вдруг кто-нить код группы изменит... или еще какая-нить хрень случится...
  3. TopicStarter Overlay
    Kugelfangg
    Offline

    Kugelfangg Опытный в 1С

    Регистрация:
    13 фев 2008
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Спасибо огромное за помощь.

Поделиться этой страницей