[РЕШЕНО] Excel

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем VIPOS, 19 мар 2014.

  1. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Друзья! Столкнулся с проблемой
    Написал обработку для установки периодических реквизитов в карточке ОС, но выдает ошибку
    [​IMG]
    В чем может быть причина?
    Код:
    Процедура Сформировать()
    
    Excel = СоздатьОбъект("Excel.Application");
    СпрОС = СоздатьОбъект("Справочник.ОсновныеСредства");
    Excel.Workbooks.Open(СокрЛП(НазваниеФайла));
    Книга = Excel.ActiveWorkbook;
    Строки = Excel.Cells.CurrentRegion.Rows.Count;
    Сообщить(Строки);
    ТекЭлем = СпрОС.ТекущийЭлемент();
    Для х = 1 По Строки Цикл
    
    Код       = СокрЛП(Excel.Cells(х, 3).Value);
    
    КоэфПересчета = СокрЛП(Строка(Excel.Cells(х, 8).Value));
    ВостСтоим= Число(Excel.Cells(х, 9).Value);
    //СуммаПослеПереоц=Число(Excel.Cells(х, 11).Value);
    //ОстатСтоим=Число(Excel.Cells(х, 12).Value);
    
    Если СпрОС.НайтиПоКоду(Код) = 1 Тогда
    СпрОС = СпрОС.ТекущийЭлемент();
    СпрОС.КоэфПереоценки.Установить(ДатаПереоценки, КоэфПересчета);
    СпрОС.ВосстановительнаяСтоимость.Установить(ДатаПереоценки, ВостСтоим);
    СпрОС.Записать();
    Сообщить(СпрОС.Код+" записан на дату" +ДатаПереоценки);
    Иначе
    Сообщить("ОС "+Код+ "Не найдено");
    Продолжить;
    Конецесли;
    //СпрОС.КоэфПереоценки.Установить(ДатаПереоценки, КоэфПересчета);
    //СпрОС.ВосстановительнаяСтоимость.Установить(ДатаПереоценки, ВостСтоим);
    //СпрОС.Записать();
    //Сообщить(СпрОС.Код+" записан на дату" +ДатаПереоценки);
    //.......
    
    Конеццикла;
    
    //После загрузки зарываем соединение с Excel
    Excel.Workbooks.Close();
    КонецПроцедуры
    Процедура ВыбратьКат()
    Перем Стр;
    Стр=НазваниеФайла;
    ИмяФ=НазваниеФайла;
    Если ФС.ВыбратьФайл(0,ИмяФ,Стр,"Выбор файла для экспорта","XLS-файлы (*.xls) |*.xls") > 0 Тогда
    ИмяФайлаЗагрузки=Стр+ИмяФ;
    Иначе
    ИмяФайлаЗагрузки="";
    КонецЕсли;
    КонецПроцедуры

    Вложения:

  2. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    спасибо... решено!
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    а в чем была проблема? КоэфПересчета - строка?
  4. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    скорей перепутаны переменные местами
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Установить(<Дата>,<Значение>)
    Назначение:
    Установить значение периодического реквизита справочника на заданную дату.
    Параметры:
    <Дата> - выражение со значением требуемой даты;
    <Значение> - выражение, содержащее устанавливаемое значение периодического реквизита справочника.


    да нет... дата, а потом значение...

Поделиться этой страницей