8.х ЕстьРеквизитСправочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем PavelBaryshev, 27 янв 2011.

  1. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, подскажите пожалуйста, вот есть в УТ 10.3 такая функция:
    Код:
    Функция ЕстьРеквизитДокумента(ИмяРеквизита, МетаданныеДокумента) Экспорт
    
    Если МетаданныеДокумента.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
    Возврат Ложь;
    Иначе
    Возврат Истина;
    КонецЕсли; 
    
    КонецФункции
    
    А есть ли такая же но для справочника?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Метаданные имеют тот же самый набор методов (почти) для справочников и документов. Если нет - напишите)))
  3. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    То есть все примерно так:
    Код:
    Функция ЕстьРеквизитСправочника(ИмяРеквизита, МетаданныеДокумента) Экспорт
    
    Если МетаданныеДокумента.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
    Возврат Ложь;
    Иначе
    Возврат Истина;
    КонецЕсли; 
    
    КонецФункции
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей