Если есть какие вопросы по торговому оборудованию -задавайте"

Тема в разделе "Торговое оборудование в 1С", создана пользователем рамиль, 12 мар 2006.

Статус темы:
Закрыта.
  1. Дмитрий Маренин
    Offline

    Дмитрий Маренин Опытный в 1С

    Регистрация:
    24 ноя 2009
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    фр может спокойно работать в не фискальном режиме, и отбивать чеки. проверьте дату и время на фр,
  2. Баатр
    Offline

    Баатр

    Регистрация:
    9 апр 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    все заработало, когда поставил драйвер последней версии. всем спасибо.
  3. nikita_s
    Offline

    nikita_s

    Регистрация:
    12 апр 2011
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Есть проблемы при подключении принтера PP-6800L к Ресторан+Бар+Кафе ред.2.5. Принтер подключен через сеть.

    -В справочнике оборудование создал новое устройство — спецпринтер кухни.

    -в сервис-параметры-торговое оборудование добавил принтер пречеков, указал
    порт=сетевой принтер
    Сетевое имя принтера=192.168.1.246 (ip принтера, проверил утилитой для тестирования принтера по этому адресу откликается все ок)

    -включил принтер в справочнике оборудования, оборудование включилось — ОК

    - при попытке распечатать пречек на этот принтер или заказ на кухню появляется ошибка
    "Произошла ошибка при печати заказа. ОШИБКА печати ПРЕЧЕКА (Код = 6) Windows Не удается найти указанный файл."

    подскажите пожалуйста в чем может быть дело?

    PS
    пробовал также
    Сетевое имя принтера=\\192.168.1.246

    получаем: ОШИБКА печати пречека
    (Код = 6) Windows: Указан недопустимый путь.
  4. Max56
    Offline

    Max56

    Регистрация:
    9 май 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Аналогичная проблема, только такая система работала практически год нормально, а сейчас начала при открытии смены выдавать "Проверьте дату и время" а на чеке ЧЕК АННУЛИРОВАН, дата и время на компьютере совпадает, драйвера обновлены до последних, замена компьютера тоже не помогла. Что еще можно посмотреть?
  5. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    в тесте ККМ драйвера Атол проверьте текущие дату и время в ФР, если они отличаются от текущих значений - переустановите дату/время (при этом смена на ФР должна быть закрыта - Z-отчёт снят).
  6. nachalnikdirektor
    Offline

    nachalnikdirektor

    Регистрация:
    30 май 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Прошу помощи разобраться с проблемой.

    Пожелание заказчика - печатать чеки ккм не по документу ЧекККМ а по документу реализация товаров и услуг.

    Я написал свою функцию. При подключении эмулятора ФР - печатается чек всегда стабильно. Добавил вызов функции ПечатьЧекаККМ(); в обработку проведения документа "Реализация товаров и услуг"

    Проблема:
    Чек выходит нерегулярно при подключении РЕАЛЬНОГО устройства
    (пробовал с атоловским Fprint-55 и штриховским ШТРИХ-МИНИ-ФР-К).
    Выходит ошибка "Неизвестная ошибка".

    Исходный код процедуры приведен ниже

    Код:
    Процедура ПечатьЧекаККМ() Экспорт
    //Перем ФР;
    //Перем НомерЧекаККМ;
    //Перем НомерСменыККМ;
    НомерСменыККМ=1;    НомерЧекаККМ=1;;ШиринаЛенты=36;
    
    
    МассивФР      = ПолучитьСерверТО().ПолучитьСписокУстройств(
    Перечисления.ВидыТорговогоОборудования.ФискальныйРегистратор,
    Справочники.КассыККМ.НайтиПоКоду("000000001"));
    
    
    
    КоличествоФР = МассивФР.Количество();
    Если КоличествоФР = 0 Тогда
    Ответ     = "";
    Отказ     = Истина;
    Результат = Истина;
    
    ИначеЕсли КоличествоФР = 1 Тогда
    ФР = МассивФР[0];
    Иначе
    СписокФР = РаботаСТорговымОборудованием.ПолучитьСписокУстройствТОДляВыбора(МассивФР);
    
    ФР = СписокФР.ВыбратьЭлемент("Необходимо выбрать фискальный регистратор");
    Если ФР = Неопределено Тогда
    Ответ     = "Операция отменена пользователем.";
    Отказ     = Истина;
    Результат = Ложь;
    
    Иначе
    ФР = ФР.Значение;
    КонецЕсли;
    КонецЕсли;
    
    Пароль    = ПолучитьСерверТО().ПолучитьПарольАдминистратораККМ();
    ОшибкаТО = Перечисления.ТООшибкиОбщие.ПустаяСсылка();
    Если ЗначениеЗаполнено(ОшибкаТО) Тогда
    Предупреждение(ОшибкаТО);
    КонецЕсли;
    
    ЧекККМ=Документы.ЧекККМ.СоздатьДокумент();
    
    Если Товары.Количество()>0 Тогда
    Мак=ЧекККМ.ПолучитьМакет("ЧекПокупателя");
    Тб=Новый ТекстовыйДокумент;
    Обл=Мак.ПолучитьОбласть("ШапкаЧека36");
    Обл.Параметры.Заголовок="Магазин Formoza";
    Обл.Параметры.Организация=Организация;
    Обл.Параметры.ИНН=Организация.ИНН;
    Тб.Вывести(Обл);
    
    Итог=0;
    Для т=1 по Товары.Количество()    Цикл
    Обл=Мак.ПолучитьОбласть("ТелоЧека36");
    Обл.Параметры.НаименованиеТовара=Товары[т-1].Номенклатура;
    Сумма=Товары[т-1].Цена*Товары[т-1].Количество;
    Обл.Параметры.КоличествоЦена=""+Товары[т-1].Цена+"*"+Товары[т-1].Количество+"="+Сумма;
    Тб.Вывести(Обл);
    Итог=Итог+Товары[т-1].Сумма;
    КонецЦикла;
    
    Обл=Мак.ПолучитьОбласть("ПодвалЧека36");
    Обл.Параметры.Итог=Итог;
    Тб.Вывести(Обл);
    //Тб.Показать();
    // Открыть нефискальный чек
    //НомерЧекаККМ=88;НомерСменыККМ=0;    МассивСтрокЧека=1;
    ШиринаЛенты=36;
    Мас=Новый Массив;
    Для т=1 по Тб.КоличествоСтрок() Цикл
    Мас.Добавить(Тб.ПолучитьСтроку(т-1));
    КонецЦикла;
    Пароль = 29;
    ОшибкаТО = ПолучитьСерверТО().ОткрытьЧек(ФР, ПолучитьСерверТО().ПолучитьПарольАдминистратораККМ(),
    ВидОперации = Перечисления.ВидыОперацийЧекККМ.Возврат,
    НомерЧекаККМ, НомерСменыККМ, Ложь);
    Если ЗначениеЗаполнено(ОшибкаТО) Тогда
    Предупреждение(ОшибкаТО);
    КонецЕсли;
    
    //ОшибкаТО = ПолучитьСерверТО().ПечатьСтрокиЧека(ФР,"Магазин Formozaукпук");
    // Напечатать строки полученного из макета чека
    ОшибкаТО = ПолучитьСерверТО().ПечатьТекста(ФР, Мас, ШиринаЛенты);
    // Закрыть чек
    ОшибкаТО = ПолучитьСерверТО().ЗакрытьЧек(ФР, 0, 0);
    
    КонецЕсли;
    
    Если Услуги.Количество()>0 Тогда
    Мак=ЧекККМ.ПолучитьМакет("ЧекПокупателя");
    Тб=Новый ТекстовыйДокумент;
    Обл=Мак.ПолучитьОбласть("ШапкаЧека36");
    Обл.Параметры.Заголовок="Магазин Formoza";
    Обл.Параметры.Организация=Организация;
    Обл.Параметры.ИНН=Организация.ИНН;
    Тб.Вывести(Обл);
    
    Итог=0;
    Для т=1 по Услуги.Количество()    Цикл
    Обл=Мак.ПолучитьОбласть("ТелоЧека36");
    Обл.Параметры.НаименованиеТовара=Услуги[т-1].Номенклатура;
    Сумма=Услуги[т-1].Цена*Услуги[т-1].Количество;
    Обл.Параметры.КоличествоЦена=""+Услуги[т-1].Цена+"*"+Услуги[т-1].Количество+"="+Сумма;
    Тб.Вывести(Обл);
    Итог=Итог+Услуги[т-1].Сумма;
    КонецЦикла;
    
    Обл=Мак.ПолучитьОбласть("ПодвалЧека36");
    Обл.Параметры.Итог=Итог;
    Тб.Вывести(Обл);
    Мас=Новый Массив;
    Для т=1 по Тб.КоличествоСтрок() Цикл
    Мас.Добавить(Тб.ПолучитьСтроку(т-1));
    КонецЦикла;
    
    //Тб.Показать();
    // Открыть нефискальный чек
    //НомерЧекаККМ=88;НомерСменыККМ=0;    
    //ШиринаЛенты=36;
    //Пароль = 29;
    
    //Фр="D0915D76-68EF-442C-A169-16360155DEBD"
    //ПолучитьСерверТО().ПолучитьПарольКассираККМ()=29
    //ВидОперации = Перечисления.ВидыОперацийЧекККМ.Возврат=ложь
    //НомерЧекаККМ=87; Значение до = 1;
    //НомерСменыККМ=0; Значение до = 1;
    //Ложь;
    ОшибкаТО = ПолучитьСерверТО().ОткрытьЧек(ФР, ПолучитьСерверТО().ПолучитьПарольАдминистратораККМ(),
    ВидОперации = Перечисления.ВидыОперацийЧекККМ.Возврат,
    НомерЧекаККМ, НомерСменыККМ, Ложь);
    
    // Напечатать строки полученного из макета чека
    //ФР = "D0915D76-68EF-442C-A169-16360155DEBD"
    //МАС=Массив  (Mac[2]="          Магазин            ")
    //ШиринаЛенты=36
    ОшибкаТО = ПолучитьСерверТО().ПечатьТекста(ФР, Мас, ШиринаЛенты);
    // Закрыть чек
    ОшибкаТО = ПолучитьСерверТО().ЗакрытьЧек(ФР, 0, 0);
    
    КонецЕсли;
    
    //123456789012345678901234567890123456
    //#Область ШапкаЧека36
    // 
    //[            Заголовок             ]
    //
    // 
    //[           Организация            ]
    //
    //[               ИНН                ]
    //====================================
    //#КонецОбласти
    //#Область ТелоЧека36
    //[НаименованиеТовара                ]
    //
    //[                    КоличествоЦена]
    //
    //[ЗагСкидка][                 Скидка]
    // 
    //#КонецОбласти
    //#Область ПодвалЧека36
    //====================================
    //ИТОГ: [                        Итог]
    //ОПЛАТА
    // [Оплата                           ]
    // 
    //[Сдача                             ]
    //
    // 
    //Кассир: [                 Сотрудник]
    //
    // 
    //____________________________________
    //             (подпись)              
    // 
    //#КонецОбласти
    //123456789012345678901234567890123456
    КонецПроцедуры    
    
    
    
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А через документ ЧекККМ сбоев не наблюдается или есть?
    В самом коде не вижу ошибки....
  8. jstsj
    Offline

    jstsj

    Регистрация:
    15 июн 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Помогите пожалуйста. Есть прайс чекер Shuttle SG-15, как его подружить с 1с восьмерка? С чего начать?
  9. tanya-ek
    Offline

    tanya-ek

    Регистрация:
    6 апр 2011
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, УТ-8.1 конфа 10.3 при отбитии чека ККМ сильно тормозит, Х-отчёт снимает быстро, значит дело не оборудовании а в 1С. Как исправить тормоза?
  10. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Х-отчет не создает закрытие смены, а тупо берет данные из регистров, и выдает отчет о продажах:)
  11. tanya-ek
    Offline

    tanya-ek

    Регистрация:
    6 апр 2011
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Т.е. надо копать в регистрах? Это уже в другом месте искать?
  12. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Тут дело еще может быть в драйверах для ККМ, причин может быть много. У вас типовая УТ, ничего в ней не меняли?
  13. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    Х-отчёт к 1С практически никакого отношения не имеет, когда Вы нажимаете "снять отчёт без гашения " (или как там, уже точно не помню) - 1С банально посылает команду в ккм "снять Х-отчёт", при этом данные в 1С никак не учитываются (учитываются данные сумм, хранящихся в памяти ккм), это сугубо аппаратная функция, как впрочем и Z-отчёт.
  14. ramzess9
    Offline

    ramzess9

    Регистрация:
    15 июл 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!
    Имеется следующая проблемка:
    Есть аппарат ККМ FPrint-03К и бухгалтерия Бухгалтерия предприятия, редакция 2.0 (2.0.21.1) ,
    по утверждению обслуживающей компании (которая подключала) этот аппарат и 8.2 несовместимы в подключении, либо дописывать 8.2, либо покупать базовую 8.1
    Так ли это и подскажите где можно скачать эту обработку для загрузки.
    Спасибо
  15. onlider
    Offline

    onlider

    Регистрация:
    8 июл 2011
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Сам не сталкивался, но "продавцы" пишут, что работает и к тому же нормально.
    покопайся тут: _http://www.nado.in/archive/index.php/t-4.html - может найдешь что полезное.
    и на сайте производителя глянь, если не поможет - пиши в ПМ
  16. sandman_83
    Offline

    sandman_83 Опытный в 1С

    Регистрация:
    27 фев 2009
    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    26
    Всем доброго времени суток!
    Имеется следующая проблема.
    УТ 10.3.13.2 и фискальный регистратор Штрих-мини ФРК.
    При пробитии чека данный аппарат периодически тормозит. При этом в форме регистрации продажи все элементы управления остаются активными. Продавцы нажимают ещё раз на кнопку продажи, и через некоторое время появляются два совершенно одинаковых чека. Естественно, продавцы данным фактом совершенно недовольны.
    Подскажите, пожалуйста, как избежать описанной ситуации.
    Заранее спасибо
  17. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    попробуй поиграть с драйверами фискальника...
    если старые..поищи новую версию..и наоборот...
  18. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    поддерживаю Dmitriy_76, можно попробовать переустановить драйвер (и/или установить более старый/новый). А Х-отчёт нормально печатается? п.с. может обработку из другого релиза взять (10.3.14... например)
  19. krotpk
    Offline

    krotpk

    Регистрация:
    23 июл 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Проблемма при подключении MStar TSP 700II к 1С v8.2 Розница. Драйвера установились коректно из родной программы настройки определяется и отчеты печатает. ОС Windows 7 х32. Не могу найти обработку подключения к 1С. Есть вроде атоловские в списке только аналог MSTAR-Ф - пробовал через него, выдает нет связис оборудованием. Атоловские утилитки при проверке говорят то же самое. версии Атоловских драйверов 6.х.
    Можете посоветовать что нибудь?
  20. krotpk
    Offline

    krotpk

    Регистрация:
    23 июл 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Вопрос снят... разобрались *)))
Статус темы:
Закрыта.

Поделиться этой страницей