7.7 ЭСЧФ в конфигурации с разделителем учета

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Maksim601, 2 дек 2016.

  1. TopicStarter Overlay
    Maksim601
    Offline

    Maksim601

    Регистрация:
    2 дек 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Есть конфигурация с разделителем учета. Дорабатывал программист, но кинул посреди дороги. Пришлось пробовать самому, но опыта и знаний... - очень мало в этом случае. Поэтому прошу сильно не пинать и помочь найти ошибку. Вот код журнала. При открытии журнала ошибок не выдает, но и списка документов по фирме тоже нет, хотя, если убираю лишнее по разделителю- общий журнал(все вместе) открывает... Добавлю, что дописывал код по образцу рабочих журналов документов
    Код:
    Перем СтатусыЭСЧФ;  
    Перем гСписокКолонок;
    Перем гИдФормы;
    Процедура ПриОткрытии() Далее
    Процедура ПриВыбореФирмы() Далее
    Процедура ПриНачалеВыбораЗначения(перЭлемент,перСтандарт) Далее
    
    //************************************************************************************************************
    Процедура ПриОткрытии()
     
        Форма.Заголовок(" ЭЛЕКТРОННЫЕ СЧЕТА ФАКТУРЫ ",0);
        глРаскрытиеОкна();
        ВидыОтбора("");
        ВыбФирма = глТекФирма;
        УстановитьОтбор("ФирмаЭСЧФ",ВыбрФирма.Код);
        глУстановитьВидимостьКолонок(Контекст, гИдФормы, гСписокКолонок, 1);
         
    КонецПроцедуры // ПриОткрытии()
    
    //************************************************************************************************************
    Процедура ПриВыбореФирмы()
     
        глТекФирма = ВыбрФирма;
        ЗаголовокСистемы(глТекФирма); 
        УстановитьОтбор("ФирмаЭСЧФ",ВыбрФирма.Код);
     
    КонецПроцедуры // ПриВыбореФирмы()
    //************************************************************************************************************
    Процедура ПриНачалеВыбораЗначения(перЭлемент,перСтандарт)
     
        Если перЭлемент = "ВыбрФирма" Тогда
            Если глСписокФирм.ВыбратьЗначение(ВыбрФирма,,,,1) = 1  Тогда
                глТекФирма = ВыбрФирма;
                ЗаголовокСистемы(глТекФирма);
                УстановитьОтбор("ФирмаЭСЧФ",ВыбрФирма.Код);
            КонецЕсли;
            СтандартОбработка = 0;
        КонецЕсли;
    
    КонецПроцедуры // ПриНачалеВыбораЗначения(перЭлемент,перСтандарт)
    //************************************************************************************************************
    Процедура ОткрытьОбработкуВыгрузки(Парам)
        НачДата = РабочаяДата();
        КонДата = РабочаяДата();
        Если ВвестиПериод(НачДата,КонДата,"За какой период выгружать документы?") = 1 Тогда     
            Конт = СоздатьОбъект("СписокЗначений");
            Конт.ДобавитьЗначение(НачДата);
            Конт.ДобавитьЗначение(КонДата);
            ОткрытьФорму("Обработка."+Парам,Конт);      
        КонецЕсли;                                        
    КонецПроцедуры
    
    Функция ПоказатьСтатусЭСЧФ()
        Если ТекущийДокумент.Выбран() = 1 Тогда
            СтатусСимв = "Ошибка статуса!";
            Поз =  СтатусыЭСЧФ.НайтиЗначение(ТекущийДокумент.СтатусЭСЧФ);
            Если Поз > 0 Тогда
                СтатусыЭСЧФ.ПолучитьЗначение(Поз,СтатусСимв);  
            КонецЕсли;
            Возврат СтатусСимв;
        КонецЕсли;
        Возврат "";
    КонецФункции  
    
    
    СтатусыЭСЧФ = СоздатьОбъект("СписокЗначений");
    СтатусыЭСЧФ.ДобавитьЗначение(0,"Новый");
    СтатусыЭСЧФ.ДобавитьЗначение(1,"Выгружен в XML");
    СтатусыЭСЧФ.ДобавитьЗначение(2,"Выставлен");
    
    гИдФормы    =    "Журнал_ЭлСчетФактуры_ФормаСписка";
    
    // Список колонок видимостью которых будем управлять
    гСписокКолонок = СоздатьОбъект("СписокЗначений");
    гСписокКолонок.ДобавитьЗначение("Тип","Тип");
    гСписокКолонок.ДобавитьЗначение("ДатаОперации","Дата операции");
    гСписокКолонок.ДобавитьЗначение("ДатаАннулирования","Дата аннулирования");
    гСписокКолонок.ДобавитьЗначение("тСтатус" ,"Статус");
    гСписокКолонок.ДобавитьЗначение("Контрагент" ,"Контрагент");
    гСписокКолонок.ДобавитьЗначение("ДокОснование"  ,"Док. основание");
    гСписокКолонок.ДобавитьЗначение("НДС"        ,"Сумма НДС");
    гСписокКолонок.ДобавитьЗначение("СуммаСНДС"  ,"Всего с НДС");
    
    Для а=1 по гСписокКолонок.РазмерСписка() Цикл
        гСписокКолонок.Пометка(а,    1);
    КонецЦикла;
    Последнее редактирование модератором: 5 дек 2016
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.642
    Симпатии:
    422
    Баллы:
    104
    тип журнала какой?
  3. TopicStarter Overlay
    Maksim601
    Offline

    Maksim601

    Регистрация:
    2 дек 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
Похожие темы
  1. mc_Joker
    Ответов:
    2
    Просмотров:
    988
  2. Ири$ка
    Ответов:
    2
    Просмотров:
    1.591
  3. subastian
    Ответов:
    5
    Просмотров:
    1.184
  4. Формат
    Ответов:
    0
    Просмотров:
    6.181
  5. Elenachka
    Ответов:
    2
    Просмотров:
    2.955
Загрузка...

Поделиться этой страницей