8.х Элементы отбора в журнале документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем diada1c, 25 авг 2009.

  1. TopicStarter Overlay
    diada1c
    Offline

    diada1c

    Регистрация:
    13 авг 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Существует документ "Заказ-наряд". Степень его готовности прописана в регистре сведений
    Измерения
    Заказ-наряд - ссылка на документ
    Ресурсы
    Состояние - справочник "Состояние", у которого несколько предопределенных элементов, и несколько введенных вручную

    Необходимо в журнале документов при желании скрыть/отобразить те документы, у которых Состояние - предопределенный элемент "Готов".
  2. TopicStarter Overlay
    diada1c
    Offline

    diada1c

    Регистрация:
    13 авг 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Или как с журнале документов скрыть документ

    Процедура ЖурналДокументовСписокПриПолученииДанных(Элемент, ОформленияСтрок)

    Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    Состояние = Неопределено;
    НайденнаяСтрока = НарядСостояние.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "ЗаказНаряд");
    Если НайденнаяСтрока <> Неопределено Тогда
    Состояние = НайденнаяСтрока.Событие;
    КонецЕсли;

    Если СкрыватьВыданные И Состояние = Справочники.События.Выдан Тогда
    // здесь нужен текст, чтобы скрыть эту строку
    КонецЕсли;

    КонецЦикла;

    КонецПроцедуры

    Где НарядСостояние - ТаблицаЗначений из регистра сведений
    СкрыватьВыданные - булево

Поделиться этой страницей