8.х Экспорт в Excel ТЧ документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Tasya, 29 май 2014.

  1. TopicStarter Overlay
    Tasya
    Offline

    Tasya Опытный в 1С

    Регистрация:
    9 сен 2013
    Сообщения:
    148
    Симпатии:
    3
    Баллы:
    29
    Добрый день!
    1С Предприятие 8.2
    В модуле документа есть процедура, которая выгружает ТЧ в Excel и сохраняет файл на диске.

    Код:
    &НаСервере
       Процедура СоздатьExcel()
                Excel = Новый COMОбъект("Excel.Application");
                Книга = Excel.WorkBooks.Add();
                Лист = Книга.WorkSheets(1);
                НомерСтроки = 0;
     
         Для каждого Строка Из Объект.ЗакупкаНоменклатуры Цикл
                НомерСтроки = НомерСтроки + 1;
                Лист.Cells(НомерСтроки, 1).Value = Строка(Строка.Номенклатура);
                Лист.Cells(НомерСтроки, 2).Value = Строка(Строка.Количество);
          КонецЦикла;
      
         Книга.SaveAs("C:\Номенклатура.xls");
    КонецПроцедуры

    Выдает ошибку:
    {Документ.itilprofЗапросыНаИзменения.Форма.ФормаДокумента.Форма(40)}: Ошибка при вызове конструктора (COMОбъект): No such interface supported: No such interface supported

    В чем может быть проблема?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.984
    Симпатии:
    398
    Баллы:
    104
    Ексель установлен на компе?
  3. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.438
    Симпатии:
    373
    Баллы:
    104
    -"Не поддерживается такой интерфейс: не поддерживается такой интерфейс"
    а мелкософтовский эксель стоит на данном компе?
  4. TopicStarter Overlay
    Tasya
    Offline

    Tasya Опытный в 1С

    Регистрация:
    9 сен 2013
    Сообщения:
    148
    Симпатии:
    3
    Баллы:
    29
    на компе, где установлен клиент (в котором формируется документ - Да), на самом сервере - нет
  5. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.984
    Симпатии:
    398
    Баллы:
    104
    Вот установите тогда на сервер. Компилятор же на сервере работает.
  6. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    такой простой вопрос к ТС - а нафига долбиться в Excel с такими простейшими выводами документов, если можно сделать обычный табличный документ и записать его в файл в формате Excel?
  7. TopicStarter Overlay
    Tasya
    Offline

    Tasya Опытный в 1С

    Регистрация:
    9 сен 2013
    Сообщения:
    148
    Симпатии:
    3
    Баллы:
    29
    спасибо за ответы. Пока согласовывала установку офиса на сервер, решила попробовать создавать excel на клиенте и прикреплять к документу.

    Код:
    &НаКлиенте
    Процедура СоздатьExcel()
        Попытка
       
        Excel = Новый COMОбъект("Excel.Application");
        Книга = Excel.WorkBooks.Add();
        Лист = Книга.WorkSheets(1);
        НомерСтроки = 0;
        Для каждого Строка Из Объект.ЗакупкаНоменклатуры Цикл
            НомерСтроки = НомерСтроки + 1;
            Лист.Cells(НомерСтроки, 1).Value = Строка(Строка.Номенклатура);
            Лист.Cells(НомерСтроки, 2).Value = Строка(Строка.Количество);
        КонецЦикла;
       
           
            Книга.SaveAs("C:\Номенклатура.xlsx");
    
        исключение
               
               Сообщить(ОписаниеОшибки());
              
           КонецПопытки;
          
          
          Excel.Application.Quit();
      
    КонецПроцедуры
    
    В тонком/толстом клиентах все работает, в веб-клиенте выдает ошибку:
    Ошибка при вызове конструктора (ComObject):Невозможно создание объекта сервером программирования объектов
    --- Объединение сообщений, 3 июн 2014 ---
    Попробую, а вы могли бы написать строчку кода с записью табличного документа в формате excel?
    Последнее редактирование: 3 июн 2014
  8. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    ТабДок.Записать(ИмяФайла, ТипФайлаТабличногоДокумента.XLS);
  9. TopicStarter Overlay
    Tasya
    Offline

    Tasya Опытный в 1С

    Регистрация:
    9 сен 2013
    Сообщения:
    148
    Симпатии:
    3
    Баллы:
    29
    С табличным документом ранее не работала. А можно ли без Макета его создать? Просто пройтись по табличной части циклом и вставить туда строки?
  10. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    да, можно, но с макетом жить проще

Поделиться этой страницей