8.х Экспорт данных в Excel

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем steach, 16 авг 2007.

  1. TopicStarter Overlay
    steach
    Offline

    steach

    Регистрация:
    16 авг 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Я не профессионал в программировании 1С, но начинаю только изучать. сейчас стоит задача выгрузить определенные документы в определнном формате в Эксель, подскажите пожалуйсто как это сделать, если можно то подробно, потому что программированием я не занимался вообще. Выгрузить необходимо Остатки на складе, Заказы клиентов, Реализацию, Номенклатуру, Контрагентов. С указанием периода выгрузки. Зарание спасибо.
  2. sergey
    Offline

    sergey Курильщик

    Регистрация:
    13 апр 2006
    Сообщения:
    365
    Симпатии:
    0
    Баллы:
    26
    После вывода печатной формы отчета:
    Файл>Сохранить как>Выбрать "Таблица Excel">Сохранить
  3. Prospero
    Offline

    Prospero Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    111
    Симпатии:
    0
    Баллы:
    26
    Наверное, человек имеет ввиду выгрузку программно :)
    Steach, задействуй поиск - тут не раз импорт-экспорт с участием Экселя пробегал...
    Если что - пиши в личку - мож чем и помогу на общественных началах :)
  4. TopicStarter Overlay
    steach
    Offline

    steach

    Регистрация:
    16 авг 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1

    Вот именно что программно, сразу группу документов. Поиск пробовал, мало что дал.
  5. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26
    Эксель = Новый COMОбъект("Excel.Application");
    Исключение
    Возврат;
    КонецПопытки;
    templ="C:\Documents and Settings\A_Voronov\Рабочий стол\Баланс2.xls";
    Книга=Эксель.Workbooks.Open(templ);
    ТекЛист=Книга.WorkSheets(1);

    ТекЛист.Cells(2,14).Value = ПредставлениеПериода(ПериодС, КонецДня(ПериодПо));
    к = 8;
    Пока Выборка.Следующий() цикл
    к = к+1;
    ТекЛист.Cells(к,1).Value = Выборка.Источник; // данный параметр не передается (ошибка Value)
    Если Выборка.Пар=0 Тогда
    ТекЛист.Cells(к,3).Value = Null;
    Иначе
    ТекЛист.Cells(к,3).Value = Выборка.Пар;
    КонецЕсли;
    Если Выборка.Вода=0 Тогда
    ТекЛист.Cells(к,7).Value = Null;
    Иначе
    ТекЛист.Cells(к,7).Value = Выборка.Вода;
    КонецЕсли;
    Если Выборка.Промывка=0 Тогда
    ТекЛист.Cells(к,12).Value = Null;
    Иначе
    ТекЛист.Cells(к,12).Value = Выборка.Промывка;
    КонецЕсли;
    Если Выборка.ГВС=0 Тогда
    ТекЛист.Cells(к,11).Value = Null;
    Иначе
    ТекЛист.Cells(к,11).Value = Выборка.ГВС;
    КонецЕсли;
    Если Выборка.Отопление=0 Тогда
    ТекЛист.Cells(к,16).Value = Null;
    Иначе
    ТекЛист.Cells(к,16).Value = Выборка.Отопление;
    КонецЕсли;
    Если Выборка.Вентиляция=0 Тогда
    ТекЛист.Cells(к,17).Value = Null;
    Иначе
    ТекЛист.Cells(к,17).Value = Выборка.Вентиляция;
    КонецЕсли;
    Если Выборка.Потери=0 Тогда
    ТекЛист.Cells(к,18).Value = Null;
    Иначе
    ТекЛист.Cells(к,18).Value = Выборка.Потери;
    КонецЕсли;

    КонецЦикла;
    Эксель.Visible = Истина;
    http://www.1c-pro.ru/index.php?showtopic=4852&hl=Excel
  6. TopicStarter Overlay
    steach
    Offline

    steach

    Регистрация:
    16 авг 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1

    Спасибо попробовал твою обработку, ошибка на ошибке, дело в том что у нас конфигурации разные, у меня Управление Торговлей 10.2

Поделиться этой страницей