8.х ОБМЕН Двусторонний обмен данными УТ 10.3.18.3 и БП 2.0.36.4

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем aids, 18 июн 2012.

  1. TopicStarter Overlay
    aids
    Offline

    aids

    Регистрация:
    16 авг 2007
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Добрый день!​

    1 С начала все операции велись в БП.

    2 Требуется ввести в эксплуатацию УТ с историей, которая была занесена в БП

    3 Учет ведется по Подразделениям и Складам


    4 При обмене документами УТ с БП - из БП в документе "Требование-накладная" нет подразделения, поле приходит пустым.

    Вопрос: где и что в правилах обмена надо исправить для переноса полного документа "Требование накладная"?

    ps: Обмен настраивался в УТ, через Сервис - Обмен с "Бухгалтерия предприятия, редакция 2.0".


    В правилах обмена УТ>БП есть​

    Код:
       Если Не ЗначениеЗаполнено(ПараметрСклад) Тогда
    ПодразделениеВозврат = Справочники.ПодразделенияОрганизаций.ПустаяСсылка();
    КонецЕсли;
    
    Если Не ЗначениеЗаполнено(ПараметрОрганизация) Тогда
    ПодразделениеВозврат = ПараметрСклад.ПодразделениеОрганизации;
    КонецЕсли;
    
    ПодразделениеОрганизации = ПараметрСклад.ПодразделениеОрганизации;
    
    Если ПодразделениеОрганизации.Владелец = ПараметрОрганизация Тогда
    ПодразделениеВозврат = ПодразделениеОрганизации;
    Иначе
    ПодразделениеВозврат = Справочники.ПодразделенияОрганизаций.ПустаяСсылка();
    КонецЕсли;
    но нет подобного в правилах обмена БП>УТ,

    Так же есть следующий нюанс, в БП в документе "Требование-накладная" Подразделение является не отдельным реквизитом, а Субконто1, которое зависит от счета затрат[​IMG]

Поделиться этой страницей