8.х Движения документа в регистре сведений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем has, 8 июл 2010.

  1. TopicStarter Overlay
    has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Не выспался из-за футбола, торможу. Вобщем есть документ, который делает движения в регистр сведений. В обработке проведения хочу получить движения этого документа. Делал и набором записей и запросом, в котором ссылку передавал. Выгружаю в таблицу значений, а она пуста. При это в консоле запросов результат выдает. Т.е. движений уже у проведенного документа при повторном проведении получается нет. Объясните мне-тормозу почему так?
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Давайте Ваш код, глянем. Не одни Вы футбол смотрели. Сейчас сижу с банкой энергетика и собираюсь с мыслями
  3. TopicStarter Overlay
    has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    весь код процедур не привожу, но суть думаю ясна
    Код:
    Процедура ОбработкаПроведения(Отказ, РежимПроведения)
    
    //проверим была ли корректировка движений
    ПроверкаНаличияКорректировкиВДвижениях(Отказ);
    
    //проведем документ
    Если Не Отказ Тогда
    ДвижениеПоРегистрам(Отказ);
    КонецЕсли;
    КонецПроцедуры
    
    
    
    
    Код:
    Процедура ПроверкаНаличияКорректировкиВДвижениях(Отказ)
    //проверим, была ли корректировка
    НаборЗаписей = РегистрыСведений.ПланПродажУДМ.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Регистратор.Установить(Ссылка);
    НаборЗаписей.Прочитать();
    ТаблицаДвижений =  НаборЗаписей.Выгрузить(); //таблица пустая получается
    КорректированнаяСтрокаРегистра = ТаблицаДвижений.Найти(Истина,"Корректирован");
    Если Не КорректированнаяСтрокаРегистра = Неопределено Тогда
    Отказ = Истина;
    Сообщить("По документу уже была выполнена корректировка!");
    КонецЕсли;
    КонецПроцедуры
    
    
    
    
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    У вас у этого документа в свойствах движения стоит : Удалять автоматически?
  5. TopicStarter Overlay
    has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Ааааа, вот черт :unsure:
    Спасибо, я сразу и не сообразил. Неужели в понедельник после финала также буду ...
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Все зависит от того, с кем и где смотреть, а то понедльника может вовсе не быть
  7. TopicStarter Overlay
    has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    3 раза прочитал, не понял смысла фразы :)
Похожие темы
  1. MrShvets
    Ответов:
    10
    Просмотров:
    1.522
Загрузка...

Поделиться этой страницей