8.х Доступность вкладки на управляемой форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем skv_79, 13 дек 2015.

  1. TopicStarter Overlay
    skv_79
    Offline

    skv_79 Опытный в 1С

    Регистрация:
    10 июл 2013
    Сообщения:
    206
    Симпатии:
    3
    Баллы:
    29
    Здравствуйте!
    При обработке определенных реквизитов срабатывает обработчик ПриИзменении и изменяет Доступность вкладки Билеты но на форме она все равно остается недоступной. Подскажите, может нужно обновить форму или еще что..
    Код:
    &НаСервере
    Процедура ПроверкаКатегорииНаСервере(Категория)
        Если (Категория = Справочники.Категории.НайтиПоНаименованию("1.7"))
            ИЛИ (Категория = Справочники.Категории.НайтиПоНаименованию("2.5"))
            Тогда
                ЭтаФорма.Элементы.Билеты.Доступность = Истина;
            КонецЕсли;
    КонецПроцедуры;
  2. SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Код:
    &НаКлиенте
    Процедура ПриИзмененииПроверкаКатегории()
    ПроверкаКатегорииНаСервере(Категория);
    КонецПроцедуры;
    
    &НаСервере
    Процедура ПроверкаКатегорииНаСервере(Категория)
    Если Категория = Справочники.Категории.НайтиПоНаименованию("1.7") ИЛИ Категория = Справочники.Категории.НайтиПоНаименованию("2.5") Тогда
    Элементы.Билеты.Доступность = Истина;
    Иначе
    Элементы.Билеты.Доступность = Ложь;
    КонецЕсли;
    КонецПроцедуры;
    Может так ?

    Если обновлять форму реквизиты и.т.д, можно добавить..,на клиенте разумеется..
    Типа:
    Код:
    Элементы.Билеты.Прочитать();
    ЭтаФорма.ОбновитьОтображениеДанных();
    Обновить() - Обновляет данные в таблице.

    Прочитать() - Обновляет объект управляемой формы.

    ОбновитьОтображениеДанных() - В принудительном порядке обновляет содержание элементов управления. Полезен при изменении значений реквизитов формы вне формы, в тот момент, когда форма отображается на экране.
    Последнее редактирование: 13 дек 2015

Поделиться этой страницей