8.х Доступность строки в ТЧ.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем zayaroslava, 27 май 2010.

  1. TopicStarter Overlay
    zayaroslava
    Offline

    zayaroslava Опытный в 1С

    Регистрация:
    27 янв 2010
    Сообщения:
    329
    Симпатии:
    1
    Баллы:
    26
    Подскажите,а можно ли в ТЧ строку сделать недоступной для редактирования.
    Например для ПоляВВода есть св-ва Доступность,а для строки в ТЧ можно ли применить доступность?
    Задача заключается в том,чтобы после добавления строки в ТЧ,строка становилась не доступная для редактирования.
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Используйте обработчик табличной части "ПриНачалеРедактирования"
    Код:
    Процедура ТабличнаяЧастьПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если Не НоваяСтрока Тогда
    Отказ = Истина;
    КонецЕсли;
    КонецПроцедуры
    
    
    Хотя не дочитал. Так работать не будет :(

    Описание:
    Возникает при начале редактирования старой или добавленной строки табличного поля. В процедуре - обработчике события нельзя отказаться от редактирования, но могут быть выполнены действия, необходимые при вводе новой строки, например, установка начальных значений
  3. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Пробуйте так:
    Код:
    Процедура ТабличнаяЧастьПередНачаломИзменения(Элемент, Отказ)
    Отказ = Истина;
    КонецПроцедуры
    
  4. TopicStarter Overlay
    zayaroslava
    Offline

    zayaroslava Опытный в 1С

    Регистрация:
    27 янв 2010
    Сообщения:
    329
    Симпатии:
    1
    Баллы:
    26
    Спасибо,Работает =)!

Поделиться этой страницей