8.х Доступность элемента формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем zelevova, 30 ноя 2006.

  1. TopicStarter Overlay
    zelevova
    Offline

    zelevova

    Регистрация:
    13 ноя 2006
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Задача следующая:
    В документе есть реквизит "Реквизит1", нужно при открытии документа если есть основание, то делать реквизит1 недоступным для изменения.

    Я пробую так:
    Код:
    Процедура ПриОткрытии()
    Если ДокументОснование.Пустая() Тогда
    Реквизит1.Доступность(0);
    КонецЕсли;
    КонецПроцедуры
    
    Где ДокументОснование это реквизит типа Ссылка. Не получается. Ругается на "Пустая()". Кто что посоветует?
  2. Неглупый
    Offline

    Неглупый

    Регистрация:
    23 окт 2006
    Сообщения:
    29
    Симпатии:
    1
    Баллы:
    1
    что имено ругается?
  3. Неглупый
    Offline

    Неглупый

    Регистрация:
    23 окт 2006
    Сообщения:
    29
    Симпатии:
    1
    Баллы:
    1
    Пустая() действует только для конкретного типа
    У тебя ДокументОснование составной тип?

    Если да то

    Если ДокументОснование = Неопределено Тогда

    КонецЕсли;
  4. TopicStarter Overlay
    zelevova
    Offline

    zelevova

    Регистрация:
    13 ноя 2006
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо.

Поделиться этой страницей