8.х Доступ на установку пометки удаления

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем adminus, 24 сен 2010.

  1. TopicStarter Overlay
    adminus
    Offline

    adminus

    Регистрация:
    15 сен 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    В документе есть реквизит логического значения ЗаявкаУтверждена. Если значение реквизита Истина, то документ блокируется для редактирования(для этого элементам формы я задала доступность=Ложь, возможно это надо было по-другому сделать). В списке документов эти утвержденные документы надо сделать недоступными для установки пометки удаления. Как это сделать?
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.552
    Симпатии:
    716
    Баллы:
    204
    Обработчика события "пометки удаления" у объектов нет, видимо не реализуемо, либо реализуемо, но шибко через Ж получится.
  3. TopicStarter Overlay
    adminus
    Offline

    adminus

    Регистрация:
    15 сен 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    может к роли пользователя привязаться? если это возможно, то как реализовать?
  4. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.552
    Симпатии:
    716
    Баллы:
    204
    толку от привязыывания к роли нет, т.к. невозможно отследить сам момент установки/снятия пометки удаления
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    Может добавить какое условие в процедуру?
  6. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.552
    Симпатии:
    716
    Баллы:
    204
    если "ПередЗаписью", то видимо в него, и рулим ОТКАЗом....

    Типа такого:

    Если ПометкаУдаления И НЕ РольДоступна("ПолныеПрава") Тогда
    Отказ = Истина;
    КонецЕсли;
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    Я к этому и клонил:)
  8. TopicStarter Overlay
    adminus
    Offline

    adminus

    Регистрация:
    15 сен 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Где процедуру написать вроде определилась, а вот как обратиться к реквизиту текущего документа не знаю( реквизит УтверждениеЗаяки):


    Процедура ДокументСписокПередУстановкойПометкиУдаления(Элемент, Отказ)

    Если "УтверждениеЗаявки" И НЕ РольДоступна("ПолныеПрава") Тогда
    Отказ = Истина;
    КонецЕсли;

    КонецПроцедуры
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    Попробуйте так:
    ЭтотОбъект.УтверждениеЗаявки
  10. Gulnaz
    Offline

    Gulnaz Опытный в 1С

    Регистрация:
    20 сен 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Так пишет, что переменная ЭтотОбъект не определена
  11. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    А вы в модуле документа это прописываете? Реквизит УтверждениеЗаявки есть, или вы просто на форме галку разместили?
  12. Gulnaz
    Offline

    Gulnaz Опытный в 1С

    Регистрация:
    20 сен 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Да, в модуле документа есть этот реквизит.
  13. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    В отладчике посмотрите значение этого реквизита. Что-то у меня сомнения по вашему вопросу:(
  14. Gulnaz
    Offline

    Gulnaz Опытный в 1С

    Регистрация:
    20 сен 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26

    Получилось!!! :angry:
    Доступ к ревзиту получила так:

    Если ЭлементыФормы.ДокументСписок.ТекущаяСтрока.Ссылка.УтверждениеЗаявки
    И НЕ РольДоступна ("ПолныеПрава")
    Тогда
    Отказ = Истина;
    КонецЕсли;

Поделиться этой страницей