7.7 Доработка отчета "продажи"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Vikras, 31 мар 2017.

  1. TopicStarter Overlay
    Vikras
    Offline

    Vikras

    Регистрация:
    31 мар 2017
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Как правильно добавить в отчет Цену прихода из приходной накладной?
    Пробовал вписать в запрос:
    |Цена0 = Документ.ПриходнаяНакладная.Цена0;
    Но после формирования отчета,цена прихода у каждого товара равна нулю.

    [​IMG]
    Код:
    Процедура Очистить()
      ВыбТовар=0;
    КонецПроцедуры
    
    Процедура Сформировать()
     
        Перем Запрос,Флаг;
        Ном=0;
        ИтогСумма=0;
        Запрос=СоздатьОбъект("Запрос");
     
        Флаг = Запрос.Выполнить("
        |Период с ДатаНач по ДатаКон;
        |Товар = Документ.РасходнаяНакладная.Товар;
        |Количество = Документ.РасходнаяНакладная.Колич;
        |Сумма = Документ.РасходнаяНакладная.Сумма;
        |Фирма = Документ.РасходнаяНакладная.Фирма;
        |Группировка Товар упорядочить по Товар.Наименование;
        |Условие (Фирма=ВыбФ);
        |Функция ИтСум=Расход(Сумма);
        |Функция ИтКол=Расход(Количество);
        |");
        Если Флаг = 0 Тогда
            Возврат;
        КонецЕсли;
        Таб=СоздатьОбъект("Таблица");
        Таб.ВывестиСекцию("Отчет");
            Пока Запрос.Группировка("Товар")=1 Цикл
                Если Запрос.ИтКол <>0 Тогда
                ИтогСумма=ИтогСумма+Запрос.ИтСум;
                Ном=Ном+1;
                СрЦена=Формат(Запрос.ИтСум/Запрос.ИтКол,"Ч17.2");
                Таб.ВывестиСекцию("Строка");
                КонецЕсли;
            КонецЦикла;
        Таб.ВывестиСекцию("Подвал");
        Таб.Опции(0,0,0,0);
        Таб.Показать("","");
         
    КонецПроцедуры
    
    Процедура ПриОткрытии()
        ДатаНач=ДобавитьМесяц(ТекущаяДата(),-1);
        ДатаКон=ТекущаяДата();
    КонецПроцедуры
    
    Последнее редактирование: 31 мар 2017
  2. man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    241
    Симпатии:
    11
    Баллы:
    29
    Сомневаюсь что в Документе ПоступлениеТМЦ есть Цена0!!!
    У товара есть БазовыйТипЦен, его и наверное и надо использовать, если нужно последнюю цену.
  3. TopicStarter Overlay
    Vikras
    Offline

    Vikras

    Регистрация:
    31 мар 2017
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    [​IMG]
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    Создавайте отдельный запрос. Его результат в ТЗ. При выводе строки отчета ищем в ТЗ
  5. man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    241
    Симпатии:
    11
    Баллы:
    29
    Что здесь означают Цена1 и Цена0 ?
    Код:
        |Товар1 = Документ.ПриходнаяНакладная.Товар;
        |Количество1 = Документ.ПриходнаяНакладная.Колич;
        |Сумма1 = Документ.ПриходнаяНакладная.Сумма;
    
    Дальше типа этого:
    Код:
    Пока Товар = Товар1 Цикл
    ................
    Цена = Запрос.Сумма1/Запрос.Количество1;
    ................
    КонецЦикла;
    Только товар может не попасть в отчет из-за периода (может не было поступления) или еще по какой причине!