7.7 Доработка отчета Инвентаризационная опись

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем spartak_lp, 1 фев 2012.

  1. TopicStarter Overlay
    spartak_lp
    Offline

    spartak_lp Опытный в 1С

    Регистрация:
    3 окт 2011
    Сообщения:
    201
    Симпатии:
    0
    Баллы:
    26
    Здраствуйте! Вопрос один возник по отчету "Инвентаризационная опись". Попросили добавить туда в закладку "ТМЦ на местах хранения" счет МЦ.04. Я добавил в конфигураторе строку рис.1 (выделена). Через предприятие запускаю, если в фильтре не выбраны места хранения и МОЛ, то выводит весь список верно в отчете, но пробую выбрать конкретного МОЛ, то выдает сообщение рис.2, фильтр не срабатывает, но на данном МОЛе и счете, через ОСВ по счету посмотрев, числятся вещи. Что-то в модуле отчета важное может не добавил еще?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Тут как минимум еще МДшник нужен, что бы анализировать

    (или информация о конфигурации и релизе)
  3. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    там есть такие строки

    Код:
       Пока Склады.ПолучитьЭлемент() = 1 Цикл
    Если Склады.МОЛ = ВыбМОЛСклада Тогда
    ВыбСклад = Склады.ТекущийЭлемент();
    ВидСубконто = ВидыСубконто.МестаХранения;
    КонецЕсли;
    КонецЦикла;
    вывод: ВыбСклад = Склады.ТекущийЭлемент(); - последний в списке складов, и по нему нэт остаков

    в процедуре сформировать замени кусок кода на ето

    Код:
    //ВыбСклад="";
    ВыбСклад = СоздатьОбъект("СписокЗначений");
    ВидСубконто = "";
    Если Склад.Выбран() = 1 Тогда
    ВыбСклад.ДобавитьЗначение(Склад);
    ВидСубконто = ВидыСубконто.МестаХранения;
    
    ИначеЕсли ВыбМОЛСклада.Выбран() = 1 Тогда
    Склады = СоздатьОбъект("Справочник.МестаХранения");
    Склады.ВыбратьЭлементы();
    Пока Склады.ПолучитьЭлемент() = 1 Цикл
    Если Склады.МОЛ = ВыбМОЛСклада Тогда
    //  ВыбСклад = Склады.ТекущийЭлемент();
    ВыбСклад.ДобавитьЗначение(Склады.ТекущийЭлемент());
    ВидСубконто = ВидыСубконто.МестаХранения;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
  4. TopicStarter Overlay
    spartak_lp
    Offline

    spartak_lp Опытный в 1С

    Регистрация:
    3 окт 2011
    Сообщения:
    201
    Симпатии:
    0
    Баллы:
    26
    WaRDeR, Конфигурация Бухгалтерия 7.70.484 MDшник не получается прикрепить, т.к. не разрешает больше 1Мб файлы, мог бы на мэйл скинуть.
    Хряк, в процедуре "сформировать" изменил код, но результат такой же остался: выдает сообщение как на Рис. 2. по любому складу причем так.

Поделиться этой страницей