Работа Доработка обработки выгрузки в VirtueMart из 1С

Тема в разделе "Архив", создана пользователем setqa, 9 дек 2011.

  1. TopicStarter Overlay
    setqa
    Offline

    setqa

    Регистрация:
    26 окт 2010
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Кто сможет Помочь?

    Контакт
    ICQ 6880010

    Требуется знания

    Virtuemart+MySQL
    подключение к БД через ODBC

    Есть обработка выгрузки Номенклатур в VirtueMart

    Не выгружаются Типы Товаров при создании БОЛЕЕ 1 вида Типа товаров
    выдает ошибку
    вроде
    Код:
    Процедура Кнопка6Нажатие(Элемент)
    // Вставить содержимое обработчика.
    СтрокаСоединения();
    
    Connection = Новый COMОбъект("ADODB.Connection");
    Попытка
    Connection.Open(СтрПодключения);
    Исключение
    Предупреждение("Ошибка соединения с БД");
    Возврат;
    КонецПопытки;	
    
    RS = Новый COMОбъект("ADODB.Recordset");
    RSIDProduct = Новый COMОбъект("ADODB.Recordset");
    Command = Новый COMОбъект ("ADODB.Command");
    Command.ActiveConnection = Connection;
    
    
    
    ТипыТОваров.Очистить();
    ПараметрыТипов.Очистить();
    query = "
    |SELECT *
    |FROM "+Префикс+"_vm_product_type";
    RS.Open(query, Connection);
    //	Попытка
    RS.MoveFirst();
    Пока RS.EOF() = 0 Цикл
    НС = ТипыТОваров.Добавить();
    НС.ТипТовара = RS.Fields("product_type_name").Value;
    НС.ИД = RS.Fields("product_type_id").Value;
    RS.MoveNext();
    query = "
    |SELECT *
    |FROM "+Префикс+"_vm_product_type_parameter WHERE product_type_id='"+НС.ИД+"'";
    RSIDProduct.Open(query, Connection);
    Попытка
    RSIDProduct.MoveFirst();
    Пока RSIDProduct.EOF() = 0 Цикл
    НС = ПараметрыТипов.Добавить();
    НС.Параметр = RSIDProduct.Fields("parameter_name").Value;
    НС.ИД = RSIDProduct.Fields("product_type_id").Value;
    RSIDProduct.MoveNext();
    КонецЦикла;
    Исключение
    
    КонецПопытки;	
    
    
    КонецЦикла;
    RS.Close();
    //Исключение
    //	
    //КонецПопытки;	
    //ЭлементыФормы.ТипыТОваров.Значение = ТипыТОваров;
    //ЭлементыФормы.ТипыТОваров.СоздатьКолонки();
    //
    //ЭлементыФормы.ПараметрыТипов.Значение = ПараметрыТипов;
    //ЭлементыФормы.ПараметрыТипов.СоздатьКолонки();
    //
    
    КонецПроцедуры
    
  2. TopicStarter Overlay
    setqa
    Offline

    setqa

    Регистрация:
    26 окт 2010
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    решено, вроде)

Поделиться этой страницей