8.х Дополнительные реквизиты в типовой операции БГУ2.0

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Александр 1906, 28 сен 2015.

  1. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    Подскажите пожалуйста дополнительные реквизиты которые создаются в режиме "Предприятия" в типовых операциях, можно ли их найти где нибудь в конфигураторе или может быть существуют функции для их получения?
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    Нет, функций для их получения нет и в конфигурации вы их не найдете.
    Их и их значения можно видеть в списке доп. свойств наряду с другими в режиме предприятия.
  3. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    а как же быть, если во ВПФ нужно добавить значение этого реквизита?
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    Программировать ВПФ под реалии.
  5. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    вы не сталкивались с функцией КПССчета(Организация, ИФО = Неопределено, КФО, Период, Счет)? можно через нее получить кпс кредита?
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    Если посмотрите внутрь функции, то сами все узнаете.
  7. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    буду смотреть
  8. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    не могу понять почему не работает эта функция, она не выдает ошибку ну и не его не выводит
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Отладчик прыгает туда ?
  10. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    да
    --- Объединение сообщений, 28 сен 2015 ---
    в этой функции есть маленький запрос вот при его выполнении пишет ошибка чтения знаений
    --- Объединение сообщений, 28 сен 2015 ---

    Код:
    Функция КПССчета(Организация, Знач ИФО = Неопределено, КФО, Период, Счет, ВидПоказателя = Неопределено) Экспорт
     
        Если НЕ ПолучитьФункциональнуюОпцию("ИспользоватьУчетПоИФО") Тогда
            ИФО = Справочники.ИсточникиФинансовогоОбеспечения.ПустаяСсылка();
        КонецЕсли;
     
        Запрос = Новый Запрос(    "ВЫБРАТЬ ПЕРВЫЕ 1
                                |    РабочиеСчетаСрезПоследних.КПС
                                |ИЗ
                                |    РегистрСведений.РабочиеСчета.СрезПоследних(
                                |            &Период,
                                |            Актуален = ИСТИНА
                                |                И Организация = &Организация
                                |                И КФО = &КФО
                                |                И Счет = &Счет
                                |                <ВидПоказателя>
                                |                И &УсловиеИФО) КАК РабочиеСчетаСрезПоследних");
     
        Запрос.УстановитьПараметр("Период",         Период);
        Запрос.УстановитьПараметр("Организация",    Организация);
        Запрос.УстановитьПараметр("КФО",             КФО);
        Запрос.УстановитьПараметр("Счет",             Счет);
     
        Если ЗначениеЗаполнено(ИФО) Тогда
         
            Запрос.Текст = СтрЗаменить(Запрос.Текст, "&УсловиеИФО", "ИФО = &ИФО");
         
            Запрос.УстановитьПараметр("ИФО",         ИФО);
         
        Иначе
         
            Запрос.УстановитьПараметр("УсловиеИФО", Истина);
         
        КонецЕсли;
     
        Если ВидПоказателя = Неопределено Тогда
            ВидПоказателяТекст = "";
        Иначе
            ВидПоказателяТекст = "И КПС.ВидПоказателя В (&ВидПоказателя)";
            Если ТипЗнч(ВидПоказателя) = Тип("ПеречислениеСсылка.ВидыКБК") Тогда
                // Указано одно значение.
                ЗначениеПараметраВидПоказателя = ВидПоказателя;
             
            ИначеЕсли ТипЗнч(ВидПоказателя) = Тип("Структура") Тогда
                // Указано несколько значений.
                ЗначениеПараметраВидПоказателя = Новый Массив();
                Для Каждого Элем Из ВидПоказателя Цикл
                    ЗначениеПараметраВидПоказателя.Добавить(Элем.Значение);
                КонецЦикла;
             
            Иначе
                ЗначениеПараметраВидПоказателя = Неопределено;
            КонецЕсли;
            Запрос.УстановитьПараметр("ВидПоказателя", ЗначениеПараметраВидПоказателя);
         
        КонецЕсли;
        Запрос.Текст = СтрЗаменить(Запрос.Текст, "<ВидПоказателя>", ВидПоказателяТекст);
     
        Выборка = Запрос.Выполнить().Выбрать();
     
        Если Выборка.Следующий() Тогда
         
            Возврат Выборка.КПС;
         
        Иначе
         
            Возврат Справочники.КлассификационныеПризнакиСчетов.ПустаяСсылка();
         
        КонецЕсли;   
     
    КонецФункции
    --- Объединение сообщений, 28 сен 2015 ---
    не могу понять почему не работает
    Последнее редактирование модератором: 29 сен 2015
  11. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    Если ошибок нет, то все работает.
  12. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    значит просто возвращается пустая ссылка
  13. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    алгоритм, приведенный вами, верный, что вы от нас ждете?
  14. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    так как я чайник скажите эта функция предназначена для получения кпс счета?
  15. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    Да, эта функция для получения КПС счета.
  16. TopicStarter Overlay
    Александр 1906
    Offline

    Александр 1906 Опытный в 1С

    Регистрация:
    25 июн 2015
    Сообщения:
    351
    Симпатии:
    3
    Баллы:
    29
    наверное с параметрами накосячил

Поделиться этой страницей