8.х Дополнительная колонка печатных форм документов

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем ofautumn, 28 май 2014.

  1. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Всем добрый день! Бухгалтерия для Казахстана, редакция 2.0, разработка для Казахстана: «1С-Рейтинг» (2.0.14.10). Проблема следующая в печатной форме "Поступление ТМЗ" не выводится колонка артикул, выходит номенклатурный номер. Пробовал менять через Операции--->Константы--->Настройки параметров учета, далее вкладка "Печать" выбираю артикул вместо номенклатурного номера, но на печатной форме это не выводится, не подскажете почему?
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Трудно сказать, у Вас специфическая конфигурация... Можно написать/заказать ВПФ под Ваши нужды
  3. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Разобрался, оказывается эта настройка не влияет на эту печатную форму :) Сейчас поправил вручную, добавил на печатную форму колонку артикул, вот теперь вопрос, а можно ли самому вносить изменения в общие макеты? Не придереться ли потом кто?
  4. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    хм, смотря какие изменения... Должно быть согласовано с вашими бух-рами, и насколько помню там можно вернуться(откатиться) к первоначальному макету
    зы: если изменения в режиме Предприятия делались
  5. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Так, ребята, возникла идея, добавить еще одну печатную форму, старую оставить и еще одну с артиклулом, теперь вопрос, как добавить печатную форму в писок выбора? По кнопке печать выходит Приходная накладная и Приходный ордер запасов. Как в список выбора добавить еще " Приходный ордер запасов ( с артикулом)? Учитывая что один макет лежит в самом документе а второй макет в Общих макетах?
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    На форуме целая ветка посвящена ВПФ. Так что курите...
  7. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Покурим хорошенько) В двух словах врядли объяснишь, нашел видео урок по поводу создаия ВПФ, поглядим. Всем спасибо1
  8. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Что то не выходит... выводит ошибку: "Переменная не определена (Дата)"

    Функция Печать() Экспорт

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
    Запрос.УстановитьПараметр("Дата" , Дата);

    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    | Номер КАК НомерДокумента,
    | Дата КАК ДатаДокумента,
    | Контрагент,
    | Организация,
    | СтруктурноеПодразделение,
    | СуммаДокумента,
    | ВалютаДокумента,
    | ВалютаДокумента.Представление КАК ВалютаПредставление,
    | УчитыватьНДС,
    | СуммаВключаетНДС,
    | Склад,
    | СчетУчетаРасчетовСКонтрагентом КАК КорреспондентскийСчет,
    | ОтветственныеЛицаСклад.ФизическоеЛицо КАК МОЛ,
    | НомерВходящегоДокумента КАК НомерСопроводительногоДокумента
    |ИЗ
    | Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
    | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних(&Дата, ) КАК ОтветственныеЛицаСклад
    | ПО Склад = ОтветственныеЛицаСклад.СтруктурнаяЕдиница
    |ГДЕ
    | Ссылка = &ТекущийДокумент";

    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();

    ЗапросПоТоварам = Новый Запрос();
    ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
    ЗапросПоТоварам.Текст = "ВЫБРАТЬ
    | СУММА(Товары.Количество) КАК КоличествоПоДокументу,
    | Товары.Цена КАК Цена,
    | СУММА(Товары.Сумма) КАК ВсегоСНДС,
    | Товары.ЕдиницаИзмерения.Представление КАК ЕдиницаНаименование,
    | СУММА(Товары.СуммаНДС) КАК СуммаНДС,
    | Товары.Номенклатура.Код КАК ТоварКод,
    | Товары.ЕдиницаИзмерения.Код КАК ЕдиницаКод,
    | Товары.Номенклатура.Артикул КАК Артикул,
    | ВЫРАЗИТЬ(Товары.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК ТоварНаименование,
    | Товары.НомерСтроки КАК НомерСтроки
    |ИЗ
    | Документ.ПоступлениеТоваровУслуг.Товары КАК Товары
    |ГДЕ
    | Товары.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    | Товары.Цена,
    | Товары.Номенклатура.Наименование,
    | Товары.Номенклатура.Код,
    | Товары.Номенклатура.Артикул,
    | Товары.ЕдиницаИзмерения.Код,
    | Товары.ЕдиницаИзмерения.Представление,
    | ВЫРАЗИТЬ(Товары.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)),
    | Товары.НомерСтроки
    |
    |УПОРЯДОЧИТЬ ПО
    | НомерСтроки,
    | ТоварНаименование
    |АВТОУПОРЯДОЧИВАНИЕ";
    ВыборкаСтрок = ЗапросПоТоварам.Выполнить().Выгрузить();

    СтруктурнаяЕдиницаОрганизация = ОбщегоНазначения.ПолучитьСтруктурнуюЕдиницу(Шапка.Организация, Шапка.СтруктурноеПодразделение);
    СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(СтруктурнаяЕдиницаОрганизация, Шапка.ДатаДокумента);

    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_З1";
    Макет = ПолучитьОбщийМакет("З1");

    // Выводим шапку накладной
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ПредставлениеОрганизации = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(СтруктурнаяЕдиницаОрганизация, Шапка.ДатаДокумента), "ПолноеНаименование,");
    ОбластьМакета.Параметры.ПредставлениеСклада = Шапка.Склад.Наименование;
    ОбластьМакета.Параметры.ОрганизацияРНН_БИН = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "БИН_ИИН,", Ложь, Шапка.ДатаДокумента, "ru");
    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокДокумента");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.ДатаДокумента), "ПолноеНаименование,");
    ОбластьМакета.Параметры.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект, глСписокПрефиксовУзлов);
    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    ОбластьМакета.Параметры.ВалютаПредставление = Шапка.ВалютаПредставление;
    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("Строка");
    Количество = 0;
    Сумма = 0;

    Для Каждого ВыборкаСтрокТовары Из ВыборкаСтрок Цикл

    ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);

    ОбластьМакета.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.ТоварНаименование);
    ТабДокумент.Вывести(ОбластьМакета);

    Сумма = Сумма + ВыборкаСтрокТовары.ВсегоСНДС;
    Количество = Количество + ВыборкаСтрокТовары.КоличествоПоДокументу;

    КонецЦикла;

    // Вывести Итого
    ОбластьМакета = Макет.ПолучитьОбласть("Итого");
    ОбластьМакета.Параметры.ИтогВсегоСНДС = ОбщегоНазначения.ФорматСумм(Сумма);
    ОбластьМакета.Параметры.ИтогКоличествоПоДокументу = Количество;
    ТабДокумент.Вывести(ОбластьМакета);

    // Вывести Итого
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
    // заполняем МОЛ
    Если ЗначениеЗаполнено(Шапка.Склад) Тогда
    ДанныеМОЛ = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.МОЛ, Шапка.ДатаДокумента);
    ОбластьМакета.Параметры.МОЛ = ДанныеМОЛ.Представление;
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьМакета);

    Возврат ТабДокумент;

    КонецФункции // ПечатьЗ1()
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    СсылкаНаОбъект.Дата
  10. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Спасибо, заработало!
  11. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Только теперь проблема в следующем. Подключил печатную форму через внешние отчеты, но они идентичную информацию дают, что стандартная что внешняя.. На внешний был добавлен еще одна колонка, в конфигураторе она видна, а когда выводишь на печать ее нет... В чем может быть дело?
  12. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    В обработке и выводе результата в печатную форму.
  13. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Такое чувство что она синзронизируется с основным макетом, в основном добавляешь колонку, появляется во внешнем, убираешь, пропадает и там и там
  14. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Как писали ВПФ ?
  15. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    По видеоинструкции и вашей помощи, создал внешнюю обработку, скопировал функцию печати с общих макетов этого документа, подправил и вуаля, получилось что получилось
  16. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Значит что-то не так сделали, разбирайтесь :), я не телепат что бы вынести вердикт :)
  17. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    :) Может вам еще какую-нибудь наводочку дать? Вы спросите я расскажу.
  18. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Так макет вы какой получаете ??? Который в обработке или в конфигурации ????
  19. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    + думаю ошибка в строке
    Код:
    Макет = ПолучитьОбщийМакет("З1");
  20. TopicStarter Overlay
    ofautumn
    Offline

    ofautumn Опытный в 1С

    Регистрация:
    30 окт 2012
    Сообщения:
    109
    Симпатии:
    1
    Баллы:
    29
    Спасибо, ошибка была в этом
Похожие темы
  1. Maks
    Ответов:
    11
    Просмотров:
    442
Загрузка...

Поделиться этой страницей