8.х ДокументОбъект

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем denmember, 18 фев 2007.

  1. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    В табл части документа обращаюсь к конкретной строке и изменяю в ней сумму

    ДокОбъект=Документы.ЗаявкаНаРасходованиеСредств.НайтиПоНомеру("0000001").ПолучитьОбъект();
    СтруктураДляПоиска = Новый Структура("НомерСтроки",1);
    ТЧЗаявкаОбъект=ДокОбъект.РасшифровкаПлатежа;
    СтрокаДокОбъект=ТЧЗаявкаОбъект.НайтиСтроки(СтруктураДляПоиска);
    Для каждого стр из СтрокаДокОбъект цикл
    стр.СуммаПлатежа=20000;
    КонецЦикла;


    Данная строка ТЧ документа не находися! Почему?
  2. Deosfen
    Offline

    Deosfen Опытный в 1С

    Регистрация:
    6 фев 2007
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    так попробуй:

    ДокОбъект=Документы.ЗаявкаНаРасходованиеСредств.НайтиПоНомеру("0000001").ПолучитьОбъект();
    Для каждого стр из ДокОбъект.РасшифровкаПлатежа цикл
    стр.СуммаПлатежа=20000;
    КонецЦикла;
  3. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Мне нужна строка с конкретным номером!!! help
  4. Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    А просто Найти ?

    ДокОбъект=Документы.ЗаявкаНаРасходованиеСредств.НайтиПоНомеру("0000001").ПолучитьОбъект();
    ТЧЗаявкаОбъект=ДокОбъект.РасшифровкаПлатежа;
    СтрокаДокОбъект=ТЧЗаявкаОбъект.Найти(1,"НомерСтроки");
    Если СтрокаДокОбъект <> Неопределено Тогда
    СтрокаДокОбъект.СуммаПлатежа=20000;
    КонецЕсли;
  5. Deosfen
    Offline

    Deosfen Опытный в 1С

    Регистрация:
    6 фев 2007
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    Тогда через запрос

    Запрос = Новый Запрос() ;

    Запрос.Текст = "ВЫБРАТЬ Состав.Ссылка КАК Док
    ИЗ Документ.ЗаявкаНаРасходованиеСредств.Состав КАК Состав
    ГДЕ Состав.НомерСтроки = &Номер И Состав.Ссылка.Номер=&ДокНомер" ;

    Результат = Запрос.Вы...
    ....

    хотя искать по номеру строки в таб. части, скажем ... не совсем логично, может нужно логику пересмотреть.
Похожие темы
  1. vall-n-rol
    Ответов:
    15
    Просмотров:
    916
Загрузка...

Поделиться этой страницей