7.7 Документ закрытие Периода

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем sashadeo, 16 мар 2013.

  1. TopicStarter Overlay
    sashadeo
    Offline

    sashadeo Опытный в 1С

    Регистрация:
    29 дек 2010
    Сообщения:
    379
    Симпатии:
    0
    Баллы:
    26
    1с 7.7 бух для казахстана
    Здравствуйте!
    Есть документ закрытие периода.
    При закрытие накладных расходов они закрываются как 8411 на 8115
    Мне необходимо сделать что бы все закрывалось так же (8411 на 8115) но если подразделение Транспорт то закрытие было 8411 на 8315
    Изначально процедура был такая:

    Код:
    Процедура ЗакрытьНакладныеРасходы()
    
    Если ЗакрытьНакладныеРасходы = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Сообщить("-- Закрытие накладных расходов (8411-го счета)","i");
    СформированоПроводок = 0;	  
    
    //Получаем базу распределения накладных расходов
    СчетРаспределения = Организация.БазаРаспределенияНакладныхРасходов.Получить(ДатаДок);
    // если база распределения не выбрана по умолчанию  задаем счет 8112
    Если СчетРаспределения.Выбран() = 0 Тогда
    СчетРаспределения = СчетПоКоду("8112");
    КонецЕсли;
    
    // рассчитываем базу распределения накладных расходов
    ТЗРаспределения = СоздатьОбъект("ТаблицаЗначений");
    ТзРаспределения.НоваяКолонка("Подразделение");
    ТзРаспределения.НоваяКолонка("ВидДеятельности");
    ТзРаспределения.НоваяКолонка("Сумма");
    
    БухИтогиБаза = СоздатьОбъект("БухгалтерскиеИтоги");
    
    Если Метаданные.РазделительУчета.Выбран() = 1 Тогда
    Если ПустоеЗначение(Организация) = 0 Тогда
    БухИтогиБаза.ИспользоватьРазделительУчета(Организация);
    КонецЕсли; 
    КонецЕсли;
    
    // заполняем общую базу распределения
    ТзРаспределенияОбщ = СоздатьОбъект("ТаблицаЗначений");
    ТзРаспределенияОбщ.НоваяКолонка("Подразделение");
    ТзРаспределенияОбщ.НоваяКолонка("ВидДеятельности");
    ТзРаспределенияОбщ.НоваяКолонка("Сумма");
    
    БухИтогиБаза.ИспользоватьСубконто(ВидыСубконто.Подразделения);
    БухИтогиБаза.ИспользоватьСубконто(ВидыСубконто.ВидыДеятельности);
    БухИтогиБаза.ВыполнитьЗапрос(,ТекущийДокумент(), СчетРаспределения);
    БухИтогиБаза.ВыбратьСубконто(1);
    
    Пока БухИтогиБаза.ПолучитьСубконто(1) = 1 Цикл
    БухИтогиБаза.ВыбратьСубконто(2);
    Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    ТзРаспределенияОбщ.НоваяСтрока();
    ТзРаспределенияОбщ.Подразделение   = БухИтогиБаза.Субконто(1);
    ТзРаспределенияОбщ.ВидДеятельности = БухИтогиБаза.Субконто(2);
    ТзРаспределенияОбщ.Сумма = БухИтогиБаза.СКД("С");
    КонецЦикла;   
    КонецЦикла;
    
    БухИтоги.ИспользоватьСубконто(ВидыСубконто.Подразделения);
    БухИтоги.ИспользоватьСубконто(ВидыСубконто.ВидыЗатрат);
    БухИтоги.ВыполнитьЗапрос(,ТекущийДокумент(), СчетПоКоду("8411"));
    БухИтоги.ВыбратьСубконто(1);
    Если ТзРаспределенияОбщ.КоличествоСтрок()<=0 Тогда
    Сообщить("Не обнаружены затраты на счете " + СчетРаспределения +  " формирование базы распределения накладных расходов не возможно", "i");
    Сообщить("-- При закрытии накладных расходов (8411-го счета) - проводки не сформированы","i");
    Иначе
    Пока БухИтоги.ПолучитьСубконто(1) = 1 Цикл   
    //Сообщить(БухИтоги.Субконто());
    // заполняем базу распределения накладных расходов
    // вариант 1-ый - на счете 8111 присутствуют затраты по подразделению -
    // тогда это общецеховые затраты, относящиеся на конкретное подразделение  
    
    
    
    
    
    Если БухИтогиБаза.ПолучитьСубконто(1,,БухИтоги.Субконто(1)) = 1  Тогда
    
    ТзРаспределения.УдалитьСтроки();
    БазаРаспределения = 0;
    БухИтогиБаза.ВыбратьСубконто(2);
    
    Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    ТзРаспределения.НоваяСтрока();
    ТзРаспределения.Подразделение   = БухИтогиБаза.Субконто(1);
    ТзРаспределения.ВидДеятельности = БухИтогиБаза.Субконто(2);
    ТзРаспределения.Сумма = БухИтогиБаза.СКД("С");
    КонецЦикла;// Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    
    БазаРаспределения = ТзРаспределения.Итог("Сумма");
    
    БухИтоги.ВыбратьСубконто(2);
    Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    РаспределеннаяСумма = 0;
    СуммаРаспределения  = БухИтоги.СКД("С");
    Пока ТзРаспределения.ПолучитьСтроку() = 1 Цикл
    СуммаПроводки = Окр((СуммаРаспределения *  ТзРаспределения.Сумма)/БазаРаспределения,2);
    РаспределеннаяСумма = РаспределеннаяСумма + СуммаПроводки;
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ТзРаспределения.ВидДеятельности),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , СуммаПроводки,,,
    "Закрытие накл. расходов", "ГП", Организация, 1);
    СформированоПроводок = СформированоПроводок + 1;
    
    КонецЦикла;
    // проверка на распрделение всей суммы
    Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    ТзРаспределения.ПолучитьСтрокуПоНомеру(ТзРаспределения.КоличествоСтрок());  
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ТзРаспределения.ВидДеятельности),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , Окр(СуммаРаспределения - РаспределеннаяСумма,2),,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1; 
    
    
    КонецЕсли;//Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    КонецЦикла;//Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл 
    // вариант 2-ой - на счете 8111 нет затрат по подразделению -
    // тогда это общезаводские затраты, распределяем между всеми подразделениями основного производства
    Иначе
    глСообщить(Операция, "Не обнаружены затраты на счете " + СчетРаспределения +  " для: " + БухИтоги.Субконто(1) + ".
    |затраты будут распределены по всем подразделениям основного производства", "i");
    БухИтоги.ВыбратьСубконто(2);
    Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    РаспределеннаяСумма  = 0;
    СуммаРаспределения   = БухИтоги.СКД("С");
    БазаРаспределенияОбщ = ТзРаспределенияОбщ.Итог("Сумма");
    
    Пока ТзРаспределенияОбщ.ПолучитьСтроку() = 1 Цикл
    СуммаПроводки = Окр((СуммаРаспределения * ТзРаспределенияОбщ.Сумма)/БазаРаспределенияОбщ,2);
    РаспределеннаяСумма = РаспределеннаяСумма + СуммаПроводки; 
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(ТзРаспределенияОбщ.Подразделение, ТзРаспределенияОбщ.ВидДеятельности, БухИтоги.Субконто(2)),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , СуммаПроводки,,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1;  
    //
    КонецЦикла;//Пока ТзРаспределения.ПолучитьСтроку() = 1 Цикл
    // проверка на распрделение всей суммы
    Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    ТзРаспределенияОбщ.ПолучитьСтрокуПоНомеру(ТзРаспределенияОбщ.КоличествоСтрок()); 
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(ТзРаспределенияОбщ.Подразделение, ТзРаспределенияОбщ.ВидДеятельности, БухИтоги.Субконто(2)),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , Окр( СуммаРаспределения - РаспределеннаяСумма, 2),,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1;
    КонецЕсли;//Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    КонецЦикла; //Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    КонецЕсли;//Если БухИтогиБаза.ПолучитьСубконто(1,,БухИтоги.Субконто(1)) = 1  Тогда 
    ....
    
    
    
    
    
    
    
    
    

    Далее я сделал следующие изменения:

    Код:
    Процедура ЗакрытьНакладныеРасходы()
    
    Если ЗакрытьНакладныеРасходы = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Сообщить("-- Закрытие накладных расходов (8411-го счета)","i");
    СформированоПроводок = 0;	  
    
    //Получаем базу распределения накладных расходов
    СчетРаспределения = Организация.БазаРаспределенияНакладныхРасходов.Получить(ДатаДок);
    // если база распределения не выбрана по умолчанию  задаем счет 8112
    Если СчетРаспределения.Выбран() = 0 Тогда
    СчетРаспределения = СчетПоКоду("8112");
    КонецЕсли;
    
    // рассчитываем базу распределения накладных расходов
    ТЗРаспределения = СоздатьОбъект("ТаблицаЗначений");
    ТзРаспределения.НоваяКолонка("Подразделение");
    ТзРаспределения.НоваяКолонка("ВидДеятельности");
    ТзРаспределения.НоваяКолонка("Сумма");
    
    БухИтогиБаза = СоздатьОбъект("БухгалтерскиеИтоги");
    
    Если Метаданные.РазделительУчета.Выбран() = 1 Тогда
    Если ПустоеЗначение(Организация) = 0 Тогда
    БухИтогиБаза.ИспользоватьРазделительУчета(Организация);
    КонецЕсли; 
    КонецЕсли;
    
    // заполняем общую базу распределения
    ТзРаспределенияОбщ = СоздатьОбъект("ТаблицаЗначений");
    ТзРаспределенияОбщ.НоваяКолонка("Подразделение");
    ТзРаспределенияОбщ.НоваяКолонка("ВидДеятельности");
    ТзРаспределенияОбщ.НоваяКолонка("Сумма");
    
    БухИтогиБаза.ИспользоватьСубконто(ВидыСубконто.Подразделения);
    БухИтогиБаза.ИспользоватьСубконто(ВидыСубконто.ВидыДеятельности);
    БухИтогиБаза.ВыполнитьЗапрос(,ТекущийДокумент(), СчетРаспределения);
    БухИтогиБаза.ВыбратьСубконто(1);
    
    Пока БухИтогиБаза.ПолучитьСубконто(1) = 1 Цикл
    БухИтогиБаза.ВыбратьСубконто(2);
    Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    ТзРаспределенияОбщ.НоваяСтрока();
    ТзРаспределенияОбщ.Подразделение   = БухИтогиБаза.Субконто(1);
    ТзРаспределенияОбщ.ВидДеятельности = БухИтогиБаза.Субконто(2);
    ТзРаспределенияОбщ.Сумма = БухИтогиБаза.СКД("С");
    КонецЦикла;   
    КонецЦикла;
    
    БухИтоги.ИспользоватьСубконто(ВидыСубконто.Подразделения);
    БухИтоги.ИспользоватьСубконто(ВидыСубконто.ВидыЗатрат);
    БухИтоги.ВыполнитьЗапрос(,ТекущийДокумент(), СчетПоКоду("8411"));
    БухИтоги.ВыбратьСубконто(1);
    Если ТзРаспределенияОбщ.КоличествоСтрок()<=0 Тогда
    Сообщить("Не обнаружены затраты на счете " + СчетРаспределения +  " формирование базы распределения накладных расходов не возможно", "i");
    Сообщить("-- При закрытии накладных расходов (8411-го счета) - проводки не сформированы","i");
    Иначе
    Пока БухИтоги.ПолучитьСубконто(1) = 1 Цикл   
    //Сообщить(БухИтоги.Субконто());
    // заполняем базу распределения накладных расходов
    // вариант 1-ый - на счете 8111 присутствуют затраты по подразделению -
    // тогда это общецеховые затраты, относящиеся на конкретное подразделение  
    
    
    
    Добавил условие

    Код:
    Если  БухИтоги.Субконто(1) ="Транспорт"  тогда
    Сообщить("Получилось1") ;
    Если истина то закрываем 8411 на 8315

    Код:
    Если БухИтогиБаза.ПолучитьСубконто(1,,БухИтоги.Субконто(1)) = 1  Тогда
    
    ТзРаспределения.УдалитьСтроки();
    БазаРаспределения = 0;
    БухИтогиБаза.ВыбратьСубконто(2);
    
    Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    ТзРаспределения.НоваяСтрока();
    ТзРаспределения.Подразделение   = БухИтогиБаза.Субконто(1);
    ТзРаспределения.ВидДеятельности = БухИтогиБаза.Субконто(2);
    ТзРаспределения.Сумма = БухИтогиБаза.СКД("С");
    КонецЦикла;// Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    
    БазаРаспределения = ТзРаспределения.Итог("Сумма");
    
    БухИтоги.ВыбратьСубконто(2);
    Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    РаспределеннаяСумма = 0;
    СуммаРаспределения  = БухИтоги.СКД("С");
    Пока ТзРаспределения.ПолучитьСтроку() = 1 Цикл
    СуммаПроводки = Окр((СуммаРаспределения *  ТзРаспределения.Сумма)/БазаРаспределения,2);
    РаспределеннаяСумма = РаспределеннаяСумма + СуммаПроводки;
    глПроводка( Операция,
    СчетПоКоду("8315"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ТзРаспределения.ВидДеятельности),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , СуммаПроводки,,,
    "Закрытие накл. расходов", "ГП", Организация, 1);
    СформированоПроводок = СформированоПроводок + 1;
    
    КонецЦикла;
    // проверка на распрделение всей суммы
    Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    ТзРаспределения.ПолучитьСтрокуПоНомеру(ТзРаспределения.КоличествоСтрок());
    глПроводка( Операция,
    СчетПоКоду("8315"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ТзРаспределения.ВидДеятельности),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , Окр(СуммаРаспределения - РаспределеннаяСумма,2),,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1; 
    
    
    КонецЕсли;//Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    КонецЦикла;//Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл 
    // вариант 2-ой - на счете 8111 нет затрат по подразделению -
    // тогда это общезаводские затраты, распределяем между всеми подразделениями основного производства
    Иначе
    глСообщить(Операция, "Не обнаружены затраты на счете " + СчетРаспределения +  " для: " + БухИтоги.Субконто(1) + ".
    |затраты будут распределены по всем подразделениям основного производства", "i");
    БухИтоги.ВыбратьСубконто(2);
    Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    РаспределеннаяСумма  = 0;
    СуммаРаспределения   = БухИтоги.СКД("С");
    БазаРаспределенияОбщ = ТзРаспределенияОбщ.Итог("Сумма");
    
    Пока ТзРаспределенияОбщ.ПолучитьСтроку() = 1 Цикл
    СуммаПроводки = Окр((СуммаРаспределения * ТзРаспределенияОбщ.Сумма)/БазаРаспределенияОбщ,2);
    РаспределеннаяСумма = РаспределеннаяСумма + СуммаПроводки; 
    глПроводка( Операция,
    СчетПоКоду("8315"), глСубконто(ТзРаспределенияОбщ.Подразделение, ТзРаспределенияОбщ.ВидДеятельности, БухИтоги.Субконто(2)),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , СуммаПроводки,,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1;  
    //
    КонецЦикла;//Пока ТзРаспределения.ПолучитьСтроку() = 1 Цикл
    // проверка на распрделение всей суммы
    Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    ТзРаспределенияОбщ.ПолучитьСтрокуПоНомеру(ТзРаспределенияОбщ.КоличествоСтрок()); 
    глПроводка( Операция,
    СчетПоКоду("8315"), глСубконто(ТзРаспределенияОбщ.Подразделение, ТзРаспределенияОбщ.ВидДеятельности, БухИтоги.Субконто(2)),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , Окр( СуммаРаспределения - РаспределеннаяСумма, 2),,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1;
    КонецЕсли;//Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    КонецЦикла; //Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    КонецЕсли;//Если БухИтогиБаза.ПолучитьСубконто(1,,БухИтоги.Субконто(1)) = 1  Тогда 
    
    
    
    
    
    
    

    Иначе закрываем 8411 на 8115 т.е если подразделение не равно транспорт

    Код:
    Иначе  
    
    
    
    Сообщить("Получилось2") ;
    
    Если БухИтогиБаза.ПолучитьСубконто(1,,БухИтоги.Субконто(1)) = 1  Тогда
    
    ТзРаспределения.УдалитьСтроки();
    БазаРаспределения = 0;
    БухИтогиБаза.ВыбратьСубконто(2);
    
    Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    ТзРаспределения.НоваяСтрока();
    ТзРаспределения.Подразделение   = БухИтогиБаза.Субконто(1);
    ТзРаспределения.ВидДеятельности = БухИтогиБаза.Субконто(2);
    ТзРаспределения.Сумма = БухИтогиБаза.СКД("С");
    КонецЦикла;// Пока БухИтогиБаза.ПолучитьСубконто(2) = 1 Цикл
    
    БазаРаспределения = ТзРаспределения.Итог("Сумма");
    
    БухИтоги.ВыбратьСубконто(2);
    Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    РаспределеннаяСумма = 0;
    СуммаРаспределения  = БухИтоги.СКД("С");
    Пока ТзРаспределения.ПолучитьСтроку() = 1 Цикл
    СуммаПроводки = Окр((СуммаРаспределения *  ТзРаспределения.Сумма)/БазаРаспределения,2);
    РаспределеннаяСумма = РаспределеннаяСумма + СуммаПроводки;
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ТзРаспределения.ВидДеятельности),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , СуммаПроводки,,,
    "Закрытие накл. расходов", "ГП", Организация, 1);
    СформированоПроводок = СформированоПроводок + 1;
    
    КонецЦикла;
    // проверка на распрделение всей суммы
    Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    ТзРаспределения.ПолучитьСтрокуПоНомеру(ТзРаспределения.КоличествоСтрок());
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ТзРаспределения.ВидДеятельности),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , Окр(СуммаРаспределения - РаспределеннаяСумма,2),,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1; 
    
    
    КонецЕсли;//Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    КонецЦикла;//Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл 
    // вариант 2-ой - на счете 8111 нет затрат по подразделению -
    // тогда это общезаводские затраты, распределяем между всеми подразделениями основного производства
    Иначе
    глСообщить(Операция, "Не обнаружены затраты на счете " + СчетРаспределения +  " для: " + БухИтоги.Субконто(1) + ".
    |затраты будут распределены по всем подразделениям основного производства", "i");
    БухИтоги.ВыбратьСубконто(2);
    Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    РаспределеннаяСумма  = 0;
    СуммаРаспределения   = БухИтоги.СКД("С");
    БазаРаспределенияОбщ = ТзРаспределенияОбщ.Итог("Сумма");
    
    Пока ТзРаспределенияОбщ.ПолучитьСтроку() = 1 Цикл
    СуммаПроводки = Окр((СуммаРаспределения * ТзРаспределенияОбщ.Сумма)/БазаРаспределенияОбщ,2);
    РаспределеннаяСумма = РаспределеннаяСумма + СуммаПроводки; 
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(ТзРаспределенияОбщ.Подразделение, ТзРаспределенияОбщ.ВидДеятельности, БухИтоги.Субконто(2)),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , СуммаПроводки,,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1;  
    //
    КонецЦикла;//Пока ТзРаспределения.ПолучитьСтроку() = 1 Цикл
    // проверка на распрделение всей суммы
    Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    ТзРаспределенияОбщ.ПолучитьСтрокуПоНомеру(ТзРаспределенияОбщ.КоличествоСтрок()); 
    глПроводка( Операция,
    СчетПоКоду("8115"), глСубконто(ТзРаспределенияОбщ.Подразделение, ТзРаспределенияОбщ.ВидДеятельности, БухИтоги.Субконто(2)),
    СчетПоКоду("8411"), глСубконто(БухИтоги.Субконто(1), БухИтоги.Субконто(2), ),
    , Окр( СуммаРаспределения - РаспределеннаяСумма, 2),,,
    "Закрытие накл. расходов", "ГП", Организация, 1);  
    СформированоПроводок = СформированоПроводок + 1;
    КонецЕсли;//Если Окр( СуммаРаспределения - РаспределеннаяСумма, 2) <> 0  Тогда
    КонецЦикла; //Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    КонецЕсли;//Если БухИтогиБаза.ПолучитьСубконто(1,,БухИтоги.Субконто(1)) = 1  Тогда 
    
    
    
    
    КонецЕсли; 
    
    
    

    И это не сработало((( помогите разобраться в чем ошибка...
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Если  СокрЛП(БухИтоги.Субконто(1)) ="Транспорт"  тогда
    Сообщить("Получилось1") ;
    
  3. TopicStarter Overlay
    sashadeo
    Offline

    sashadeo Опытный в 1С

    Регистрация:
    29 дек 2010
    Сообщения:
    379
    Симпатии:
    0
    Баллы:
    26
    Урааа!!!!!!!!!!
    Работает!!!
    Огромное спасибооооооо"""

Поделиться этой страницей