8.х Документ Требование - Накладная

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Ermak, 30 июл 2009.

  1. TopicStarter Overlay
    Ermak
    Offline

    Ermak

    Регистрация:
    30 июл 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Доброе утро! У меня тут такая проблемка, если можете то помогите.
    В документе Требование-Накладная в печатной форме надо заменить колонку Материал на Сумму и Цена и в конце таблицы сделать Итого.
    Сумма и Цена чтобы выводило я сделал но вот с итогами у меня проблема получилась, он не + между собой номенклатуру. Щас все покажу:

    [​IMG]



    Код:
    Функция ПечатьТребованиеНакладная()
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
    Запрос.Текст ="
    |ВЫБРАТЬ
    |	Номер,
    |	Дата,
    |	Организация,
    |	Склад
    |ИЗ
    |	Документ.ТребованиеНакладная КАК ТребованиеНакладная
    |
    |ГДЕ
    |	ТребованиеНакладная.Ссылка = &ТекущийДокумент";
    
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
    
    Запрос.Текст =
    "ВЫБРАТЬ
    |	ТребованиеНакладная.Номенклатура.Код КАК Код,
    |	ТребованиеНакладная.Номенклатура.НаименованиеПолное КАК Имя,
    |	ТребованиеНакладная.Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдИзм,
    |	ТребованиеНакладная.Количество КАК Количество,
    |	ТребованиеНакладная.ЕдиницаИзмерения КАК ЕдИзмМест
    |ИЗ
    |	Документ.ТребованиеНакладная.Материалы КАК ТребованиеНакладная
    |ГДЕ
    |	ТребованиеНакладная.Ссылка = &ТекущийДокумент";
    
    ЗапросПоНоменклатуре = Запрос.Выполнить();
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ТребованиеНакладная_ТН";
    
    // Вывод заголовка
    Макет = ПолучитьМакет("ТребованиеНакладная");
    Область = Макет.ПолучитьОбласть("Заголовок");
    Область.Параметры.ТекстЗаголовка = РаботаСДиалогами.СформироватьЗаголовокДокумента(Ссылка, "Требование-накладная");
    Область.Параметры.Заполнить(Шапка);
    ТабДокумент.Вывести(Область);
    
    ВыборкаПоСтрокам = ЗапросПоНоменклатуре.Выгрузить();
    ВыборкаПоСтрокам.Свернуть("Код, Имя, ЕдИзм, ЕдИзмМест", "Количество");
    
    // Поиск сумм списания активов для заполнения Цены и Суммы
    ТаблицаСуммСписания = БухгалтерскийУчет.ПолучитьСуммуСписанияАктивов(ЭтотОБъект);
    
    НомерТекущий = 1;
    Для Каждого СтрокаТЧ Из ВыборкаПоСтрокам Цикл
    
    Область = Макет.ПолучитьОбласть("Строка");
    Область.Параметры.Заполнить(СтрокаТЧ);
    Область.Параметры.НомерТекущий = НомерТекущий;
    НомерТекущий = НомерТекущий + 1;
    ПоискНоменклатуры=  Справочники.Номенклатура.НайтиПоКоду(СтрокаТЧ.Код);
    
    СтрокаСуммСписания =  ТаблицаСуммСписания.Найти(ПоискНоменклатуры, "Номенклатура");
    Если СтрокаСуммСписания = Неопределено Тогда
    Область.Параметры.Цена = 0;
    Область.Параметры.Сумма = 0;
    Иначе
    Цена = ?(СтрокаСуммСписания.Количество = 0, 0, СтрокаСуммСписания.Сумма / СтрокаСуммСписания.Количество);
    Область.Параметры.Цена  = Цена;
    Область.Параметры.Сумма = Цена * СтрокаТЧ.Количество;
    КонецЕсли;
    ТабДокумент.Вывести(Область);
    
    КонецЦикла;
    //Вывод Итогов
    Сумма=  Область.Параметры.Сумма;
    Область = Макет.ПолучитьОбласть("Итого");
    Область.Параметры.Всего = Сумма + ?????;
    
    ТабДокумент.Вывести(Область);
    
    
    // Вывод подвала
    Область = Макет.ПолучитьОбласть("Подписи");
    ТабДокумент.Вывести(Область);
    
    Возврат ТабДокумент;
    
    КонецФункции // ПечатьТребованиеНакладная()
    
    


    Вот так я сделал но не знаю что писать здесь :

    Область.Параметры.Всего = Сумма + ????? ;

    За ранее большое спасибо!
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Это если не вдаваться в подробности остального кода
  3. TopicStarter Overlay
    Ermak
    Offline

    Ermak

    Регистрация:
    30 июл 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Я вывел код печатной формы Требование-Накладная, есть еще М-11
  4. TopicStarter Overlay
    Ermak
    Offline

    Ermak

    Регистрация:
    30 июл 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Это что за форрум, уже висит 4 дня и не кто не может помочь!!!!!!!
  5. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    А никто тебе здесь ничего и не должен. Не нравится - извини, а истерик устраивать не надо. Да и выходные сейчас. Основная работа - она ведь не работе. :unsure: Подожди до понедельника - может и тебе будет помошник.
  6. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    И вообще, Вам в первый же день ответили. Удалите из кода текст: ///***** и будет все работать. Только последняя измененная строка должна так выглядеть:
    Код:
    Область.Параметры.Всего = Итог; 
    
  7. TopicStarter Overlay
    Ermak
    Offline

    Ermak

    Регистрация:
    30 июл 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое, я просто не заметил что в первом ответе мне уже дали ответ :unsure: .

Поделиться этой страницей