7.7 Документ на Основании

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем honor, 29 мар 2009.

  1. TopicStarter Overlay
    honor
    Offline

    honor

    Регистрация:
    2 апр 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Подскажите пож-та как найти какой документ вводится по команде: "Действия - Ввести на основании"? Для документа "Реализация товаров", это вроде документ "Возврат от покупателя", но если выбираю документы за даты, то выходят только документы введенные вручную из Журнала "Возвраты ТМЗ" документ "Возврат от поставщика". Где прописывается документ вызываемый по этой команде?
  2. eviloid
    Offline

    eviloid Опытный в 1С

    Регистрация:
    15 май 2008
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    Какие документы могут вводится на основании можно посмотреть в конфигураторе:
    Посмотреть вложение 1747

    Можно программно:
    Код:
    ВводимыеНаОсновании = Метаданные.Документ("Реализация").ВводимыеНаОснованииДокументы;
    
    Для Н = 1 По ВводимыеНаОсновании.Количество() Цикл
    Сообщить(ВводимыеНаОсновании.Получить(Н).ПолныйИдентификатор());
    КонецЦикла;
    
    
    
    Для того что бы получить из базы введенные на основании документы нужно использовать метод объекта "Документ"
    ВыбратьПодчиненныеДокументы(<?>,,)
    Синтаксис:
    ВыбратьПодчиненныеДокументы(<Дата1>,<Дата2>,<Докум>)
    Назначение:
    Открыть выборку документов, подчиненных заданному, в интервале дат.
    Возвращает:
    1 - если действие выполнено и в выборке есть хотя бы один документ;
    0 - если действие не выполнено или в выборке нет ни одного документа.
    Параметры:
    <Дата1> - дата, документ или позиция начала выборки документов. Если данный параметр опущен, то выборка начинается с самого первого существующего в системе документа.
    <Дата2> - дата, документ или позиция конца выборки документов. Если данный параметр опущен, то выборка заканчивается самым последним существующим в системе документом.
    <Докум> - документ, подчиненные которому будут включаться в выборку.
    Замечание:
    Метод можно использовать только для объектов, созданных функцией СоздатьОбъект.

    выбрать все документы:
    Код:
    Док = СоздатьОбъект("Документ");
    
    Док.ВыбратьПодчиненныеДокументы(,,ВыбДокОснование);
    
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Сообщить(Док.ТекущийДокумент());
    КонецЦикла;
    
    
    
    Если нужно выбрать документы определенного типа, то:
    Код:
    Док = СоздатьОбъект("Документ.ВозвратОтПокупателя");
    
    Док.ВыбратьПодчиненныеДокументы(,,ВыбДокОснование);
    
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Сообщить(Док.ТекущийДокумент());
    КонецЦикла;
    
    
    

    Вложения:

    • osnovanie.JPG
      osnovanie.JPG
      Размер файла:
      96,5 КБ
      Просмотров:
      70
  3. X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    428
    Симпатии:
    3
    Баллы:
    29
    Код:
    Док = СоздатьОбъект("Документ.ВозвратОтПокупателя");
    
    Док.ВыбратьПодчиненныеДокументы(,,ВыбДокОснование);
    
    
    А вот это бред, работать не будет:)
  4. eviloid
    Offline

    eviloid Опытный в 1С

    Регистрация:
    15 май 2008
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    Кстати, да. X-Man прав, а я нет.
    Мдя, давно 7-ку в руки не брал. И ведь даже не проверил. Мои извинения. :unsure:

    Код:
    Док = СоздатьОбъект("Документ");
    
    Док.ВыбратьПодчиненныеДокументы(,,ВыбДок);
    
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если Док.Вид() = "ВозвратОтПокупателя" Тогда
    Сообщить(Док.ТекущийДокумент());
    КонецЕсли;
    КонецЦикла;
    
    
    

Поделиться этой страницей