8.х Документ *.doc

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем PavelBaryshev, 10 авг 2009.

  1. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста, как из 1с 8.1 открыть документ, если есть на форме соханенный путь к документу?
    Код:
    Процедура ОписаниеРаботНачалоВыбора(Элемент, СтандартнаяОбработка)
    ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогФыбораФайла.Каталог = Элемент.Значение;
    ДиалогФыбораФайла.Фильтр="(MS Word)|*.Doc";
    ДиалогФыбораФайла.Заголовок = "Выберите файл";
    Если ДиалогФыбораФайла.Выбрать() Тогда	
    Элемент.Значение = ДиалогФыбораФайла.ПолноеИмяФайла;
    КаталогФайла=ДиалогФыбораФайла.Каталог;
    КонецЕсли;
    Путь = Элемент.Значение;
    Если НайтиФайлы(Путь).Количество()=0 тогда
    Сообщить("Выберите описание (VS Word)!!!");
    КонецЕсли;
    Если НайтиФайлы(Путь).Количество()=1 тогда
    Сообщить("Внешнее описание (VS Word)!!!");
    КонецЕсли;
    
    КонецПроцедуры
    [code]
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Что значит "открыть документ"?
    Имеется ввиду просто отдать системе команду на открытие выбранного файла соответствующей программой в отдельном окне?
    Имеется ввиду редактирование документа средствами 1С?
  3. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Просто чтоб он открылся в ворде
  4. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    ЗапуститьПриложение (RunApp)
    Синтаксис:
    ЗапуститьПриложение(<Строка команды>, <Текущий каталог>, <Дождаться завершения>)
    Параметры:
    <Строка команды> (обязательный)
    Тип: Строка. Командная строка для запуска приложения либо имя файла, ассоциированного с некоторым приложением.
    <Текущий каталог> (необязательный)
    Тип: Строка. Задает текущий каталог запускаемого приложения.
    <Дождаться завершения> (необязательный)
    Тип: Булево. Истина - дожидаться завершения запущенной системы перед продолжением работы.
    Значение по умолчанию: Ложь
    Описание:
    Выполняет запуск внешнего приложения либо открытие файла с использованием ассоциированного с ним приложения.
    Недоступен на сервере 1С:Предприятие. Не используется в модуле внешнего соединения.
    Примечание:
    В отличие от функции КомандаСистемы запуск приложения выполняется непосредственно, минуя командный интерпретатор.
    Пример:
    ЗапуститьПриложение("www.1c.ru");
    // открытие файла MS Excel
    ЗапуститьПриложение("Таблица.xls");

Поделиться этой страницей