7.7 Добыть данные с книги продаж и книги покупок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем anton, 12 апр 2010.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не уверен что у вас все правильно....
    В Договорах контрагентов стоит крыж "Автоформирование книг покупок/продаж". Если нет то в документе с/ф д.б. крыж "включать в книку покупок/продаж".
    ОБЯЗАТЕЛЬНО д.б. сделаны документы ЗапиСЬКнигиПокупок/Продаж ИЛИ ЗапиСИКнигиПокупок/Продаж. Скорее всего у вас нет этих документов... (или частично)
  2. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    ну с ""получить сумму НДС из книги покупок (за квартал)""" я разобрался,
    а вот с
    а вот с эим как быть незнаю???
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Какое еще условие? Сумму без НДС можно же взять при отборе с/фактур!
  4. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    может я че не понимаю вот код который я пытаюсь расковырять вы набейте по рукам где тут взять сумму без ндс??? :unsure: и вот еще фопрос сумма НДС (НДС_ПОКУПОК) по книге покупок блин почемуто не выводитсе в секции шапка или расчет а выводится только в подвале либо в самой таблице почему это может быть???? (НУ ЧАЙНИК Я ЕЩЁ :smile: )

    Код:
    Процедура РеестрНДС()
    
    ТабОтчета = СоздатьОбъект("ТаблицаЗначений");   
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Таб.ИсходнаяТаблица("Реестр");
    УстановленныйОтбор = "";
    Если СтандартнаяФорма = 0 Тогда
    Если ВыбКонтрагент.Выбран() = 1 Тогда
    УстановленныйОтбор = "Установлен отбор по контрагенту: "+СокрЛП(ВыбКонтрагент.Наименование);
    КонецЕсли;
    ТекстВШапке = "";
    КонецЕсли;
    
    Таб.ВывестиСекцию("Шапка"); 
    Таб.ВывестиСекцию("Расчеты"); 	
    Ит.Рассчитать(ДатаНачала,ДатаКонца);
    НДС_ПОКУПОК = Ит.ДО(СчетПоКоду("19"), "С");
    
    Таб.Опции(0,0,13,0, "Параметры печати Реестр НДС" );
    
    
    
    ТекстЗапроса = "Период с ДатаНачала по ДатаКонца;
    |ОбрабатыватьДокументы Все;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Док = Документ.ЗаписьКнигиПродаж.ТекущийДокумент,
    |      Документ.ЗаписьКнигиПродажТорг.ТекущийДокумент,
    |      Документ.СчетФактура.ТекущийДокумент;
    |Контрагент = Документ.ЗаписьКнигиПродаж.Контрагент,
    |             Документ.ЗаписьКнигиПродажТорг.Контрагент,
    |             Документ.СчетФактура.Контрагент;
    |Всего = Документ.ЗаписьКнигиПродаж.Всего,
    |        Документ.ЗаписьКнигиПродажТорг.ВсегоПродаж,
    |        Документ.СчетФактура.Всего;
    |ВсегоТорг = Документ.ЗаписьКнигиПродажТорг.ВсегоПродаж;
    |Сумма = Документ.ЗаписьКнигиПродаж.Сумма,
    |        Документ.СчетФактура.Сумма;
    |СтавкаНДС = Документ.ЗаписьКнигиПродаж.СтавкаНДС,
    |            Документ.ЗаписьКнигиПродажТорг.СтавкаНДС,
    |            Документ.СчетФактура.СтавкаНДС;
    |НДС = Документ.ЗаписьКнигиПродаж.НДС,
    |      Документ.ЗаписьКнигиПродажТорг.НДС,
    |      Документ.СчетФактура.НДС;
    |КВ = Документ.СчетФактура.КомиссионноеВознаграждение;
    |НДСКВ = Документ.СчетФактура.НДС_Вознаграждения;
    |НДСТорг = Документ.ЗаписьКнигиПродажТорг.НДС;
    |Товар = Документ.СчетФактура.Товар;
    |ВерсияСФ = Документ.СчетФактура.ВерсияОбъекта;
    |Счет68 = Документ.СчетФактура.СчетНДС;
    |СтавкаНоль = Документ.ЗаписьКнигиПродаж.НДСпоСтавкеНольПроцентов,
    |             Документ.ЗаписьКнигиПродажТорг.НДСпоСтавкеНольПроцентов,
    |             Документ.СчетФактура.НДСпоСтавкеНольПроцентов;
    |Экспорт = Документ.ЗаписьКнигиПродаж.Экспорт,Документ.ЗаписьКнигиПродажТорг.Экспорт,Документ.СчетФактура.Экспорт;
    |Группировка Док;
    |Функция ВсегоПродаж = Сумма(Пересчет(Док,Всего,КВ));
    |Функция НДС20 = Сумма(Пересчет(Док,НДС,НДСКВ)) Когда (СтавкаНДС.Ставка > 10.5);
    |Функция СуммаБезНДС20 = Сумма(Пересчет(Док,Сумма,КВ)) Когда (СтавкаНДС.Ставка > 10.5);
    |Функция СуммаБезНДС20Торг = Сумма(ВсегоТорг - НДСТорг) Когда (СтавкаНДС.Ставка = 20);
    |Функция СуммаБезНДС16Торг = Сумма(ВсегоТорг) Когда (СтавкаНДС.Ставка = 16.67);
    |Функция НДС10 = Сумма(Пересчет(Док,НДС,НДСКВ)) Когда ((СтавкаНДС.Ставка < 10.5) и (СтавкаНДС.Ставка > 0));
    |Функция СуммаБезНДС10 = Сумма(Пересчет(Док,Сумма,КВ)) Когда ((СтавкаНДС.Ставка < 10.5) и (СтавкаНДС.Ставка > 0));
    |Функция СуммаБезНДС10Торг = Сумма(ВсегоТорг - НДСТорг) Когда (СтавкаНДС.Ставка = 10);
    |Функция СуммаБезНДС09Торг = Сумма(ВсегоТорг) Когда (СтавкаНДС.Ставка = 9.09);
    |Функция НДС0 = Сумма(Пересчет(Док,Всего,КВ)) Когда (СтавкаНоль = 1);
    |Функция СуммаСовсемБезНДС = Сумма(Пересчет(Док,Всего,КВ)) Когда (СтавкаНДС = глБезНалога(""НДС""));
    |Условие (Счет68 = 1);
    |Условие ((ТоварНаКомиссии(Товар)=0) или (ВерсияСФ<""7.70.421""));
    |Условие (Экспорт = 1);
    //и (Экспортные=1) и (Обычные=0))  или ((Экспорт = 0) и (Экспортные=0) и (Обычные=1))  или ((Экспортные=1) и (Обычные=1)));
    |Условие (Всего <> 0);";
    Если СтандартнаяФорма = 0 Тогда
    Если ВыбКонтрагент.Выбран() = 1 Тогда
    ТекстЗапроса = ТекстЗапроса + "
    |Условие (Контрагент в ВыбКонтрагент);";
    КонецЕсли;
    КонецЕсли;
    
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Предупреждение("Невозможно выполнить запрос");
    Возврат;
    КонецЕсли;   
    
    Запрос.Выгрузить(ТабОтчета);
    ТабОтчета.НоваяКолонка("ДатаДок","Дата"); 
    ТабОтчета.НоваяКолонка("ДатаНомер"); 
    ТабОтчета.НоваяКолонка("ДатаОплаты");
    ТабОтчета.НоваяКолонка("Контрагент","Справочник.Контрагенты");
    ТабОтчета.НоваяКолонка("ДокументОснование");
    ТабОтчета.НоваяКолонка("Договор"); 
    ТабОтчета.НоваяКолонка("Номер_ГТД"); 
    ТабОтчета.НоваяКолонка("ВосстанавливатьНДС");
    ТабОтчета.НоваяКолонка("ПозицияДок"); 
    
    ТабОтчета.ВыбратьСтроки();
    Пока ТабОтчета.ПолучитьСтроку()=1 Цикл
    Если ПустоеЗначение(ТабОтчета.Док)=1 Тогда
    ТабОтчета.СуммаБезНДС20 	= ТабОтчета.СуммаБезНДС20 + ТабОтчета.СуммаБезНДС20Торг + ТабОтчета.СуммаБезНДС16Торг;
    ТабОтчета.СуммаБезНДС10 	= ТабОтчета.СуммаБезНДС10 + ТабОтчета.СуммаБезНДС10Торг + ТабОтчета.СуммаБезНДС09Торг;
    Продолжить;
    КонецЕсли;
    ТабОтчета.ДатаДок			= ТабОтчета.Док.ДатаДок;
    ТабОтчета.ДатаНомер			= ДатаНомер(ТабОтчета.Док); 
    ТабОтчета.ДатаОплаты		= ТабОтчета.Док.ДатаОплаты;
    ТабОтчета.Контрагент        = ТабОтчета.Док.Контрагент;
    ТабОтчета.ДокументОснование = ТабОтчета.Док.ДокументОснование;
    ТабОтчета.Договор			= ТабОтчета.Док.Договор;   
    ТабОтчета.Номер_ГТД			= ТабОтчета.Док.Номер_ГТД;
    ТабОтчета.ВосстанавливатьНДС= ТабОтчета.Док.ВосстанавливатьНДС;
    ТабОтчета.ПозицияДок		= ТабОтчета.Док.ПолучитьПозицию();
    
    ТабОтчета.СуммаБезНДС20 	= ТабОтчета.СуммаБезНДС20 + ТабОтчета.СуммаБезНДС20Торг + ТабОтчета.СуммаБезНДС16Торг;
    ТабОтчета.СуммаБезНДС10 	= ТабОтчета.СуммаБезНДС10 + ТабОтчета.СуммаБезНДС10Торг + ТабОтчета.СуммаБезНДС09Торг;
    КонецЦикла; 
    
    
    ДокАвто = СоздатьОбъект("Документ.ЗаписиКнигиПродаж");
    ДокАвто.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Всего 		= 0;
    БезНДС20 	= 0;
    НДС20 		= 0;
    БезНДС10	= 0;
    НДС10		= 0;
    НДС0		= 0;
    Освобождаемые = 0;
    
    Пока ДокАвто.ПолучитьДокумент()=1 Цикл
    Если ДокАвто.ПометкаУдаления()=1 Тогда
    Продолжить;
    КонецЕсли;
    ДокАвто.ВыбратьСтроки();
    Пока ДокАвто.ПолучитьСтроку() = 1 Цикл
    Если (ВыбКонтрагент.Выбран() = 1)и
    (ВыбКонтрагент<>ДокАвто.Контрагент)и
    (ДокАвто.Контрагент.ПринадлежитГруппе(ВыбКонтрагент)=0) Тогда
    Продолжить;
    КонецЕсли;
    
    Если (ДокАвто.ТипЗаписи = Перечисление.ТипыЗаписейКнигиПродаж.ВозвратНеОплаченного) Тогда
    Продолжить;
    КонецЕсли;
    
    ТабОтчета.НоваяСтрока();
    
    ТабОтчета.Док	 			= ДокАвто.ТекущийДокумент();
    ТабОтчета.ДатаДок			= ДокАвто.Оплата.ДатаДок;
    ТабОтчета.ДатаНомер			= ДокАвто.ДатаНомерСчетаФактуры; 
    ТабОтчета.ДатаОплаты		= ДокАвто.Оплата.ДатаДок;
    ТабОтчета.Контрагент        = ДокАвто.Контрагент;
    ТабОтчета.ИНН               = ДокАвто.Контрагент.ИНН;
    
    ТабОтчета.ПозицияДок		= ДокАвто.Оплата.ПолучитьПозицию();
    
    ТабОтчета.ВсегоПродаж 		= ДокАвто.Всего;
    ТабОтчета.СуммаБезНДС20 	= ДокАвто.БезНДС20;
    ТабОтчета.НДС20 			= ДокАвто.НДС20;
    ТабОтчета.СуммаБезНДС10 	= ДокАвто.БезНДС10;
    ТабОтчета.НДС10 			= ДокАвто.НДС10;
    ТабОтчета.НДС0 				= ДокАвто.НДС0;
    ТабОтчета.СуммаСовсемБезНДС = ДокАвто.Освобождаемые; 
    
    Всего 		= Всего + ДокАвто.Всего;
    БезНДС20 	= БезНДС20 + ДокАвто.БезНДС20;
    НДС20 		= НДС20 + ДокАвто.НДС20;
    БезНДС10 	= БезНДС10 + ДокАвто.БезНДС10;
    НДС10 		= НДС10 + ДокАвто.НДС10;
    НДС0		= НДС0 + ДокАвто.НДС0;
    Освобождаемые = Освобождаемые + ДокАвто.Освобождаемые;     
    ТабОтчета.УстановитьЗначение("ВсегоПродаж",Всего+ТабОтчета.ПолучитьЗначение("ВсегоПродаж"));
    
    КонецЦикла;
    КонецЦикла;
    
    ТабОтчета.УстановитьЗначение(1,"ВсегоПродаж",Всего+ТабОтчета.ПолучитьЗначение(1,"ВсегоПродаж"));
    ТабОтчета.УстановитьЗначение(1,"СуммаБезНДС20",БезНДС20+ТабОтчета.ПолучитьЗначение(1,"СуммаБезНДС20"));
    ТабОтчета.УстановитьЗначение(1,"НДС20",НДС20+ТабОтчета.ПолучитьЗначение(1,"НДС20"));
    ТабОтчета.УстановитьЗначение(1,"СуммаБезНДС10",БезНДС10+ТабОтчета.ПолучитьЗначение(1,"СуммаБезНДС10"));
    ТабОтчета.УстановитьЗначение(1,"НДС10",НДС10+ТабОтчета.ПолучитьЗначение(1,"НДС10"));
    ТабОтчета.УстановитьЗначение(1,"НДС0",НДС0+ТабОтчета.ПолучитьЗначение(1,"НДС0"));
    ТабОтчета.УстановитьЗначение(1,"СуммаСовсемБезНДС",Освобождаемые+ТабОтчета.ПолучитьЗначение(1,"СуммаСовсемБезНДС"));
    
    ТабОтчета.Сортировать("ПозицияДок");
    
    Ном = 1; 
    
    Если ГруппироватьПоКонтрагентам = 1 Тогда 
    ТабОтчета.Сортировать("Контрагент"); 
    Контр = " не контрагент ";
    КонецЕсли;
    ТабОтчета.ВыбратьСтроки();
    ТабОтчета.ПолучитьСтроку(); //пропустим строку итогов
    Пока ТабОтчета.ПолучитьСтроку()=1 Цикл 
    Если ГруппироватьПоКонтрагентам = 1 Тогда
    Если Контр<>ТабОтчета.Контрагент Тогда 
    Если Ном>1 Тогда 
    Таб.ВывестиСекцию("ВсегоКонтрагент"); 
    КонецЕсли;
    Таб.ВывестиСекцию("Контрагент"); 
    Контр=ТабОтчета.Контрагент; 
    ВсегоПродаж=0; 
    СуммаБезНДС20=0; 
    НДС20=0; 
    СуммаБезНДС10=0; 
    НДС10=0; 
    НДС0=0; 
    СуммаСовсемБезНДС=0; 
    КонецЕсли; 
    ВсегоПродаж=ВсегоПродаж+ТабОтчета.ВсегоПродаж; 
    СуммаБезНДС20=СуммаБезНДС20+ТабОтчета.СуммаБезНДС20; 
    НДС20=НДС20+ТабОтчета.НДС20; 
    СуммаБезНДС10=СуммаБезНДС10+ТабОтчета.СуммаБезНДС10; 
    НДС10=НДС10+ТабОтчета.НДС10; 
    НДС0=НДС0+ТабОтчета.НДС0; 
    СуммаСовсемБезНДС=СуммаСовсемБезНДС+ТабОтчета.СуммаСовсемБезНДС; 
    КонецЕсли; 
    Таб.ВывестиСекцию("Строка"); 
    Ном = Ном + 1; 
    КонецЦикла; 
    Если ГруппироватьПоКонтрагентам = 1 Тогда 
    Таб.ВывестиСекцию("ВсегоКонтрагент"); 
    КонецЕсли; 
    
    ТабОтчета.ПолучитьСтрокуПоНомеру(1);
    Таб.ВывестиСекцию("Всего");
    
    ГлБух = ФИО(Константа.ГлБухгалтер.Получить( ДатаКонца ));
    Таб.ВывестиСекцию("Подвал");
    Таб.ОбластьПечати(2);
    Таб.ПовторятьПриПечатиСтроки(13,13);
    Таб.ПараметрыСтраницы(1,,,,,,,,,1);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Реестр НДС","");
    
    КонецПроцедуры // реестр НДС()
    
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Запрос.Выгрузить(ТабОтчета);    
    ТабОтчета.НоваяКолонка("ДатаДок","Дата"); ТабОтчета.НоваяКолонка("ДатаНомер");     
    ТабОтчета.НоваяКолонка("ДатаОплаты");    
    ТабОтчета.НоваяКолонка("Контрагент","Справочник.Контрагенты");
    ТабОтчета.НоваяКолонка("ДокументОснование");
    ТабОтчета.НоваяКолонка("Договор");     
    ТабОтчета.НоваяКолонка("Номер_ГТД");     
    ТабОтчета.НоваяКолонка("ВосстанавливатьНДС");
    ТабОтчета.НоваяКолонка("ПозицияДок");     
    
    ТабОтчета.ВыбратьСтроки();    
    Пока ТабОтчета.ПолучитьСтроку()=1 Цикл
    //Вот здесть ты имеешь ссылку на документ. Проверяй что это 
    //импорт... и ВЭЛКАМ - можешь суммировать сумму без НДС из документа
    
    
    
  6. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    ребят чет я совсем запутался почему то у меня не выводится на печать "НДС_ПОКУПОК" она находится в секции расчеты??? :unsure: почему так???
    и еще вот сдесь не могу догнать"1 Отгружено товара всего без НДС по книге продаж:" хоть мне и Бухгалтерчский угодник показал где и что ну видно я совсем чайник!!!! У меня в запросе стоит условие
    |Условие (Экспорт = 1); тоесть я так понимаю запрашиваются документы с условием экспортные ????
    а мне то надо всю сумму реализации минус НДС !!!

    может так понятнее файлик кину!!!

    Вложения:

  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) не выводится потому что
    Код:
    //у тебя так  
    Таб.ВывестиСекцию("Шапка"); 
    Таб.ВывестиСекцию("Расчеты");     
    Ит.Рассчитать(ДатаНачала,ДатаКонца);
    НДС_ПОКУПОК = Ит.ДО(СчетПоКоду("19"), "С");
    //а надо так
    Таб.ВывестиСекцию("Шапка"); 
    Ит.Рассчитать(ДатаНачала,ДатаКонца);
    НДС_ПОКУПОК = Ит.ДО(СчетПоКоду("19"), "С");
    Таб.ВывестиСекцию("Расчеты");
    
    
    
    
    2) По запросу:
    Код:
    |Условие (Экспорт = 1); 
    
    
    
    Этим ты накладываешь условие НА ВЕСЬ ЗАПРОС.
    Если хочешь выцепить экспорт - включи это условие В ФУНКЦИЮ (ты же ее с успехом применяешь уже)

    Код:
    |Функция НДС20_Весь = Сумма(Пересчет(Док,НДС,НДСКВ)) Когда (СтавкаНДС.Ставка > 10.5);
    |Функция НДС20_Экспорт = Сумма(Пересчет(Док,НДС,НДСКВ)) Когда ((СтавкаНДС.Ставка > 10.5)И(Экспорт = 1));
    
    
    
    И еще....
    • Самое распоследнее дело вызывать внешнюю функцию внутри запроса.... ЖУТКИЕ ТОРМОЗА
    • Некорректно использовать зарезервированные слова для своих переменных - может выйти боком
  8. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    убрал условие экспорта
    // |Условие (Экспорт = 1);

    потом сделал так и вылазиет ошибка "Поле агрегатного объекта не обнаружено (Экспорт)"???
    Код:
        Запрос.Выгрузить(ТабОтчета);
    ТабОтчета.НоваяКолонка("ДатаДок","Дата"); 
    ТабОтчета.НоваяКолонка("ДатаНомер"); 
    ТабОтчета.НоваяКолонка("ДатаОплаты");
    ТабОтчета.НоваяКолонка("Контрагент","Справочник.Контрагенты");
    ТабОтчета.НоваяКолонка("ДокументОснование");
    ТабОтчета.НоваяКолонка("Договор"); 
    ТабОтчета.НоваяКолонка("Номер_ГТД"); 
    ТабОтчета.НоваяКолонка("ВосстанавливатьНДС");
    ТабОтчета.НоваяКолонка("ПозицияДок"); 
    ТабОтчета.ВыбратьСтроки();
    Пока ТабОтчета.ПолучитьСтроку()=1 Цикл   
    Если ТабОтчета.Док.Экспорт=1 Тогда 
    ОтгрОбычБезНДС=ТабОтчета.СуммаБезНДС20+ТабОтчета.СуммаБезНДС10+ТабОтчета.НДС0+ТабОтчета.СуммаСовсемБезНДС;
    иначе 
    ОтгрЭкспБезНДС=ТабОтчета.СуммаБезНДС20+ТабОтчета.СуммаБезНДС10+ТабОтчета.НДС0+ТабОтчета.СуммаСовсемБезНДС;
    конецЕсли;    
    ТаСумма= ОтгрЭкспБезНДС+ ОтгрОбычБезНДС;
    Если ПустоеЗначение(ТабОтчета.Док)=1 Тогда 
    ТабОтчета.СуммаБезНДС20     = ТабОтчета.СуммаБезНДС20 + ТабОтчета.СуммаБезНДС20Торг + ТабОтчета.СуммаБезНДС16Торг;
    ТабОтчета.СуммаБезНДС10     = ТабОтчета.СуммаБезНДС10 + ТабОтчета.СуммаБезНДС10Торг + ТабОтчета.СуммаБезНДС09Торг;             
    
    
    
    похоже я какуюто фигню сделал!!!!
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    ТабОтчета.ВыбратьСтроку();
    //смотрите что у вас выгрузилось из запроса...
    
    
  10. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    подскажите как в цикле отобрать только экспортные документы ???

    Код:
    Пока ТабОтчета.ПолучитьСтроку()=1 Цикл 
    ********
    Если ТабОтчета.Док.Вид()="(((СчетФактура с флажком экспорт)))" тогда
    внести в таблицу иначе пропустить?????
    ******
    Таб.ВывестиСекцию("Строка"); 
    Ном = Ном + 1; 
    КонецЦикла; 
    
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что-то недопонял. М.б. Так?
    Код:
    Пока ТабОтчета.ПолучитьСтроку()=1 Цикл 
    Если ТабОтчета.Док.Вид()="СчетФактура" тогда
    Если ОпределитьФлагЭкспорта Тогда
    Таб.ВывестиСекцию("Строка"); 	
    Ном = Ном + 1; 
    КонецЕсли;
    КонецЕсли;
    КонецЦикла; 
    
    
  12. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    ОК! спасибо все работает!!!
    Только вот вопрос о сумме НДС вы мне посоветовали сделать через бух итоги взять сумму со счета но проблема в том что бухи сторонируют документы и там это не отражается тоесть + НДС с аванса тоже там и в итоге сумма НДС получается больше чем в книге покупок как всетаки добыть данные с которые попдают в книгу покупок отдельным запросом или можно добавить параметры в существующий запрос???
    или можно еще как нибудь????
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Каким образом они делают сторнирование и ЗАЧЕМ?
  14. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Если честно даже не знаю конфу кто то писал еще до меня на базе Бух учет 4.4. так что с какой целью это все сделано даже и незнаю блин неужеле одному мне так невезет устраивался на одну контору а сдесь их оказалось целых 4 + по каждой 3 базы 1С.
    Главбух говорит да это все правельно сделано но у нас подругому надо чтобы данные поподали отдуда(книга покупок НДС20+НДС10)!!!
  15. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Спасибо огромное Тема закрыта вопрос решился вот таким обычным способом!!!
    Код:
        //****
    Дока = СоздатьОбъект("Документ.ЗаписьКнигиПокупок");
    Дока.ВыбратьДокументы(ДатаНачала,ДатаКонца);  
    Ндс1=0;
    Ндс2=0; 
    сумм1=0;
    сумм2=0;
    сумм3=0;
    Пока Дока.ПолучитьДокумент() = 1 Цикл   
    Если Дока.Проведен()=0 Тогда
    Продолжить;
    КонецЕсли;
    Дока.ВыбратьСтроки();
    Ндс1=Дока.НДС20;
    Ндс2=Дока.Ндс10; 
    сумм1=сумм1+Ндс1;
    сумм2=сумм2+Ндс2; 
    сумм3=сумм1+сумм2;   
    КонецЦикла;  
    //**** 
    НДС_ПОКУПОК= сумм3 - ит76;
    
    
    Всем огромное спасибо!!!!!!

Поделиться этой страницей