7.7 добавления в модуль (счёт-фактуру)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем rom-pro, 23 апр 2009.

  1. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    1с7,7 бухучёт 2,5
    здравствуите,можно ли вставить в документ счёт-фактура(модуль) печатную форму Счёта,не перинася всё Шапку... или добавить в Выбор печатной формы,чтоб при нажатии выходил и Счёт или при нажатие другой кнопке(создать кнопку)...sample.gif (и возможна ли это в принципе ):)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Реально... Если в самаой структуре подчиненности документов присутствует счет (иначе откуда возьмешь номер счета)))))..... Если номер не важен (равен СФ) то можно и так
  3. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    может ток да подскажите как записать правильно чтоб при нажатие кнопки выходил счёт...кнопку создал... :unsure:
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Зачем! Есть же регистрация внешних печатных форм....... Не изменяй без необходимости стандартную конфу!
    А насчет счета в каталоге БД есть ExtForms\PrnForms в ней есть стандартные внешние формы докуметов. Возми любую в качестве образца для написания своей!
  5. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    в том вся проблема что она уже написана,но шефу надо чтоб при открытие счёт-фактуры при печати выходил и счёт с заполненными палями.... :unsure:
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Так сказать в одной таблице 2 документа??? И печать на одном листе или в разных таблицах, но по нажатию одной кнопки?
  7. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    счет фактура\печать\счет фактура+счёт поставщика товара
    Печать на двух листах, разных таблиц, на одном счет фактура на другом счет, но по нажатию одной кнопки (печать)....
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Проще всего так если уже как ты сказал что печать счета есть
    1) Вставь обработку внутрь конфигурации
    2) В просцедуре СФ Печать() вызывай эту обработку. Незабудь, что передавать в качестве параметра нужно Контекст, а не ТекущийДокумент()
  9. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    распиши по поподробнее (что куда)... я вписывал но у меня постоянна ошибка... весь день голаву ламаю а завтра надо дать ответ.... :unsure:

    счёт фактуру на да впихнуть сюда...
    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    [color=green]// #Переменные ****************************************************************[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВидСчетаФактуры[color=red];[/color] [color=green]// вид документа, являющегося счетом-фактурой[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> КонтекстОснования[color=red];[/color]	[color=green]// контекст формы документа - основания[/color]
    
    [color=green]// Для контроля необходимости пересчетов[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СтараяОрганизация[color=red],[/color] СтароеОснование[color=red],[/color] СтарыйКонтрагент[color=red];[/color]
    
    [color=green]// для контроля изменений при записи [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НачКонтрагент[color=red],[/color] НачДоговор[color=red],[/color] НачФирма[color=red];[/color]
    
    [color=green]//Для печати документов[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ТаблицаПечФорм[color=red];[/color]  [color=green]// список печатных форм документа[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НомерТекущейФормы[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриВыбореКонтрагента[color=red]([/color][color=red])[/color] Далее  
    
    [color=green]// #Форма *********************************************************************[/color]
    [color=green]//[/color]
    [color=green]// ОбновитьНадписи()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//   Обновляет текст информационных надписей в форме документа[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбновитьНадписи[color=red]([/color][color=red])[/color]
    
    Форма[color=red].[/color]ТекстОплаты[color=red].[/color]Заголовок[color=red]([/color]глСтрокаОплаты[color=red]([/color]Контекст[color=red])[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ТекстРеквизитовВходящегоДокумента[color=red].[/color]Заголовок[color=red]([/color]глПредставлениеВходящегоДокумента[color=red]([/color]Контекст[color=red])[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//ОбновитьНадписи()    [/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ПоКнопкеЦены()[/color]
    [color=green]// [/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Вызывается по кнопке редактирования параметров оплаты в документе[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеЦены[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> КонтекстДокумента[color=red];[/color]
    
    ОткрытьФормуМодально[color=red]([/color][color=black]"Обработка.ИнформацияОценах"[/color][color=red],[/color] Контекст[color=red])[/color][color=red];[/color]
    ОбновитьНадписи[color=red]([/color][color=red])[/color][color=red];[/color]    
    
    КонецПроцедуры	[color=green]//ПоКнопкеЦены()    [/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ПоКнопкеОснование()[/color]
    [color=green]// [/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Вызывается по кнопке выбора документа основания                  [/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеОснование[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ДокОснование[color=red];[/color]
    
    [color=green]// если документ основание уже есть, откроем его[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]ДокументОснование[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОткрытьФорму[color=red]([/color]ДокументОснование[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    [color=green]// если документа - основания нет, позволяем выбрать его[/color]
    ДокОснование [color=red]=[/color] глВыбратьОснование[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]ДокОснование[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    ТекстВопроса [color=red]=[/color] [color=black]"Заполнить по документу основанию?"[/color][color=red];[/color]
    
    [color=green]// Выбрали основание[/color]
    глЗаполнитьШапкуНаОсн[color=red]([/color]Контекст[color=red],[/color] ДокОснование[color=red],[/color] [color=red],[/color] [color=black]1[/color][color=red])[/color][color=red];[/color]
    
    ПриВыбореКонтрагента[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> [color=red]([/color]СтароеОснование [color=red]<[/color][color=red]>[/color] Основание[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]ПустоеЗначение[color=red]([/color]Основание[color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтароеОснование	[color=red]=[/color] Основание[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    ОбновитьНадписи[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//ПоКнопкеОснование()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПриИзмененииОрганизации()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание: [/color]
    [color=green]//  Вызывается из формулы реквизита диалога "Организация"[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриИзмененииОрганизации[color=red]([/color][color=red])[/color]      
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтараяОрганизация [color=red]<[/color][color=red]>[/color] Организация <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// только если изменили[/color]
    глПриИзмененииОрганизации[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    СтараяОрганизация [color=red]=[/color] Организация[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриИзмененииОрганизации()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПриВыбореСчета()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Устанавливает значение реквизита справочника "Счет"[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриВыбореСчета[color=red]([/color][color=red])[/color]
    
    Валютность [color=red]=[/color] Счет[color=red].[/color]Валютный[color=red];[/color]
    Валюта_Прежн [color=red]=[/color] Валюта[color=red];[/color]
    Курс_Прежн [color=red]=[/color] глКурсДляВалюты[color=red]([/color]Валюта_Прежн[color=red],[/color] ДатаДок[color=red])[/color][color=red];[/color]
    Счет_Прежн [color=red]=[/color] Счет[color=red];[/color]
    
    [color=green]// устанавливаем значение реквизита "Счет" в соответсвии с выбранным счетом[/color]
    [color=green]// в СпискеСчетов [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Счет [color=red]<[/color][color=red]>[/color] СписокСчетов[color=red].[/color]ПолучитьЗначение[color=red]([/color]СписокСчетов[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    Счет [color=red]=[/color] СписокСчетов[color=red].[/color]ПолучитьЗначение[color=red]([/color]СписокСчетов[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Счет[color=red].[/color]Валютный [color=red]<[/color][color=red]>[/color] Валютность <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> [color=red]([/color]Счет[color=red].[/color]Валютный [color=red]=[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Валюта [color=red]<[/color][color=red]>[/color] глВалютаБухУчета[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстВопроса [color=red]=[/color] 					[color=black]"Валюта счета отличается от установленной ранее в документе! "[/color][color=red];[/color]
    ТекстВопроса [color=red]=[/color] ТекстВопроса [color=red]+[/color]	[color=black]"Строки документа будут пересчитаны!"[/color] [color=red]+[/color] РазделительСтрок[color=red];[/color]
    ТекстВопроса [color=red]=[/color] ТекстВопроса [color=red]+[/color]	[color=black]"Продолжить выполнение операции?"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> Вопрос[color=red]([/color]ТекстВопроса[color=red],[/color] [color=black]"Да+Нет"[/color][color=red])[/color] [color=red]=[/color] [color=black]"Нет"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Счет [color=red]=[/color] Счет_Прежн[color=red];[/color]
    СписокСчетов[color=red].[/color]ТекущаяСтрока[color=red]([/color]СписокСчетов[color=red].[/color]НайтиЗначение[color=red]([/color]Счет[color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">					Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    [color=green]//значит нужно пересчитать[/color]
    Валюта [color=red]=[/color] глВалютаБухУчета[color=red];[/color]
    Курс [color=red]=[/color] глКурсДляВалюты[color=red]([/color]Валюта[color=red],[/color] ДатаДок[color=red])[/color][color=red];[/color][color=red];[/color]
    
    глПересчитатьСтрокиДокумента[color=red]([/color]Контекст[color=red],[/color] Валюта_Прежн[color=red],[/color] Курс_Прежн[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    ОбновитьНадписи[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриВыбореСчета()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПриИзмененииОснования()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание: [/color]
    [color=green]//  Процедура вызывается при смене договора.[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриИзмененииОснования[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтароеОснование [color=red]<[/color][color=red]>[/color] Основание <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>    
    глПриИзмененииОснования[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    СтароеОснование [color=red]=[/color] Основание[color=red];[/color]
    ОбновитьНадписи[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриИзмененииОснования()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПриВыбореКонтрагента()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Процедура вызывается при выборе контрагента[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриВыбореКонтрагента[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтарыйКонтрагент [color=red]<[/color][color=red]>[/color] Контрагент <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    глПриИзмененииКонтрагента[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    СтарыйКонтрагент [color=red]=[/color] Контрагент[color=red];[/color]
    [color=green]// если изменился контрагент, то договор тоже изменится[/color]
    СтароеОснование [color=red]=[/color] Основание[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]     
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриВыбореКонтрагента()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// РассчитатьАванс()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Рассчитывает сумму для зачета аванса[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> РассчитатьАванс[color=red]([/color][color=red])[/color]
    
    [color=green]//краткосрочная задолженность[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Счет[color=red].[/color]ПринадлежитГруппе[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"33"[/color][color=red])[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СчетЗапроса [color=red]=[/color] СчетПоКоду[color=red]([/color][color=black]"161"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    [color=green]//долгосрочная задолженность[/color]
    СчетЗапроса [color=red]=[/color] СчетПоКоду[color=red]([/color][color=black]"291"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    ВалютаЗапроса [color=red]=[/color] Валюта[color=red];[/color]
    
    СуммаАванса [color=red]=[/color] глПолучитьСальдоНаДокумент[color=red]([/color]Контекст[color=red],[/color] СчетЗапроса[color=red],[/color] ВалютаЗапроса[color=red],[/color] [color=black]"Контрагенты, Основания"[/color][color=red],[/color] Контрагент[color=red],[/color] Основание[color=red],[/color][color=red],[/color] [color=black]"Д"[/color][color=red])[/color][color=red];[/color][color=red];[/color]   
    СуммаАванса [color=red]=[/color] Мин[color=red]([/color]СуммаАванса[color=red],[/color]Итог[color=red]([/color][color=black]"Сумма"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// РассчитатьАванс()  [/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// Заполнить()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  заполняет табличную часть документа[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> Заполнить[color=red]([/color][color=red])[/color]
    
    Параметры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Контекст[color=red],[/color]		[color=black]"Контекст"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Организация[color=red],[/color]     [color=black]"Организация"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Склад[color=red],[/color]           [color=black]"Склад"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]"Да"[/color][color=red],[/color]			[color=black]"ЦенаВподборе"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Валюта[color=red],[/color]          [color=black]"Валюта"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Курс[color=red],[/color]            [color=black]"Курс"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]"132,133,135"[/color][color=red],[/color][color=black]"Счет"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]"Номенклатура"[/color][color=red],[/color]	[color=black]"ВидТМЦ"[/color][color=red])[/color][color=red];[/color]
    
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]"Подбор номенклатуры в документ "[/color] [color=red]+[/color] ПредставлениеВида[color=red]([/color][color=red])[/color] [color=red]+[/color] [color=black]" № "[/color] [color=red]+[/color] НомерДок[color=red],[/color] [color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    глПодбор[color=red]([/color]Контекст[color=red],[/color] Параметры[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// Заполнить()[/color]
    
    
    [color=green]// #Печать *********************************************************************[/color]
    [color=green]// Печать()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Процедура печати документа[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> Печать[color=red]([/color]СразуНаПринтер [color=red]=[/color] [color=black]0[/color][color=red],[/color]КолЭкз [color=red]=[/color] [color=black]1[/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span>  ПустоеЗначение[color=red]([/color]НомерТекущейФормы[color=red])[/color] [color=red]=[/color] [color=black]1[/color]  <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НомерТекущейФормы [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    Форма[color=red].[/color]кнПечать[color=red].[/color]Заголовок[color=red]([/color]ТаблицаПечФорм[color=red].[/color]ПолучитьЗначение[color=red]([/color]НомерТекущейФормы[color=red],[/color] [color=black]"Кнопка"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Таб [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    
    ИмяФайлаПечатнойФормы [color=red]=[/color] КаталогИБ[color=red]([/color][color=red])[/color][color=red]+[/color][color=black]"ExtForms\PrnForms\prfpltv.mxl"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]Константа[color=red].[/color]ИспользоватьВнешниеПечатныеФормы [color=red]=[/color] Да[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]ФС[color=red].[/color]СуществуетФайл[color=red]([/color]ИмяФайлаПечатнойФормы[color=red])[/color] [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color]ИмяФайлаПечатнойФормы[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> [color=red]([/color]Счет[color=red].[/color]Валютный [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]Валюта [color=red]<[/color][color=red]>[/color] глВалютаБухУчета[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    ПечЦена			[color=red]=[/color] ФорматС[color=red]([/color]глПересчет[color=red]([/color]Цена[color=red],[/color]		Валюта[color=red],[/color] Курс[color=red],[/color] глВалютаБухУчета[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    ПечСумма		[color=red]=[/color] ФорматС[color=red]([/color]глПересчет[color=red]([/color]Сумма[color=red],[/color]		Валюта[color=red],[/color] Курс[color=red],[/color] глВалютаБухУчета[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    ПечСуммаНДС		[color=red]=[/color] ФорматС[color=red]([/color]глПересчет[color=red]([/color]СуммаНДС[color=red],[/color]	Валюта[color=red],[/color] Курс[color=red],[/color] глВалютаБухУчета[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    
    ПечЦенаВал		[color=red]=[/color] глФРМ[color=red]([/color]Цена[color=red],[/color]		Валюта[color=red])[/color][color=red];[/color]
    ПечСуммаВал		[color=red]=[/color] глФРМ[color=red]([/color]Сумма[color=red],[/color]		Валюта[color=red])[/color][color=red];[/color]
    ПечСуммаНДСВал	[color=red]=[/color] глФРМ[color=red]([/color]СуммаНДС[color=red],[/color]	Валюта[color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"СтрокаВал"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    ПечЦена			[color=red]=[/color] ФорматС[color=red]([/color]Цена[color=red])[/color][color=red];[/color]
    ПечСумма		[color=red]=[/color] ФорматС[color=red]([/color]Сумма[color=red])[/color][color=red];[/color]
    ПечСуммаНДС		[color=red]=[/color] ФорматС[color=red]([/color]СуммаНДС[color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]Счет[color=red].[/color]Валютный [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]Валюта [color=red]<[/color][color=red]>[/color] глВалютаБухУчета[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ПечИтогСумма		[color=red]=[/color] ФорматС[color=red]([/color]глПересчет[color=red]([/color]Итог[color=red]([/color][color=black]"Сумма"[/color][color=red])[/color][color=red],[/color]		Валюта[color=red],[/color] Курс[color=red],[/color] глВалютаБухУчета[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    ПечИтогСуммаНДС		[color=red]=[/color] ФорматС[color=red]([/color]глПересчет[color=red]([/color]Итог[color=red]([/color][color=black]"СуммаНДС"[/color][color=red])[/color][color=red],[/color]	Валюта[color=red],[/color] Курс[color=red],[/color] глВалютаБухУчета[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итоги"[/color][color=red])[/color][color=red];[/color]
    
    ПечИтогСуммаВал		[color=red]=[/color] ФорматС[color=red]([/color]Итог[color=red]([/color][color=black]"Сумма"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    ПечИтогСуммаНДСВал	[color=red]=[/color] ФорматС[color=red]([/color]Итог[color=red]([/color][color=black]"СуммаНДС"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"ИтогиВал"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ПечИтогСумма		[color=red]=[/color] ФорматС[color=red]([/color]Итог[color=red]([/color][color=black]"Сумма"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    ПечИтогСуммаНДС		[color=red]=[/color] ФорматС[color=red]([/color]Итог[color=red]([/color][color=black]"СуммаНДС"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итоги"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Подвал"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color] [color=black]"ОпцииПоступлениеТоваров"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]2[/color][color=red])[/color][color=red];[/color]
    
    глЗащитаТаблицы[color=red]([/color]Таб[color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Показать[color=red]([/color][color=black]"Печать приходной накладной"[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// Печать()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПоКнопкеПечать()[/color]
    [color=green]// [/color]
    [color=green]// Параметры: [/color]
    [color=green]//	Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Вызывается по кнопке "Печать"  [/color]
    [color=green]// 	  [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеПечать[color=red]([/color]СразуНаПринтер [color=red]=[/color] [color=black]0[/color][color=red],[/color]КолЭкз [color=red]=[/color] [color=black]1[/color][color=red])[/color]
    [color=green]// проверим полномочия печати непроведенных документов[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span>  ПустоеЗначение[color=red]([/color]НомерТекущейФормы[color=red])[/color] [color=red]=[/color] [color=black]1[/color]  <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НомерТекущейФормы [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    Форма[color=red].[/color]кнПечать[color=red].[/color]Заголовок[color=red]([/color]ТаблицаПечФорм[color=red].[/color]ПолучитьЗначение[color=red]([/color]НомерТекущейФормы[color=red],[/color] [color=black]"Кнопка"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> НомерТекущейФормы [color=red]=[/color] [color=black]1[/color]  <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Печать[color=red]([/color]СразуНаПринтер[color=red],[/color] КолЭкз[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Параметры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Контекст[color=red],[/color] [color=black]"Контекст"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]СразуНаПринтер[color=red],[/color] [color=black]"Устройство"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]КолЭкз[color=red],[/color] [color=black]"КоличествоКопий"[/color][color=red])[/color][color=red];[/color]
    
    ОткрытьФорму[color=red]([/color][color=black]"Отчет"[/color][color=red],[/color] Параметры[color=red],[/color] глКаталогПечФорм[color=red]+[/color]ТаблицаПечФорм[color=red].[/color]ПолучитьЗначение[color=red]([/color]НомерТекущейФормы[color=red],[/color][color=black]"Файл"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПоКнопкеПечать()  [/color]
    
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПоКнопкеВыборПечатнойФормы()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  нет.    [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  нет.[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  - открывает список для выбора способа печати. [/color]
    [color=green]//  - формирует таблицу по выбранному способу.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеВыборПечатнойФормы[color=red]([/color][color=red])[/color]
    
    ВыбНомер [color=red]=[/color] глВыборПечатнойФормы[color=red]([/color][color=black]"Документ."[/color] [color=red]+[/color] Вид[color=red]([/color][color=red])[/color][color=red],[/color] ТаблицаПечФорм[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ВыбНомер [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НомерТекущейФормы [color=red]=[/color] ВыбНомер[color=red];[/color]
    Форма[color=red].[/color]кнПечать[color=red].[/color]Заголовок[color=red]([/color]ТаблицаПечФорм[color=red].[/color]ПолучитьЗначение[color=red]([/color]НомерТекущейФормы[color=red],[/color] [color=black]"Кнопка"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    ПоКнопкеПечать[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПоКнопкеВыборПечатнойФормы()[/color]
    
    
    [color=green]// #Предопределенные **********************************************************[/color]
    [color=green]//       [/color]
    [color=green]//*****************************************************************************[/color]
    [color=green]// ОбработкаПодбора()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//	Элемент - Выбранный в подборе элемент[/color]
    [color=green]//[/color]
    [color=green]// Вызывается: [/color]
    [color=green]//	При обработке подбора в форме[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//	Добавляет в табличную часть документа элементы, выбранные в подборе[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбработкаПодбора[color=red]([/color]Элемент[color=red])[/color]
    
    глОбработкаПодбора[color=red]([/color]Контекст[color=red],[/color] Элемент[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ОбработкаПодбора()[/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]//[/color]
    [color=green]// ПриВыбореЗакладки()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: Номер - номер закладки, Значение - значение выбранной закладки формы[/color]
    [color=green]// Вызывается: При выборе закладки[/color]
    [color=green]// Описание:[/color]
    [color=green]//		Устанавливает видимость слоев формы[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриВыбореЗакладки[color=red]([/color]Номер[color=red],[/color] Значение[color=red])[/color]
    
    глПриВыбореЗакладки[color=red]([/color]Контекст[color=red],[/color] Номер[color=red],[/color] Значение[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриВыбореЗакладки()[/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ВводНового()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: Признак копирования[/color]
    [color=green]// Описание:[/color]
    [color=green]//		Предопределенная процедура при вводе нового документа.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ВводНового[color=red]([/color]ПризнакКопирования[color=red])[/color]
    
    ВСтатус [color=red]=[/color] глПроцедураДокумента[color=red]([/color][color=black]"ВводНового"[/color][color=red],[/color] глПараметры[color=red]([/color]Контекст[color=red],[/color] [color=red],[/color][color=black]"ПризнакКопирования"[/color][color=red],[/color] ПризнакКопирования[color=red],[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    СтатусВозврата[color=red]([/color]ВСтатус[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ВводНового()[/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ВводНаОсновании()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: Документ основание[/color]
    [color=green]// Описание:[/color]
    [color=green]//		Предопределенная процедура при вводе документа на основании[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ВводНаОсновании[color=red]([/color]ДокОснование[color=red])[/color]
    
    ВСтатус [color=red]=[/color] глПроцедураДокумента[color=red]([/color][color=black]"ВводНаОсновании"[/color][color=red],[/color] глПараметры[color=red]([/color]Контекст[color=red],[/color] [color=red],[/color][color=black]"ДокОснование"[/color][color=red],[/color] ДокОснование[color=red],[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    СтатусВозврата[color=red]([/color]ВСтатус[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ВводНаОсновании()[/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ПриОткрытии()[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//		Предопределенная процедура при открытии документа[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриОткрытии[color=red]([/color][color=red])[/color]
    
    ВСтатус [color=red]=[/color] глПроцедураДокумента[color=red]([/color][color=black]"ПриОткрытии"[/color][color=red],[/color] глПараметры[color=red]([/color]Контекст[color=red],[/color] [color=red],[/color][color=black]"Режим"[/color][color=red],[/color] [color=black]1[/color][color=red],[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    СтатусВозврата[color=red]([/color]ВСтатус[color=red])[/color][color=red];[/color] 
    
    [color=green]// Заполним таблицу для выбора печатной формы[/color]
    НомерТекущейФормы [color=red]=[/color] глУстановкаКнопкиПечать[color=red]([/color]Контекст[color=red],[/color] [color=black]"Документ."[/color] [color=red]+[/color] Вид[color=red]([/color][color=red])[/color][color=red],[/color]ТаблицаПечФорм[color=red])[/color][color=red];[/color]
    
    [color=green]//заполняем список счетов[/color]
    СписокСчетов[color=red].[/color]УдалитьВсе[color=red]([/color][color=red])[/color][color=red];[/color]
    
    [color=green]// Краткосрочная задолженность[/color]
    [color=green]// поступление от поставщиков[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"331"[/color][color=red])[/color][color=red],[/color][color=black]"(3310) "[/color] [color=red]+[/color] [color=black]"Краткосрочная задолженность поставщикам и подрядчикам"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]// поступление от дочерних,зависимых организаций[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"332"[/color][color=red])[/color][color=red],[/color][color=black]"(3320) "[/color][color=red]+[/color][color=black]"Краткосрочная кредиторская задолженность дочерним организациям"[/color][color=red])[/color][color=red];[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"333"[/color][color=red])[/color][color=red],[/color][color=black]"(3330) "[/color][color=red]+[/color][color=black]"Краткосрочная кредиторская задолженность ассоциированным и совместным организациям"[/color][color=red])[/color][color=red];[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"334"[/color][color=red])[/color][color=red],[/color][color=black]"(3340) "[/color][color=red]+[/color][color=black]"Краткосрочная кредиторская задолженность филиалам и структурным подразделениям"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]//Прочие расчеты с контрагентами[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"3397"[/color][color=red])[/color][color=red],[/color][color=black]"(3397) "[/color] [color=red]+[/color] [color=black]"Прочая краткосрочная кредиторская задолженность"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]// Долгосрочная задолженность[/color]
    [color=green]// поступление от поставщиков[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"411"[/color][color=red])[/color][color=red],[/color][color=black]"(4110) "[/color] [color=red]+[/color] [color=black]"Долгосрочная задолженность поставщикам и подрядчикам"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]// поступление от дочерних,зависимых организаций[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"412"[/color][color=red])[/color][color=red],[/color][color=black]"(4120) "[/color][color=red]+[/color][color=black]"Долгосрочная кредиторская задолженность дочерним организациям"[/color][color=red])[/color][color=red];[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение[color=red]([/color]СчетПоКоду[color=red]([/color][color=black]"413"[/color][color=red])[/color][color=red],[/color][color=black]"(4130) "[/color][color=red]+[/color][color=black]"Долгосрочная кредиторская задолженность ассоциированным и совместным организациям"[/color][color=red])[/color][color=red];[/color]
    СписокСчетов[color=red].[/color]ДобавитьЗначение<span st
  10. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Хорошо, что глобальный не выложил.....
    *шепотом* ребята, не рассказывайте где он....
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ГЫ-ГЫ! Парень же учится, но с текстом конечно перебрал))))))

    В процедуре ПоКнопкеПечать() последеней строчной добавь
    Код:
    ОткрытьФорму("Очет.ПечатьСФ",Контекст);
    
    
    ПечатьСФ это твоя обработка печати счет фактуры вставленная в конфу в виде отчета (ты сказал что написана)

    Это сработает в любом случае. Если идет печать через внешнюю (зарегистрированную через "Регистрация внешних печатных форм") так и через встроенную печать
  12. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    спасибо за ответ,но не работает!!!может я что то не так делаю... вставил в процедуре
    Код:
     ПоКнопкеПечать()
    ...
    ОткрытьФорму("Очет.ПечатьСФ",Контекст);
    
    
    не запускается вообще нечего... Форма печатьСФ есть но она записана как Внешний отчёт (обработка)...
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Так ВСТАВЬ в конфигурацию. Встань на отчеты правая кнопка мышки - вставить внешний отчет....
  14. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    ВСТАВИЛ не запускается всё равно!! прописываю любой другой отчёт тоже самое.... сделал отдельную кнопку тоже самое не каких действии, в ней попробовал прописать как документ ("Документ.СчетФактура",Контекст); открывает...
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выложи сюда свой отчет печати СФ
  16. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Код:
    //******************************************************************************
    // Печать(Докум)
    //
    // Параметры:
    //  Нет
    //
    // Возвращаемое значение:
    //  Нет
    //
    // Описание:
    //
    Процедура Печать(Докум, Устройство=0, КолвоКопий=1)
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    
    Докум.Контрагент.ИспользоватьДату(Докум.ДатаДок); 
    
    СтрГрузополучатель = "";
    СтрГрузоотправитель = "";
    СтрТТН = "";
    
    Если (Докум.ТипНоменклатуры <> Перечисление.ТипыНоменклатуры.Услуга) и 
    (Докум.ТипНоменклатуры <> Перечисление.ТипыНоменклатуры.Работа) Тогда 
    
    СтрТТН = ?((Докум.ДокументОснование.Выбран()=1),"№ "+СокрЛП(глНомерДокумента(Докум.ДокументОснование))+" от "
    +Формат(Докум.ДокументОснование.ДатаДок, "Д ДДММММГГГГ"),"№ _____________  от ____________________  200__ г.");
    
    СтрГрузоотправитель = ?(Докум.Грузоотправитель.Выбран() = 1, СокрЛП(Докум.Грузоотправитель.ПолноеНаименование) +
    ". РНН и адрес грузоотправителя: " + Докум.Грузоотправитель.РНН +
    ", " + СокрЛП(Докум.Грузоотправитель.ЮридическийАдрес), СокрЛП(Докум.Организация.ПолноеНаименование) + 
    ". РНН и адрес грузоотправителя: " + Докум.Организация.РНН +", " + СокрЛП(Докум.Организация.ЮридическийАдрес));
    СтрГрузополучатель = СокрЛП(Докум.Грузополучатель.ПолноеНаименование) + ". РНН и адрес грузополучателя: " + 
    Докум.Грузополучатель.РНН + ", "+ СокрЛП(Докум.Грузополучатель.ЮридическийАдрес);                      
    КонецЕсли;//Если (Докум.ТипНоменклатуры  Перечисление.ТипыНоменклатуры.Услуга) и 
    
    //Уполномоченные лица
    Если Докум.УполномоченноеЛицоРуководитель.Выбран() = 1 Тогда
    УполномоченноеЛицоРуководительПеч = СокрЛП(Докум.УполномоченноеЛицоРуководитель.Должность) +": "+ ФИО(Докум.УполномоченноеЛицоРуководитель);
    Иначе
    УполномоченноеЛицоРуководительПеч = "Руководитель организации: "+ ФИО(Докум.Организация.Руководитель.Получить(Докум.ДатаДок));
    КонецЕсли;
    
    Если Докум.УполномоченноеЛицоГлавныйБухгалтер.Выбран() = 1 Тогда
    УполномоченноеЛицоГлавныйБухгалтерПеч = СокрЛП(Докум.УполномоченноеЛицоГлавныйБухгалтер.Должность) +": "+ ФИО(Докум.УполномоченноеЛицоГлавныйБухгалтер);
    Иначе
    УполномоченноеЛицоГлавныйБухгалтерПеч = "Главный бухгалтер организации: " + ?(ПустаяСтрока(Докум.Организация.ГлавныйБухгалтер.Получить(Докум.ДатаДок))=0, ФИО(Докум.Организация.ГлавныйБухгалтер.Получить(Докум.ДатаДок)), "Не предусмотрен");
    КонецЕсли;
    
    ТекстВалюта = "тенге";
    Если ПустоеЗначение(Докум.Валюта) = 0 Тогда
    Если Докум.Валюта <> глВалютаБухУчета Тогда
    ТекстВалюта = Докум.Валюта.Наименование; 
    КонецЕсли;
    КонецЕсли;
    
    ДопСчетФактура = "";
    
    Если Докум.Дополнительная = 1 Тогда
    Если Докум.ДокументОснование.Выбран() = 1 Тогда
    Если Докум.ДокументОснование.Вид() = "ВозвратОтПокупателя" тогда
    Если Докум.ДокументОснование.ДокументОснование.Выбран() = 1 Тогда
    СФ = глНайтиСчетФактуру(Докум.ДокументОснование.ДокументОснование, "СчетФактура");
    ДопСчетФактура = "Дополнительный Счет-фактура к " + глПредставлениеДокумента(СФ);   
    КонецЕсли;// Если ДокументОснование.ДокументОснование.Выбран() = 1 Тогда
    КонецЕсли; //
    КонецЕсли;    
    КонецЕсли;    
    
    Таб.ВывестиСекцию("Шапка");
    
    Докум.ВыбратьСтроки();
    Пока Докум.ПолучитьСтроку() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;                   
    
    Таб.ВывестиСекцию("Итоги");
    Таб.ВывестиСекцию("Примечание");
    
    Таб.ПараметрыСтраницы(,,,,,,,,,1,,);
    Таб.Опции(0,0,0,0,"ОпцииСчетФактура");
    глЗащитаТаблицы(Таб);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать счет-фактуры",""); 
    
    Если глЗначение(Форма.Параметр, "ВидОбработки") = "ОбработкаДействияДокумента" Тогда
    Форма.Закрыть();
    КонецЕсли;
    
    КонецПроцедуры // Печать()
    
    
    //******************************************************************************
    // ПоКнопкеПечать()
    //
    // Параметры:
    //  Нет
    //
    // Возвращаемое значение:
    //  Нет
    //
    // Описание:
    //
    Процедура ПоКнопкеПечать()
    
    Печать(Док);
    
    КонецПроцедуры // ПоКнопкеПечать()
    
    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриОткрытии()
    
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    
    Докум      = Форма.Параметр.Получить("Контекст");
    Устройство = Форма.Параметр.Получить("Устройство");
    КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
    
    Печать(Докум, Устройство, КолвоКопий);
    Статусвозврата(0);
    Возврат;
    КонецЕсли;
    
    
    КонецПроцедуры // ПриОткрытии()
    
    
    [warn="Внимание!!!"]Пользуемся тегами!!!
    Буду наказывать[/warn]
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Зачем текст выкладывал? Надо было файл пркрепить))))))))))
    Все вреде бы вено. Должно работать. Кстати - права на вызов данной процедуры в конфигураторе установлены?
  18. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    да права стоят,под АдминБух. я захожу под Бух. в отчёте тоже права даны...
    но как да захожу в вкладках Отчёты ПечатьСФ неактивна...может это.... :unsure:

    Вложения:

  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вкладки здесь не играют роли. Судя по тексту обработки все должно сработать.
    Сделай так
    Код:
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(Контекст, "Контекст");
    Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
    Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
    ОткрытьФорму("Отчет.ПечатьСФ", Параметры);
    
    
  20. TopicStarter Overlay
    rom-pro
    Offline

    rom-pro

    Регистрация:
    22 апр 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    вставил в конфе проверил на ошибки их нет...
    нажал на печать....

    Если (Докум.ТипНоменклатуры <> Перечисление.ТипыНоменклатуры.Услуга) и
    {Отчет.ПечатьСФ.Форма.Модуль(23)}: Поле агрегатного объекта не обнаружено (ТипНоменклатуры)

Поделиться этой страницей