8.х Добавление телефона клиента в дополнительную обработку

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем dtown, 24 фев 2014.

  1. TopicStarter Overlay
    dtown
    Offline

    dtown

    Регистрация:
    17 июн 2013
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Добрый день,

    1С Розница 8.2
    Сделал дополнительную печатную форму для документа заказ клиента. Все ок только не могу добавить телефон клиента.
    В запросе пишу следующую строку:

    | Документ.Клиент.КонтактнаяИнформация.НомерТелефона КАК ТелефонЗаказчика,
    результата нет.

    Если же написать например:

    | Документ.Клиент.ДатаРождения КАК ТелефонЗаказчика,
    выводиться дата рождения.

    Подскажите, что делать? Как вывести телефон?
  2. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    В типовых посмотрите как из КИ выдергивается адрес и т.п. информация.
  3. TopicStarter Overlay
    dtown
    Offline

    dtown

    Регистрация:
    17 июн 2013
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    К сожалению в типовых отчетах нет не одного, где бы использовалась контактная информация клиента.
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    обычно КИ в регистре сведений вроде как сидит. Вы запрос ручками делали или конструктором?
  5. TopicStarter Overlay
    dtown
    Offline

    dtown

    Регистрация:
    17 июн 2013
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Я делал ручками. Интуитивно. Это вообще мой первый опыт создания дополнительной обработки.
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну а раз первый опыт, воспользуйтесь конструктором, сдается мне интуиция тут вас подвела
  7. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Запросом не получится, т.к. придется указывать тип КИ :)
    Вот пример, на коленке:
    Код:
    Функция ПолучитьКонтактнуюИнформацию (Ответсвенный)Экспорт
      Результат = Новый Структура("Почта,
      |Телефон");
    
      Запрос = Новый Запрос;
      Запрос.Текст =
      "ВЫБРАТЬ
      |    СотрудникиКонтактнаяИнформация.Значение КАК ЗначениеКонтакта,
      |    СотрудникиКонтактнаяИнформация.Тип
      |ИЗ
      |    Справочник.Сотрудники.КонтактнаяИнформация КАК СотрудникиКонтактнаяИнформация
      |ГДЕ
      |    СотрудникиКонтактнаяИнформация.Ссылка = &Ответственный";
    
    
      Запрос.УстановитьПараметр("Ответсвенный", Ответсвенный);
      Выборка = Запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий() Цикл
           Если   Выборка.Тип = Перечисления.ТипКонтактнойИнформации.EMail Тогда
               Результат.Вставить("Почта",Выборка.ЗначениеКонтакта);
           ИначеЕсли Выборка.Тип = Перечисления.ТипКонтактнойИнформации.Телефон Тогда
               Результат.Вставить("Телефон",Выборка.ЗначениеКонтакта);
           КонецЕсли;
      КонецЦикла; 
      Возврат Результат;
    КонецФункции 
    dtown нравится это.
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    тем более, интуитивно тут не катит.
    2ТС: Если первый раз делаете, то Алекс вам уже советовал что и где посмотреть вроде как
  9. TopicStarter Overlay
    dtown
    Offline

    dtown

    Регистрация:
    17 июн 2013
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Спасибо Алекс. Попробую использовать Вашу функцию. Только не понял какой именно параметр нужно передавать этой функции.
  10. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Там передается физлицо
  11. TopicStarter Overlay
    dtown
    Offline

    dtown

    Регистрация:
    17 июн 2013
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Вызываю так
    | ПолучитьКонтактнуюИнформацию(Документ.Клиент.Ссылка) КАК ТелефонЗаказчика,
    и так
    | ПолучитьКонтактнуюИнформацию(Документ.Клиент) КАК ТелефонЗаказчика,

    ругается
  12. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Извините меня, но вы бредите... Идите, курите матчасть, потом, если что не получится - обращайтесь....
    dtown нравится это.
  13. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    функция и запрос разные вещи. Вы только учитесь программировать в среде 1С? если да, то почитайте книжечки для начала. А если вам кодинг не нужен, а лишь разово решили подправить, то лучше к специалистам обратиться
    dtown нравится это.
  14. TopicStarter Overlay
    dtown
    Offline

    dtown

    Регистрация:
    17 июн 2013
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Вникаю потихоньку с Вашей помощью. Да я только учусь. Не разово, но по мелочам. К сожалению, бюджет выделенный руководством не позволяет обратиться к спецам. А знакомых хороших спецов нет. Ищу инфу по конкретным ситуациям по форумам, с нуля изучать структуру, язык и все правила возможности, времени и особой необходимости нет. Ибо такие случаи редки и все равно все подзабудется при нерегулярном использовании. Вот так )
  15. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Ну без базовых навыков вы только накуролесите и придется раскошеливаться на спецов. А необходимость изучить азы у вас есть, так как вы хотите что-то подправить

Поделиться этой страницей