7.7 Добавление скидки к товару процентом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем salexua, 16 окт 2009.

  1. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Стоит конфигурация Торговля+склад для Украины версия 7.70.012.
    Необходимо реализовать, добавление скидки в процентах к каждой позиции товара. Т.е чтобы была графа скидка,точнее она уже есть но там указывается скидка суммой а нужно что бы было в процентах.
    Подскажите пожалуйста как это реализовать.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Уточните - вы хотите вносить скидку на каждую позицию товара вручную?
  3. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Да именно так хочу
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1)Добавьте реквизит ТЧасти СкидкаПроцент
    2)В процедуре глПересчетТаблЧасти есть условие

    Код:
    Если ЕстьСкидка=1 Тогда
    ПроцентСкидки=Конт.Скидка.Процент;
    Иначе                                 
    ПроцентСкидки=0;
    КонецЕсли;
    
    
    
    Замените его на:
    Код:
    Если глЕстьРеквизитМнЧ("СкидкаПроцент",     Конт.Вид())=1 Тогда
    ПроцентСкидки=Конт.СкидкаПроцент;
    Иначе
    ПроцентСкидки=0;
    КонецЕсли;
    
    ЕстьСкидка = ?(ПроцентСкидки<>0,1,0);
    
    
  5. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Если не тяжело, подробнее.
    Я открыл отладчик но дальше не знаю где копать, в 1с я почти не разбираюсь, менял только печатные формы.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    гммм...... Зачем отладчик когда нужно конфигуратор.

    Сначала добавте реквизит в ТЧасть документа. (Если Делаете Заявки, то в ЗаявкиПокупателя и Реализацию. Если нет - только в Реализацию)
  7. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Зашел в расходную накладную, добавил СкидкаПроцент ( нужно ли ставить галочку напротив - Итог по колонке, в Сума скидка стоит?), потом открыл модуль документа,но такого кода не нахожу.
    Может не там рою?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Добавили реквизит. Уже хорошо. Вы присвоили ему тип число? (длина 2, точность 0)

    Затем этот реквизит нужно добавить в ТЧасть формы

    А код который я описывал находится в ГЛОБАЛЬНОМ МОДУЛЕ
  9. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Да все присвоил. Потом зашел в отладчик, в глобальный модуль но данного кода там не нахожу.

    Он у меня в списке табличной части Расходной накладной. Или нужно еще какие то действия?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Если вы занесли уже - больше ничего не нужно.

    Какая формула стоит в свойствах колонки цена (закладка дополнительно)?
  11. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Стоит галочка напротив - Неотрицательный.
    Смотрел в табличной части расходной накладной: Цена с НДС и Цена без НДС.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    НА ФОРМЕ!!! На колонке ТЧасти "Цена" пр. кн. мышки - свойства - закл. дополнительно - поле формула
  13. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    глВыч_суммы_накл(Контекст);
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Скопируй эту процедуру в текстовый файл и прикрепи к сообщению
  15. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Скопировал весь глобальный модуль. Извините но нужное нашлось несколько раз.

    Вложения:

  16. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Еще раз прошу прощение, но срочно нужно уйти на час. Спасибо Вам большое за помощь, надеюсь на продолжение разговора.
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вот в процедуре глВыч_суммы_накл измени код

    Код:
    Если ЕстьСкидка = Да Тогда
    Если Конт.СуммаСкидки > Конт.СуммаБезСкидки Тогда
    Конт.СуммаСкидки = Конт.СуммаБезСкидки;
    КонецЕсли;
    Конт.СуммаБезНДС = Конт.СуммаБезСкидки-Конт.СуммаСкидки;
    КонецЕсли;
    
    
    Скидку расчитай на основе введенного процента Конт.СкидкаПроцент
  18. TopicStarter Overlay
    salexua
    Offline

    salexua

    Регистрация:
    16 окт 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Код:
     Если ЕстьСкидка = Да Тогда
    Если Конт.СуммаСкидки > Конт.СуммаБезСкидки Тогда
    Конт.СуммаСкидки = Конт.СуммаБезСкидки;
    КонецЕсли;
    Конт.СуммаБезНДС = Конт.СуммаБезСкидки-Конт.СуммаСкидки;
    КонецЕсли;
    
    
    
    Я в разных последовательностях изменил Конт.СуммаСкидки на Конт.СкидкаПроцент, но не помогло.
    Скидка перестала вычисляться вообще.

    Теперь я разобрался, что это такое, но не могу добавить этот столбик в таблицу, говорит что не верный идентификатор.
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В диалоге формы: меню-вставить-реквизиты. Выскочит окно. Выбери в нижнем списке СкидкаПроцент (галочка), кн. вставить. Месторасположение в ТЧасти установи перетаскиванием
Похожие темы
  1. Valentus
    Ответов:
    6
    Просмотров:
    1.225
  2. natalika1601
    Ответов:
    5
    Просмотров:
    2.161
  3. abc_asup4
    Ответов:
    0
    Просмотров:
    397
  4. LNI1324
    Ответов:
    2
    Просмотров:
    1.131
  5. АннаК31
    Ответов:
    20
    Просмотров:
    1.927
Загрузка...

Поделиться этой страницей