8.х Добавление отбора

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ComOK, 27 май 2009.

  1. TopicStarter Overlay
    ComOK
    Offline

    ComOK Опытный в 1С

    Регистрация:
    11 ноя 2007
    Сообщения:
    56
    Симпатии:
    0
    Баллы:
    26
    Добрый день!
    Пытаюсь из документа вызвать обработку "ПечатьПрайсЛиста" (УТ 10.3.6.8).
    В прайс-листе необходимо сделать отбор по номенклатуре из табличной части товары.
    Написал следующий код:
    Код:
    Процедура ДействияФормыПечатьПрайсЛиса(Кнопка)
    // Вставить содержимое обработчика.
    ПрайсЛист = Обработки.ПечатьПрайсЛиста.Создать();
    СписокНоменклатуры = Новый СписокЗначений;
    Для каждого СтрокаТабличнойЧасти Из ДокументОбъект.Товары Цикл
    СписокНоменклатуры.Добавить(СтрокаТабличнойЧасти.Номенклатура);	
    КонецЦикла;
    
    МассивОтбора = Новый Массив;
    МассивОтбора.Добавить("Номенклатура");
    
    Для Каждого ЭлементОтбора Из МассивОтбора Цикл
    Если ПрайсЛист.ПостроительОтчета.Отбор.Найти(ЭлементОтбора) = Неопределено Тогда
    ПрайсЛист.ПостроительОтчета.Отбор.Добавить(ЭлементОтбора);
    КонецЕсли;
    КонецЦикла;
    
    ПрайсЛист.ПостроительОтчета.Отбор.Номенклатура.Использование = Истина;
    ПрайсЛист.ПостроительОтчета.Отбор.Номенклатура.ВидСравнения = ВидСравнения.ВСписке;
    ПрайсЛист.ПостроительОтчета.Отбор.Номенклатура.Значение = СписокНоменклатуры;
    Форма = ПрайсЛист.ПолучитьФорму("ФормаЗаполнения");
    Форма.Открыть();
    КонецПроцедуры;
    
    
    При добавлении отбора выскакивает ошибка: " {Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента(3689)}: Ошибка при вызове метода контекста (Добавить): Недопустимое значение параметра (параметр номер '1')
    ПрайсЛист.ПостроительОтчета.Отбор.Добавить(ЭлементОтбора);
    по причине:
    Недопустимое значение параметра (параметр номер '1')"

    Подскажите пожалуйста в чем может быть проблема.
    Заранее спасибо за ответы!
    "

    Прошу прощения проблему решил:) Форму открывать надо раньше, чем добавлять отбор!

Поделиться этой страницей