8.х Добавление колонки в журнал "ДокументыКонтрагентов"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем zhadan, 26 май 2008.

  1. TopicStarter Overlay
    zhadan
    Offline

    zhadan

    Регистрация:
    21 июн 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Для добавление колонки в журнал "ДокументыКонтрагентов" делаю следующие:
    в форме журнала добавляю колонку с именем "ЕстьРеализация", в модуль самой формы вписываю следующий код:

    Код:
    Процедура ЖурналДокументовСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    ДанныеСтроки = ОформлениеСтроки.ДанныеСтроки;
    Если ТипЗнч (ДанныеСтроки.Ссылка) = Тип ("ДокументСсылка.ЗаказПокупателя") 
    Тогда   ОформлениеСтроки.Ячейки.ЕстьРеализация.УстановитьФлажок(ЕстьРеализацияПоЗаказу(ДанныеСтроки.Ссылка));
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    Функция ЕстьРеализацияПоЗаказу(Заказ)
    Запрос = Новый Запрос(
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |	РеализацияТоваровУслуг.Ссылка
    |ИЗ
    |	Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |ГДЕ
    |	РеализацияТоваровУслуг.Сделка = &Сделка
    |	И РеализацияТоваровУслуг.ПометкаУдаления = ЛОЖЬ");
    Запрос.УстановитьПараметр ("Сделка", Заказ);
    Возврат Не Запрос.Выполнить().Пустой();
    КонецФункции
    
    И не чего не происходит... вообще...колонка есть а в ней пусто...
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    За один только запрос в цикле увольняют сразу.

Поделиться этой страницей