8.х Добавление колонки в табличную часть

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Sorkin, 27 авг 2014.

  1. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    да и для чего Вам сейчас ПодпискаНаСобытие, если Вы уже изменили модуль документа... меняйте дальше ;)
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Обновлять реально будет проще если объект новый. Что именно не получается?
    Sorkin нравится это.
  3. TopicStarter Overlay
    Sorkin
    Offline

    Sorkin Опытный в 1С

    Регистрация:
    30 май 2014
    Сообщения:
    106
    Симпатии:
    4
    Баллы:
    29
    Я сам сделал. Если делать движение в регистр через подписку, обновлять опять же будет легче)
    --- Объединение сообщений, 29 авг 2014 ---
    Не,я передумал программно делать:)
    --- Объединение сообщений, 29 авг 2014 ---
    Я сделал приход и расход по документам, "Поступление" и "Реализация". Теперь думаю, как сделать тоже самое по документу "Перемещение товаров":)
  4. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    если нужна максимальная обновляемость - делаете копию исходной формы, делаете с ней что хотите, и устанавливаете ее основной формой объекта

    в подписке на событие проведения документа у вас будет объект документа в параметре Источник
    просто добавляете запись в набор записей регистра
    Код:
    Для Каждого СтрокаТовары Из Источник.Товары Цикл
      Запись = Источник.Движения.ВашРегистр.Добавить();
      Запись.Период = Источник.Дата;
      Запись.Ячейка = СтрокаТовары.Ячейка;
    КонецЦикла;
    Источник.Движения.ВашРегистр.Записать();
    Sorkin нравится это.
  5. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Это прекрасно. А когда 1С в этой самой форме ченить поменяют. То все равно придется дописывать то, что они там поменяли. Вдруг там важное че нить. Палка с двумя одинаковыми концами. :)
  6. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    естественно, нужно будет что-то менять - но это можно будет сделать спокойно посмотрев на изменения в логике работы в форме и решить, что лучше будет сделать - снова доработать типовую форму или перенести изменения из типовой в свою.
    Tiger86 нравится это.
  7. TopicStarter Overlay
    Sorkin
    Offline

    Sorkin Опытный в 1С

    Регистрация:
    30 май 2014
    Сообщения:
    106
    Симпатии:
    4
    Баллы:
    29
    Спасибо. Я чуть чуть по другому сделал
    Код:
    Если ТипЗнч(Источник) = Тип("ДокументОбъект.РеализацияТоваровУслуг") Тогда
    //А =0;   
        Движения = РегистрыНакопления.Ячейки.СоздатьНаборЗаписей(); 
        Движения.Отбор.Регистратор.Установить(Источник.Ссылка);
    
     Для Каждого Строка Из Источник.Товары Цикл
       
        Движение = Движения.Добавить(); 
        Движение.Период = Источник.Дата;
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;  
        Движение.Склад = Строка.Склад; 
        Движение.СерияНоменклатуры = Строка.СерияНоменклатуры; 
        Движение.Номенклатура = Строка.Номенклатура;
        Движение.Ячейка = Строка.Ячейка;
        Движение.Количество = Строка.Количество;
    
     КонецЦикла;
        Движения.Записать(Истина);
    
    ИначеЕсли
    
    ТипЗнч(Источник) = Тип("ДокументОбъект.ПоступлениеТоваровУслуг") Тогда
       
        Движения = РегистрыНакопления.Ячейки.СоздатьНаборЗаписей(); 
        Движения.Отбор.Регистратор.Установить(Источник.Ссылка);
    
      Для Каждого Строка Из Источник.Товары Цикл
       
        Движение = Движения.Добавить(); 
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;  
        Движение.Склад = Строка.Склад; 
        Движение.СерияНоменклатуры = Строка.СерияНоменклатуры; 
        Движение.Номенклатура = Строка.Номенклатура;
        Движение.Ячейка = Строка.Ячейка;
        Движение.Период = Источник.Дата;
        Движение.Количество = Строка.Количество;
    
      КонецЦикла;
      Движения.Записать(Истина);
    КонецЕсли;
     
  8. TriviumFan
    Offline

    TriviumFan Опытный в 1С Заблокирован

    Регистрация:
    19 мар 2013
    Сообщения:
    92
    Симпатии:
    15
    Баллы:
    29
    :)

Поделиться этой страницей