8.х Добавление колонки Остаток в форму Состав набора. Ошибка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Netnic, 27 дек 2011.

  1. TopicStarter Overlay
    Netnic
    Offline

    Netnic Опытный в 1С

    Регистрация:
    9 ноя 2011
    Сообщения:
    427
    Симпатии:
    1
    Баллы:
    29
    8.2 Розница1.0. Из РМК перенёс фрагмент кода в форму Чек ККМ, остаток показывает, работает. Тот же фрагмент добавил в форму Состав набора, ошибка.

    {Обработка.СоставНабора.Форма.ОсновнаяФорма.Форма(250,73)}: Переменная не определена (Дата)
    ТаблицаОстатков = УправлениеЗапасами.ПолучитьОстаткиПоСкладам(КонецДня(<<?>>Дата), Товары.Выгрузить()); (Проверка: Толстый клиент (обычное приложение))
    {Обработка.СоставНабора.Форма.ОсновнаяФорма.Форма(250,80)}: Переменная не определена (Товары)
    ТаблицаОстатков = УправлениеЗапасами.ПолучитьОстаткиПоСкладам(КонецДня(Дата), <<?>>Товары.Выгрузить()); (Проверка: Толстый клиент (обычное приложение))


    Код:
    // Процедура - обработчик события "ПриПолученииДанных" табличной части
    //
    Процедура СоставНабораПриПолученииДанных(Элемент, ОформленияСтрок)
    
    РаботаСДиалогами.УстановитьОтметкиНезаполненногоДляХарактеристикНоменклатуры(ОформленияСтрок);
    
    Если Не ЭлементыФормы.Товары.Колонки.Остаток.Видимость Тогда
    Возврат;
    КонецЕсли;
    
    ТаблицаОстатков = УправлениеЗапасами.ПолучитьОстаткиПоСкладам(КонецДня(Дата), Товары.Выгрузить());
    ТаблицаОстатков.Свернуть("НоменклатураДокумента, ХарактеристикаНоменклатуры", "ТекущийОстаток");
    
    Для Каждого Строка Из ОформленияСтрок Цикл
    
    МассивОстатков = ТаблицаОстатков.НайтиСтроки(Новый Структура("НоменклатураДокумента, ХарактеристикаНоменклатуры", Строка.ДанныеСтроки.Номенклатура, Строка.ДанныеСтроки.ХарактеристикаНоменклатуры));
    
    Если МассивОстатков.Количество()=0 Тогда
    Строка.Ячейки.Остаток.Значение = 0;
    Иначе
    Строка.Ячейки.Остаток.Значение = МассивОстатков[0].ТекущийОстаток;
    КонецЕсли;
    
    КонецЦИкла;
    
    
    КонецПроцедуры // СоставНабораПриПолученииДанных()
    
    Что не так?
  2. t_a_p@mail.ru
    Offline

    t_a_p@mail.ru

    Регистрация:
    27 дек 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Думаю, надо поискать в том месте, откуда был выдран кусок кода, переменную "Дата".
    Возможно она:
    1. передавалась как параметр в функцию;
    2. была объявлена в той процедуре или модуле, откуда был выдран кусок кода

    не помешало бы еще узнать, из какого модуля был взят код?
  3. TopicStarter Overlay
    Netnic
    Offline

    Netnic Опытный в 1С

    Регистрация:
    9 ноя 2011
    Сообщения:
    427
    Симпатии:
    1
    Баллы:
    29
    Был взят отсюда:

    Форма Регистрации Продаж

    "ПРОЦЕДУРЫ - ОБРАБОТЧИКИ СОБЫТИЙ РЕКВИЗИТОВ ТАБЛИЧНОЙ ЧАСТИ "ТОВАРЫ""
    // Процедура - обработчик события "ПриПолученииДанных" табличной части

    непойму, почему тоже самое заработало в форме Чек ККМ!? а тут нехочет
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Потому что в форме документа Дата - это реквизит объекта, а у вас другая форма и даты там нет.
  5. TopicStarter Overlay
    Netnic
    Offline

    Netnic Опытный в 1С

    Регистрация:
    9 ноя 2011
    Сообщения:
    427
    Симпатии:
    1
    Баллы:
    29
    А как заставить это работать, подскажите
Похожие темы
  1. o1eg
    Ответов:
    13
    Просмотров:
    4.445
Загрузка...

Поделиться этой страницей