7.7 Добавление данных в новый журнал расчетов.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем roalang, 17 апр 2014.

  1. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Доброе утро.
    Есть документ "Сбор оплаты", в табличную часть этого документа собирается вся оплата от населения за месяц: <физлицо>, <вид расчета>, <сумма>, <дата поступления платежа>. Необходимо эти данные записать в созданный журнал расчет. Как правильно это сделать?

    Код:
    Процедура ОбработкаПроведения()
    
        ЖурО = СоздатьОбъект("ЖурналРасчетов.Оплата");
        Лс = СоздатьОбъект("Справочник.Клиенты");
       
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 цикл
                          
             ЖурО.УстановитьРеквизит("Рассчитана", 1);
            ЖурО.ВвестиРасчет(ФизЛицо, ВидРасчета.ОплатаЧерезКассу, ДатаОплаты, ДатаОплаты, Сумма);   
    
        КонецЦикла;
    КонецПроцедуры
    При попытке провести документ пишет ошибку "Объект расчета не найден". Пожалуйста помогите.
  2. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Сейчас попробовала сделать по другому
    Код:
    Процедура ОбработкаПроведения()
    
        ЖурО = СоздатьОбъект("ЖурналРасчетов.Оплата");
    
       
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 цикл 
           
            ЖурО.Новая();
            ЖурО.УстановитьРеквизит("Объект", ФизЛицо);
            ЖурО.УстановитьРеквизит("ВидРасч",ВидРасчета.ОплатаЧерезКассу );  
            ЖурО.УстановитьРеквизит("ДатаНачала", ДатаОплаты);
            ЖурО.УстановитьРеквизит("ДатаОкончания", ДатаОплаты); 
            ЖурО.УстановитьРеквизит("Результат", Сумма);
             //ЖурО.УстановитьРеквизит("Рассчитана", 1);
            //ЖурО.ВвестиРасчет(ФизЛицо, ВидРасчета.ОплатаЧерезКассу, ДатаОплаты, ДатаОплаты, Сумма);  
            ЖурО.Записать();
    
    
        КонецЦикла;
    КонецПроцедуры
    //******************************************
    НачДата = глДатаНачалаПериода;
    КонДата = глДатаКонцаПериода;
    
    гСпрВидыРасчетов = СоздатьОбъект("Справочник.ВидыРасчетов");
    Появилась ошибка "Не все обязательные реквизиты установлены при вводе новой записи журнала расчетов".
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ЖурО.УстановитьРеквизит("Документ", ТекущийДокумент());
    ЖурО.УстановитьРеквизит("РодительскийДокумент",ТекущийДокумент());
  4. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Добавила эти две строчки. И все таже ошибка.
  5. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Где еще можно посмотреть про журнал расчетов. Все реквизиты указаны, а не дает записать.
    Последнее редактирование: 17 апр 2014

Поделиться этой страницей