8.х Добавление данных в документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем VlasovSergey, 26 дек 2011.

  1. TopicStarter Overlay
    VlasovSergey
    Offline

    VlasovSergey

    Регистрация:
    26 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.
    (Платформа 8.1,"Управление торговлей" 10.3)

    я создал документ ДоверенностиВОрганы,я сделал что бы при изменений контрагента в этом документе автоматически менялись реквизиты формы такие как ИНН,КПП,Телефон,ФактическийАдрес и ЮридическийАдрес,путем запроса:

    Код:
    Процедура КонтрагентПриИзменении(Элемент)
    
    Контрагент=ЭлементыФормы.Контрагент.Значение;
    ЭлементыФормы.ИНН.Значение=Контрагент.ИНН;
    ЭлементыФормы.КПП.Значение=Контрагент.КПП;
    ЭлементыФормы.ТелФормСписка.Значение=Контрагент.ТелФормСписка;
    
    
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
    |ВЫРАЗИТЬ (КонтактнаяИнформация.Представление КАК Строка(100)) КАК ФактическийАдрес
    |ИЗ РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |ГДЕ КонтактнаяИнформация.Объект=&Контрагент
    |И КонтактнаяИнформация.Тип=Значение(Перечисление.ТипыКонтактнойИнформации.Адрес)
    |И КонтактнаяИнформация.Вид=Значение(Справочник.ВидыКонтактнойИнформации.ФактАдресКонтрагента)";
    
    
    Запрос.УстановитьПараметр("Контрагент",Контрагент); 
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() тогда
    ЭлементыФормы.ФактическийАдрес.Значение = Выборка.ФактическийАдрес;
    Иначе
    ЭлементыФормы.ФактическийАдрес.Значение = "Не найден";
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
    |ВЫРАЗИТЬ (КонтактнаяИнформация.Представление КАК Строка(100)) КАК ЮридическийАдрес
    |ИЗ РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |ГДЕ КонтактнаяИнформация.Объект=&Контрагент
    |И КонтактнаяИнформация.Тип=Значение(Перечисление.ТипыКонтактнойИнформации.Адрес)
    |И КонтактнаяИнформация.Вид=Значение(Справочник.ВидыКонтактнойИнформации.ЮрАдресКонтрагента)";
    
    
    Запрос.УстановитьПараметр("Контрагент",Контрагент);  
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() тогда
    ЭлементыФормы.ЮридическийАдрес.Значение = Выборка.ЮридическийАдрес;
    Иначе
    ЭлементыФормы.ЮридическийАдрес.Значение = "Не найден";
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
    |ВЫРАЗИТЬ (КонтактныеЛицаКонтрагентов.КонтактноеЛицо КАК Строка(100)) КАК ФИОРуководителя
    |ИЗ Справочники.КонтактныеЛицаКонтрагентов КАК КонтактныеЛицаКонтрагентов
    |ГДЕ КонтактныеЛицаКонтрагентов.Объект=&Контрагент";
    
    
    
    Запрос.УстановитьПараметр("Контрагент",Контрагент);  
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() тогда
    ЭлементыФормы.ФИОРуководителя.Значение = Выборка.ФИОРуководителя;
    Иначе
    ЭлементыФормы.ФИОРуководителя.Значение = "Не найден";
    КонецЕсли;
    
    
    КонецПроцедуры
    
    

    но в форме документа есть другие реквизиты Такие как:ФИОРуководителя и его паспортные данные.
    не могу понять где и как достать эти данные

    Вложения:

  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Смотрите регистр сведений "Паспортные данные физических лиц"
  3. TopicStarter Overlay
    VlasovSergey
    Offline

    VlasovSergey

    Регистрация:
    26 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    дело в том что еще у меня и это код не правильный:

    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
    |ВЫРАЗИТЬ (КонтактныеЛицаКонтрагентов.КонтактноеЛицо КАК Строка(100)) КАК ФИОРуководителя
    |ИЗ Справочники.КонтактныеЛицаКонтрагентов КАК КонтактныеЛицаКонтрагентов
    |ГДЕ КонтактныеЛицаКонтрагентов.Объект=&Контрагент";



    Запрос.УстановитьПараметр("Контрагент",Контрагент);
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() тогда
    ЭлементыФормы.ФИОРуководителя.Значение = Выборка.ФИОРуководителя;
    Иначе
    ЭлементыФормы.ФИОРуководителя.Значение = "Не найден";
    КонецЕсли;

    не могу найти Руководителя Контрагента

Поделиться этой страницей