7.7 Добавить ячейку с остатком по материалу

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем webresurs, 16 апр 2010.

  1. TopicStarter Overlay
    webresurs
    Offline

    webresurs

    Регистрация:
    22 июл 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Есть процедура см. ниже, надо получить в ячейке остаток на складе материалов
    в таблице:
    Выводит Наименование Материалов - СпрКС.ТекущийЭлемент()
    Выводит Единицу измерения материала - СпрКС.Элемент.ЕдиницаИзмерения
    Выводит норму расхода материала номенклатуры - СпрКС.Норма.Получить(ДатаНорм)
    Выводит остаток материала - ??????

    Код:
    Процедура ПриОткрытии(ФлагВосстановленияНастройки)  
    ВыбКоличество = 1;
    КонецПроцедуры
    
    Процедура Сформировать()  
    
    СпрСН = СоздатьОбъект("Справочник.Номенклатура");
    СпрКС = СоздатьОбъект("Справочник.НормыРасходов");
    
    ВыбКоличество = ?(ВыбКоличество = 0, 1, ВыбКоличество);
    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица"); 
    Таб.ВывестиСекцию("Шапка");   
    Если (ВыбНоменклатура.Выбран() = 1) и (ВыбНоменклатура.ЭтоГруппа()=0) Тогда
    СпрКС.ИспользоватьВладельца(ВыбНоменклатура);
    СпрКС.ВыбратьЭлементы(); 
    Если СпрКС.ВыбратьЭлементы() = 1 Тогда 
    Таб.ВывестиСекцию("СтрокаСН");  
    Пока СпрКС.ПолучитьЭлемент() = 1 Цикл 
    Таб.ВывестиСекцию("СтрокаКС");
    КонецЦикла; 
    КонецЕсли;
    
    Иначе
    
    СпрСН.ВыбратьЭлементы(); 
    Пока СпрСН.ПолучитьЭлемент() = 1 Цикл 
    ВыбЭлемент = СпрСН.ТекущийЭлемент();
    Если (ВыбНоменклатура.Выбран() = 1) и (ВыбНоменклатура.ЭтоГруппа()=1) Тогда
    Если ВыбЭлемент.ПринадлежитГруппе(ВыбНоменклатура)=0 Тогда
    Продолжить; 
    КонецЕсли;
    КонецЕсли;
    
    
    Если СпрСН.ЭтоГруппа() = 0 Тогда
    СпрКС.ИспользоватьВладельца(СпрСН.ТекущийЭлемент());
    СпрКС.ВыбратьЭлементы(); 
    Если СпрКС.ВыбратьЭлементы() = 1 Тогда 
    Таб.ВывестиСекцию("СтрокаСН");  
    Пока СпрКС.ПолучитьЭлемент() = 1 Цикл 
    Таб.ВывестиСекцию("СтрокаКС");
    КонецЦикла; 
    КонецЕсли;
    КонецЕсли;
    КонецЦикла; 
    КонецЕсли; 
    
    Таб.ВывестиСекцию("Полоска");
    Таб.Опции(0,0,6,0);
    Таб.Показать("Нормы рсходов на продукцию","");
    Таб.ТолькоПросмотр(1);
    КонецПроцедуры
    
    ДатаНорм = ТекущаяДата();
    
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Из вопроса совершенно не понятно как вы получаете остатки...
    Выложите обработку полностью и озвучте конфу

Поделиться этой страницей