8.х Добавить данные в табличную часть экранной формы

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем cobra77777, 11 июн 2014.

  1. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Скажите пожалуйста как при чтении xml файла чтобы данные добавлялись в табличную часть экранной формы ? Пример желательно.
  2. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    никто не знает :( ?
  3. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    Код:
    ПроксиСервер = Новый ИнтернетПрокси(Истина);
    Попытка
        НашеСоединение = Новый FTPСоединение(АдресFTP, 21, Логин, Пароль , , );
    Исключение
        Возврат;
    КонецПопытки;
    ИмяФайлаОтвета = ПолучитьИмяВременногоФайла(); 
    СписокФайлов = НашеСоединение.НайтиФайлы(КаталогFTP,"*Check.xml");
    ф =0;
    Для каждого Файл  из СписокФайлов Цикл
        НачатьТранзакцию();
        Если Файл.ЭтоФайл() Тогда
            Ф = Ф + 1;
            ИмяФайлаОтвета = ПолучитьИмяВременногоФайла(); 
            НашеСоединение.Получить(Файл.ПолноеИмя,ИмяФайлаОтвета);
            ТекстОтвета = Новый ТекстовыйДокумент();
            ТекстОтвета.Прочитать(ИмяФайлаОтвета);
            Если ТекстОтвета.КоличествоСтрок()>0 Тогда
                ОтветСервера = ТекстОтвета.ПолучитьТекст();
                ОбъектXML = Новый ЧтениеXML;
                ОбъектXML.ОткрытьФайл(ИмяФайлаОтвета);
                Пока ОбъектXML.Прочитать() Цикл
                    ТипУзла = ОбъектXML.ТипУзла;
                    ИмяУзла = ОбъектXML.Имя;
                    Если  ТипУзла = ТипУзлаXML.НачалоЭлемента И ИмяУзла = "Doc" тогда
                        // Смотря что в форме, то и заполняйте стандартными методами. ТЗ или ТЧ.
                        КодКарты = ОбъектXML.ПолучитьАтрибут("Karta");
                        док = Документы.ЧекЭлектронный.СоздатьДокумент();
                        док.Карта      = Карта;
                        Док.Записать(РежимЗаписиДокумента.Проведение);
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
  4. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    мне в документы записывать конечно ничего не надо (спасибо за пример): мне надо только отобразить в ТЗ.Мой код:
    Код:
    &НаКлиенте
    Процедура ТаблицаЗначений(Команда)
        ТЗ ()
    КонецПроцедуры
    
    &НаСервереБезКонтекста
    Процедура ТЗ ()
                                                          
    Чтение = Новый ЧтениеXML;
    
    
    ТЗНаФорме = Новый ТаблицаЗначений;
    
    
    Чтение.ОткрытьФайл("c:\1.xml");
    Спр="";
    // чтение осуществляется по одному тегу
    Пока Чтение.Прочитать() Цикл
        // анализируем тип элемента и его имя
        Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
           ИмяУзла = Чтение.Имя;
        КонецЕсли;  
    
    
       Если ИмяУзла = "СтраховойНомер" и Чтение.ТипУзла = ТипУзлаXML.Текст Тогда
      
         СтраховойНомер = Чтение.ПолучитьАтрибут("СтраховойНомер");
      
          ??????????????????????
    
          КонецЕсли;  
    
    КонецЦикла;
    
    КонецПроцедуры
    Последнее редактирование модератором: 16 июн 2014
  5. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну по аналогии. Костя документ создавал, а вы новую строку в свою тз пихайте. Что-то вас переклинило
    --- Объединение сообщений, 16 июн 2014 ---
    и пользуйтесь тегами
  6. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    Я не стал на внимание акцентировать :D. Думал понятно.
  7. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    кто такой Костя?
  8. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    Это я.
  9. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    может кто подскажет как выгрузить таблицу значений в xls ?
  10. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    В нете примеров куча. Да и здесь неоднократно обсуждалось. Ищите.

Поделиться этой страницей