[РЕШЕНО] Для проверки запрета изменения не найдены источники данных для таблицы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем deman_ru, 17 сен 2015.

  1. TopicStarter Overlay
    deman_ru
    Offline

    deman_ru Опытный в 1С

    Регистрация:
    27 дек 2011
    Сообщения:
    165
    Симпатии:
    1
    Баллы:
    29
    Добрый день. Подскажите пожалуйста, Конфигурация БГУ, редакция 2.0. Создал регистр накопления. По этому регистру делаю движения документом Акт об оказании услуг. В момент проведения появляется вот такая ошибка:

    Код:
    Ошибка при выполнении обработчика - 'ПередЗаписью'
    по причине:
    {ОбщийМодуль.ДатыЗапретаИзмененияСлужебный.Модуль(852)}: Для проверки запрета изменения не найдены
    источники данных для таблицы "РегистрНакопления._Спектакли".
            ВызватьИсключение(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
    Когда в настройках убираю настройку даты запрета редактирования, тогда все проводится. Как можно решить эту проблему:
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Добавить Регистр накопления, написать движения в него смогли, а разобраться, что происходит при записи в регистр и что необходимо, чтобы запись в регистр проходила без ошибок - нет?
    deman_ru нравится это.
  3. TopicStarter Overlay
    deman_ru
    Offline

    deman_ru Опытный в 1С

    Регистрация:
    27 дек 2011
    Сообщения:
    165
    Симпатии:
    1
    Баллы:
    29
    К сожалению нет) подскажите пожалуйста!
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Регистр копировали или с нуля создавали?

    Скорее всего есть подписка на событие, которая проверяет дату запрета редактирования данных
    deman_ru нравится это.
  5. TopicStarter Overlay
    deman_ru
    Offline

    deman_ru Опытный в 1С

    Регистрация:
    27 дек 2011
    Сообщения:
    165
    Симпатии:
    1
    Баллы:
    29
    Регистр создавался с нуля.
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Запускайте отладчик и проверяйте, выполнение условий, необходимых для успешной записи в регистр.
  7. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    ну посмотрите подписку на событие. типа Дата запрета или что то такое ПередЗаписьюРегистраНакопленияДатаЗапретаРедактирования
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Да все ж есть в тексте ошибки, нужно просто взять и разобраться что происходит.
  9. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    не ну понятно чтопервым делом надо отладчиком в в 852(ОбщийМодуль.ДатыЗапретаИзмененияСлужебный.Модуль(852)) строку стать и посмотреть
    --- Объединение сообщений, 17 сен 2015 ---
    Просто скорее всего есть подписка на событие и туда надо добавить новый регистр
  10. TopicStarter Overlay
    deman_ru
    Offline

    deman_ru Опытный в 1С

    Регистрация:
    27 дек 2011
    Сообщения:
    165
    Симпатии:
    1
    Баллы:
    29
    Есть такая процедура:
    Код:
    Функция ПолучитьИсточникиДанных(Отбор)
      
        ИсточникиДанныхТаблиц = ДатыЗапретаИзмененияСлужебныйПовтИсп.ИсточникиДанныхДляПроверкиЗапретаИзменения();
      
        ИсточникиДанных = ИсточникиДанныхТаблиц.НайтиСтроки(Отбор);
      
        Если ИсточникиДанных.Количество() = 0 Тогда
            ВызватьИсключение(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru = 'Для проверки запрета изменения не найдены
                           |источники данных для таблицы ""%1"".'"),
                Отбор.Таблица));
        КонецЕсли;
      
        Возврат ИсточникиДанных;
      
    КонецФункции
    
    В ИсточникиДанныхТаблиц, список объектов для проверки даты запрета изменения. Я так понимаю этот список берется из справочника Идентификаторы объекта метаданных?
    Там есть мой регистр.
    Если точнее, то если открыть справочник в пользовательском режиме регистр есть, а в ИсточникиДанныхТаблиц его нет.
    Последнее редактирование: 17 сен 2015
  11. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    ну я вам говорю же посмотрите подписки на событие, на регисры накопленя чт то типа ПередЗаписьюРегистраНакопленияДатаЗапретаРедактирования, увидите там Ваш регисрт не отмечен
  12. TopicStarter Overlay
    deman_ru
    Offline

    deman_ru Опытный в 1С

    Регистрация:
    27 дек 2011
    Сообщения:
    165
    Симпатии:
    1
    Баллы:
    29
    Да я глянул, там отмечены все регистры)
    --- Объединение сообщений, 17 сен 2015 ---
    Все огонь! Спасибо за наводящие ответы!;)
    Собака была зарыта вот тут:
    Код:
    Процедура ЗаполнитьИсточникиДанныхДляПроверкиЗапретаИзменения(ИсточникиДанных) Экспорт
       
        Для каждого ТекДокумент Из Метаданные.Документы Цикл
           
            Если НЕ ТекДокумент.Реквизиты.Найти("Организация") = Неопределено Тогда
               
                ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "Документ."+ТекДокумент.Имя, "Дата", "БухгалтерскийУчет", "Организация");
               
            КонецЕсли;
           
        КонецЦикла;
       
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрБухгалтерии.ЖурналПроводокЕПСБУ", "Период", "БухгалтерскийУчет", "Организация");
       
        Для каждого ТекРегистр Из Метаданные.РегистрыНакопления Цикл
           
            Если НЕ ТекРегистр.Измерения.Найти("Организация") = Неопределено Тогда
               
                ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрНакопления."+ТекРегистр.Имя, "Период", "БухгалтерскийУчет", "Организация");
               
            ИначеЕсли НЕ ТекРегистр.Измерения.Найти("ЛицевойСчет") = Неопределено Тогда
               
                ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрНакопления."+ТекРегистр.Имя, "Период", "БухгалтерскийУчет", "ЛицевойСчет.Владелец");
                           
            КонецЕсли;
           
        КонецЦикла;
       
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.АмортизацияОС",                                                 "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ЖурналУчетаСчетовФактур",                                     "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.КапРемонтОС",                                                 "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.МестонахождениеОС",                                             "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.МодернизацияОС",                                                 "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.НачислениеАмортизацииОСБухгалтерскийУчет",                     "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.НачислениеАмортизацииОСНалоговыйУчет",                         "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.НачислениеАмортизацииОССпециальныйКоэффициентНалоговыйУчет",     "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ОсновныеСредстваВПользовании",                                 "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ПараметрыАмортизацииОСБухгалтерскийУчет",                     "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ПараметрыАмортизацииОСНалоговыйУчет",                         "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ПервоначальныеСведенияОСНалоговыйУчет",                         "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ПереоценкаНФА",                                                 "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.РасчетАмортизацииОС",                                         "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.РасшифровкаКУДиР",                                             "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.СведенияОбОбъектеИмущества",                                     "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.СобытияОС",                                                     "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.УчетныеДанныеОбъектаОС",                                         "Период", "БухгалтерскийУчет", "Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ЦеныНоменклатуры",                                             "Период", "БухгалтерскийУчет", "Организация");
    
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ПлановыеДатыОплатыОбразование",                                 "Период", "БухгалтерскийУчет", "Учащийся.Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.ПлановыеДатыОплатыРодительскойПлаты",                         "Период", "БухгалтерскийУчет", "Ребенок.Организация");
        ДатыЗапретаИзменения.ДобавитьСтроку(ИсточникиДанных, "РегистрСведений.СведенияОСтудентах",                                             "Период", "БухгалтерскийУчет", "Студент.Организация");
    
    КонецПроцедуры
    
    Добавил в свой регистр измерение "Организация" и теперь ошибок нет.

Поделиться этой страницей