8.х Диаграмма Ганта

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Андрей_1991, 12 июл 2014.

  1. TopicStarter Overlay
    Андрей_1991
    Offline

    Андрей_1991

    Регистрация:
    12 июл 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    при формировании диаграммы все линии одинаковы,подскажите где ошибка

    Код:
    &НаКлиенте
    Процедура Сформировать(Команда)
        СформироватьНаСервере(ДиаграммаГанта);
    КонецПроцедуры
    
    &НаСервереБезКонтекста
    Процедура СформироватьНаСервере(Диаграмма)
     
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
                       |    НачисленияФактическийПериодДействия.Сотрудник,
                       |    НачисленияФактическийПериодДействия.ВидРасчета,
                       |    НачисленияФактическийПериодДействия.ПериодДействияНачало,
                       |    НачисленияФактическийПериодДействия.ПериодДействияКонец,
                       |    НачисленияФактическийПериодДействия.Результат,
                       |    НачисленияФактическийПериодДействия.Регистратор,
                       |    НачисленияФактическийПериодДействия.Регистратор.Представление
                       |ИЗ
                       |    РегистрРасчета.Начисления.ФактическийПериодДействия КАК НачисленияФактическийПериодДействия";
                    
                       ВыборкаРезультата = Запрос.Выполнить().Выбрать();
                    
                       Диаграмма.Обновление = Ложь;
                    
                       Диаграмма.Очистить();
                        Диаграмма.ОтображатьЗаголовок = Ложь;
                     
                        Пока ВыборкаРезультата.Следующий() Цикл
                         
                            ТекущаяСерия = Диаграмма.УстановитьСерию(ВыборкаРезультата.ВидРасчета);
                            ТекущаяТочка = Диаграмма.УстановитьТочку(ВыборкаРезультата.Сотрудник);
                            ТекущееЗначение = Диаграмма.ПолучитьЗначение(ТекущаяТочка, ТекущаяСерия);
                         
                            ТекущийИнтервал = ТекущееЗначение.Добавить();
                            ТекущийИнтервал.Начало = ВыборкаРезультата.ПериодДействияНачало;
                            ТекущийИнтервал.Конец = ВыборкаРезультата.ПериодДействияКонец;
                            ТекущийИнтервал.Текст = ВыборкаРезультата.РегистраторПредставление;
                            ТекущийИнтервал.Расшифровка = ВыборкаРезультата.Регистратор;
                         
                        КонецЦикла;
                     
                        Для Каждого Серия из Диаграмма.Серии Цикл
                            Если Серия.Значение = ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда
                                  Серия.Цвет = WEBЦвета.Желтый;
                               
                              ИначеЕсли Серия.Значение = ПланыВидовРасчета.ОсновныеНачисления.Премия Тогда
                                  Серия.Цвет = WEBЦвета.Зеленый;
                               
                              ИначеЕсли Серия.Значение = ПланыВидовРасчета.ОсновныеНачисления.Невыход Тогда
                                  Серия.Цвет = WEBЦвета.Красный;
                               
                              КонецЕсли;
                           
                          КонецЦикла;
                       
                          Диаграмма.Обновление = Истина;
                       
    КонецПроцедуры

    Вложения:

    • 20121.jpg
      20121.jpg
      Размер файла:
      458,8 КБ
      Просмотров:
      16
  2. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Может тут.
    ТекущийИнтервал = ТекущееЗначение.Добавить();
    ТекущийИнтервал.Начало = ВыборкаРезультата.ПериодДействияНачало;
    ТекущийИнтервал.Конец = ВыборкаРезультата.ПериодДействияКонец;

    Вы результат запроса смотрели может у Вас у Всех видов расчета периоды действия Начало и конец Совпадают?
  3. TopicStarter Overlay
    Андрей_1991
    Offline

    Андрей_1991

    Регистрация:
    12 июл 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    возможно

Поделиться этой страницей