Денежный ящик

Тема в разделе "Торговое оборудование в 1С", создана пользователем Sevak, 10 дек 2012.

  1. TopicStarter Overlay
    Sevak
    Offline

    Sevak Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    116
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста, как программно (из 1c розница 2.0) открыть денежный ящик WINCOR NIXDORF KA-18 ??????
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    А подключить его не пробовали? :))
  3. TopicStarter Overlay
    Sevak
    Offline

    Sevak Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    116
    Симпатии:
    0
    Баллы:
    26
    ну а серьезно?
  4. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Серъёзно не подскажу. Последний раз денежный ящик подключал с год назад к УТ. Все по инструкции, через кассу. Никаких дополнительных дров не устанавливал и уж тем более программных действий не совершал. Может спросишь у тех, кто вам торгвое оборудовние ставил? Они должны знать.
  5. TopicStarter Overlay
    Sevak
    Offline

    Sevak Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    116
    Симпатии:
    0
    Баллы:
    26
    Понимаешь, у меня денежный ящик открывается тогда когда я печатаю чек на принтер, а иным способом не открывается. Может какой то другой способ есть?????
  6. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Есть читай мат часть. Там есть команда на открытие ящика вставляй куда нужно.
  7. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Так же можно повесить на форму кнопку сделать ее скрытой присвоить ей команду(точнее формулу) открыть ящик.
  8. SergeyB
    Offline

    SergeyB Модераторы Команда форума Модератор

    Регистрация:
    8 июн 2010
    Сообщения:
    621
    Симпатии:
    3
    Баллы:
    29
    Из Розницы открыть ящик с кнопки нельзя. Можно его открыть из драйвера.
  9. TopicStarter Overlay
    Sevak
    Offline

    Sevak Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    116
    Симпатии:
    0
    Баллы:
    26
    если можно тщательно,просто очень нужно, Как иным способом открыть из драйвера. Объясню ситуацию.... Утром мне надо положить деньги в ящик. Не буду всяки раз печатать чек, чтобы положить там деньги??????????притом ключом не открывается WINCOR NIXDORF KA-18.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    с кассой как правило идет (или на сайте производителя есть) отдельная программа для проверки. В ней точно есть функция открытия ящика.
    А можно не мудрить и написать внешнюю обработку для открытия
  11. TopicStarter Overlay
    Sevak
    Offline

    Sevak Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    116
    Симпатии:
    0
    Баллы:
    26
    да ну как???????????
  12. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Была бы конфа УТ подсказал бы.
  13. SergeyB
    Offline

    SergeyB Модераторы Команда форума Модератор

    Регистрация:
    8 июн 2010
    Сообщения:
    621
    Симпатии:
    3
    Баллы:
    29
    а как в УТ?
  14. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    В тис команда звучит так если ящик подключен к ком порту
    Код:
    глДПОткрытьДенежныйЯщик()
    Код:
    // глДПОткрытьДенежныйЯщик()
    //
    // Параметры:
    //  Нет
    //
    // Возвращаемое значение:
    //  1 - операция успешно завершена, 0 - нет.
    //
    // Описание:
    //  Открывает денежный ящик
    Функция глДПОткрытьДенежныйЯщик() Экспорт
    Рез = 0;
    
    Если глДПВкл = 1 Тогда
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.Установить("Процесс" , "открыть_денежный_ящик");
    Параметры.Установить("Объект"  , глДП);
    
    РезТекст = глОборудованиеКоманда("Дисплей", глДПОбработка, Параметры);
    Если ПустоеЗначение(РезТекст) = 0 Тогда
    Сообщить(РезТекст);
    Иначе
    Если Параметры.Получить("Результат") = 0 Тогда
    Сообщить("Дисплей покупателя: ошибка при попытке открыть денежный ящик");
    Сообщить(Параметры.Получить("ОписаниеРезультата"));
    Иначе
    Рез = 1;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    
    Возврат Рез;
    КонецФункции // глДПОткрытьДенежныйЯщик()
    Если рассматривать вариант открытия денежного ящика через ккм
    пример на фискальнике СП101-402
    Скачиваем руководство программиста
    Находим строку
    [DLL] SPFR_OpenCashDrawer
    [OLE] OpenCashDrawer
    С помощью этой функции можно открыть денежный ящик, подключенный к ККМ.

    Но в самой обработке мы не найдем такой команды т.к команда зарегистрировать продажу подразумевает под собой вывод информации на дисплей покупателя и открыть ккм.
    Вопрос к топикстратеру у вас ящик куда подключен к ккм или непосредственно к компу?
    Если к ккм напишите модель и если можно выложите обработку для этого фискальника.
  15. dakim
    Offline

    dakim

    Регистрация:
    31 окт 2016
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, помогите мне с выбором денежного ящика, присмотрелся на этот da-office.ru/store/denezhniy-yashchik/merkurij-100.2/ , кто имел дело с ним? Может возникали проблемы в работе, или при установке к кассовому аппарату? Внедрению в конструкцию? планирую под столешницу к бармену поставить.
    Последнее редактирование модератором: 31 окт 2016

Поделиться этой страницей