7.7 День недели

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 2 июн 2010.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Ситуация в следующем. Мне в журнал "Х" документа нужно вывести колонку день недели документа.
    Делаю так:
    Создаю в "х" документе реквизит(строка) ДеньНедели далее в модуле формы заполняю
    Код:
    Если НомерДняНедели(ДатаДок) = 1 Тогда
    ДеньНедели="Понедельник";
    ИначеЕсли НомерДняНедели(ДатаДок) = 2 Тогда
    ДеньНедели="Вторник";
    ИначеЕсли НомерДняНедели(ДатаДок)= 3 Тогда
    ДеньНедели="Среда";
    ....................................... и т.д.
    
    
    В журнале добовляю новую колонку ДеньНедели. Всё отображается, но думаю так не правильно.
    По этому попробовал так, в модуле журнала делаю так:
    Код:
    Если НомерДняНедели(ТекущийДокумент.ДатаДок) = 1 Тогда
    ДеньНедели="Понедельник";
    ИначеЕсли НомерДняНедели(ТекущийДокумент.ДатаДок) = 2 Тогда
    ДеньНедели="Вторник";
    ИначеЕсли НомерДняНедели(ТекущийДокумент.ДатаДок)= 3 Тогда
    ДеньНедели="Среда";
    ................................... и т.д.
    
    
    Показывает в колонке(во всех строках) день недели Понедельник.
    Где я портачу и что я делаю не так?
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    А зачем создаете реквизит документа?

    Просто добавьте колонку (без идентификатора) в форме списка журнала документов, пропишите для колонки формулу ДеньНедели()
    и в модуле формы списка:
    Код:
    Функция ДеньНедели()   
    Если НомерДняНедели(ДатаДок) = 1 Тогда
    ДеньНедели = "Понедельник";
    ИначеЕсли НомерДняНедели(ДатаДок) = 2 Тогда
    ДеньНедели = "Вторник";
    ИначеЕсли НомерДняНедели(ДатаДок) = 3 Тогда
    ДеньНедели = "Среда";
    //....................................... и т.д.
    КонецЕсли;
    
    Возврат ДеньНедели;
    КонецФункции
    
    
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Правильнее так:
    ЗАЧЕМ КАЖДЫЙ РАЗ ВЫЗЫВАТЬ ФУНКЦИЮ????

    Код:
    Функция ДеньНедели()       
    Номер=НомерДняНедели(ДатаДок);
    Если  Номер = 1 Тогда        
    ДеньНедели = "Понедельник";    
    ИначеЕсли Номер = 2 Тогда        
    .....
    Возврат ДеньНедели;
    КонецФункции
    
    
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Полностью согласен. Не обратил внимания :unsure:

Поделиться этой страницей