[РЕШЕНО] Деление на последнее значение колонки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем s__nastusha, 18 май 2015.

  1. TopicStarter Overlay
    s__nastusha
    Offline

    s__nastusha

    Регистрация:
    3 апр 2015
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Подскажите, пожалуйста, как первый и последующие значения колонки разделить на последнее значение? Мне нужно рассчитать удельный вес, а он рассчитывается: абсолютное значение на баланс(это последняя ячейка, в этой же колонке).

    upload_2015-5-18_14-44-5.png
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Иметтся ввиду Табличная часть СравАналБал?

    СравАналБал[СравАналБал.Количество()-1] - это будет последняя строка вашей ТЧ
    а значенеи какго поля надо - берите
    СравАналБал[СравАналБал.Количество()-1].НужноеПоле
  3. TopicStarter Overlay
    s__nastusha
    Offline

    s__nastusha

    Регистрация:
    3 апр 2015
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Да, Таличная часть СравАналБал.
    Пробую код
    Код:
    СтрокаТабличнойЧасти.УделВесНаНач = СтрокаТабличнойЧасти.АбсолНаНач / СравАналБал [СравАналБал.Количество()-1].АбсолНаНач;
    Выдает ошибку переменная не определена. До этого обращались к строке табличной части, а потом к самой табличной части, как можно исправить?
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Попробуйте
    Код:
    СтрокаТабличнойЧасти.УделВесНаНач = СтрокаТабличнойЧасти.АбсолНаНач / Объект.СравАналБал [Объект.СравАналБал.Количество()-1].АбсолНаНач;
  5. TopicStarter Overlay
    s__nastusha
    Offline

    s__nastusha

    Регистрация:
    3 апр 2015
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Ошибка:
    {Справочник.СравнАналБаланс.Форма.ФормаСАБ.Форма(3)}: Поле объекта не обнаружено (СравАналБал)
    СтрокаТабличнойЧасти = Элементы.СравАналБал.ТекущиеДанные;
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    ну это уже на первую строку начал ругаться - код куда то переносили ли как?
    Как он у вас ейчас выглядеть?
  7. TopicStarter Overlay
    s__nastusha
    Offline

    s__nastusha

    Регистрация:
    3 апр 2015
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Да, я немного преобразовала код.
    Код:
    &НаКлиенте
    Процедура СравАналБалПоказателиПриИзменении(Элемент)
        СтрокаТабличнойЧасти = Элементы.СравнительноАналитическийБаланс.ТекущиеДанные;
        СтрокаТабличнойЧасти.ОтклонениеАбсолютныхВеличин =  СтрокаТабличнойЧасти.АбсолютноеЗначениеНаКонец - СтрокаТабличнойЧасти.АбсолютноеЗначениеНаНачало;
        СтрокаТабличнойЧасти.ОтклонениеУдельногоВеса =  СтрокаТабличнойЧасти.УдельныйВесНаКонец - СтрокаТабличнойЧасти.УдельныйВесНаНачало;
        СтрокаТабличнойЧасти.УдельныйВесНаНачало = СтрокаТабличнойЧасти.АбсолютноеЗначениеНаНачало / Объект.СравнительноАналитическийБаланс[Объект.СравнительноАналитическийБаланс.Количество()-1].АбсолютноеЗначениеНаНачало;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура СравАналБалАбсолНаНачПриИзменении(Элемент)
        СтрокаТабличнойЧасти = Элементы.СравнительноАналитическийБаланс.ТекущиеДанные;
        СтрокаТабличнойЧасти.ОтклонениеАбсолютныхВеличин =  СтрокаТабличнойЧасти.АбсолютноеЗначениеНаКонец - СтрокаТабличнойЧасти.АбсолютноеЗначениеНаНачало;
        СтрокаТабличнойЧасти.ОтклонениеУдельногоВеса =  СтрокаТабличнойЧасти.УдельныйВесНаКонец - СтрокаТабличнойЧасти.УдельныйВесНаНачало;
        СтрокаТабличнойЧасти.УдельныйВесНаНачало = СтрокаТабличнойЧасти.АбсолютноеЗначениеНаНачало / Объект.СравнительноАналитическийБаланс[Объект.СравнительноАналитическийБаланс.Количество()-1].АбсолютноеЗначениеНаНачало;
    КонецПроцедуры
    
    
    &НаКлиенте
    Процедура СравАналБалАбсолНаКонПриИзменении(Элемент)
        СтрокаТабличнойЧасти = Элементы.СравнительноАналитическийБаланс.ТекущиеДанные;
        СтрокаТабличнойЧасти.ОтклонениеАбсолютныхВеличин =  СтрокаТабличнойЧасти.АбсолютноеЗначениеНаКонец - СтрокаТабличнойЧасти.АбсолютноеЗначениеНаНачало;
        СтрокаТабличнойЧасти.ОтклонениеУдельногоВеса =  СтрокаТабличнойЧасти.УдельныйВесНаКонец - СтрокаТабличнойЧасти.УдельныйВесНаНачало;
        СтрокаТабличнойЧасти.УдельныйВесНаНачало = СтрокаТабличнойЧасти.АбсолютноеЗначениеНаКонец / Объект.СравнительноАналитическийБаланс[Объект.СравнительноАналитическийБаланс.Количество()-1].АбсолютноеЗначениеНаКонец;
    КонецПроцедуры
    
    + тут еще другие расчеты
    а ошибка, когда добавляешь значения
    upload_2015-5-18_16-1-6.png
    --- Объединение сообщений, 18 май 2015 ---
    Я нашла ошибку в своем коде.
    Теперь все работает.
    Спасибо большое за помощь!!!
    Последнее редактирование: 18 май 2015
  8. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    попробуйте закрыть все заново открыть конфигуратор, обновить конфигурацию и запустить. и проверьте имена может в какой букве ошиблись каогда ТЧ переменовывали
  9. TopicStarter Overlay
    s__nastusha
    Offline

    s__nastusha

    Регистрация:
    3 апр 2015
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Я нашла ошибку.
    Теперь все работает.
    Спасибо большое за помощь!!!
  10. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    да не за что

Поделиться этой страницей