7.7 Деление на 0

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Faz, 5 фев 2007.

  1. TopicStarter Overlay
    Faz
    Offline

    Faz

    Регистрация:
    5 фев 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Код:
        Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    НоваяСтрока();
    Товар=Док.Товар;
    КодТекст=Док.КодТекст;
    Цена=Док.Цена;
    Кол=Док.Кол;
    Кол0=Кол;
    Сумма=Док.Сумма;
    ЦенаПрих=Док.ОстСумма/Док.ОстКол;
    Если ПустоеЗначение(Док.Товар.ДефОтдел)=0 Тогда
    Склад=Док.Товар.ДефОтдел
    Иначе
    Склад=Док.Товар.ДефСклад
    КонецЕсли;
    КонецЦикла;   
    
    Вот что написано в коде, выдает ошибку

    ЦенаПрих=Док.ОстСумма/Док.ОстКол;
    {Документ.ВозвратРозница.Форма.Модуль(165)}: Деление на 0

    В чем дело помогите я новичек
  2. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Проверку на ноль надо добавить
    Код:
    Если Док.ОстКол=0 Тогда
    Сообщить("Количество равно нулю");
    Иначе
    ЦенаПрих=Док.ОстСумма/Док.ОстКол;
    КонецЕсли;
    
  3. TopicStarter Overlay
    Faz
    Offline

    Faz

    Регистрация:
    5 фев 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Спасибо за совет, а как?
  4. Hamster
    Offline

    Hamster Опытный в 1С

    Регистрация:
    26 янв 2007
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    ЧТо значит как??? Добавляешь указанный код вместо строки

    Код:
     ЦенаПрих=Док.ОстСумма/Док.ОстКол;
    
    и все, какие ещё проблемы?
Похожие темы
  1. Настенок
    Ответов:
    14
    Просмотров:
    2.539
  2. iluha_u
    Ответов:
    1
    Просмотров:
    1.067
  3. vartanet
    Ответов:
    2
    Просмотров:
    1.576
  4. Klaid
    Ответов:
    18
    Просмотров:
    11.909
Загрузка...

Поделиться этой страницей