Декларация по НДС 1с 2 кв. 1С 7.7 Бухгалтерия(600), ошибки

Тема в разделе "Бухгалтерский, налоговый и кадровый учет", создана пользователем Vertex, 23 июл 2015.

  1. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Ошибки при заполнении раздела 8. (Книги покупок).
    У документов поступления не заполняются поля Дата и Номер,.
    Ошибка в алгоритме. ...разделение значения ДатаНомер происходит по разделителю ";" .
    А у документов поступления разделитель "№".
    Пришлось в глобальном модуле "по быстрому " писать обработку символа номера.в стандартной функции глРазложить

    Код:
    Функция глРазложить(Знач Стр, Разделитель = ",") Экспорт
     
       Список = СоздатьОбъект("СписокЗначений");
     
       Если Найти(СокрЛП(Стр), "№") > 0 Тогда
         ДлинаСтр = СокрЛП(Стр);
         ТекПоз  = Найти(СокрЛП(Стр), "№");
         СтрД  = СокрЛ(Сред(Стр, 1,ТекПоз-1));
         СтрН  = СокрЛ(Сред(Стр, ТекПоз+1));
     
         Список.ДобавитьЗначение(СокрП(СтрН));
         Список.ДобавитьЗначение(СокрП(СтрД));
       Иначе 
         Длина  = СтрДлина(Разделитель);
       
         Стр = СокрЛП(Стр);
         Поз = Найти(Стр, Разделитель);
       
         Пока 0 < Поз Цикл
           Список.ДобавитьЗначение(СокрП(Лев(Стр, Поз-1)));
         
           Стр = СокрЛ(Сред(Стр, Поз+Длина));
           Поз = Найти(Стр, Разделитель);
         КонецЦикла;
         Список.ДобавитьЗначение(Стр);
       
       КонецЕсли; 
     
    
     
       Возврат Список;
     
    КонецФункции // глРазложить()
    Хочется выразить "благодрность" фирме 1с и писателям отчетности.
    Твари так то....имхо.

    Вложения:

    Последнее редактирование: 23 июл 2015
Похожие темы
  1. SergeyF
    Ответов:
    31
    Просмотров:
    12.242
  2. Sepegka
    Ответов:
    11
    Просмотров:
    2.253
  3. den1988m
    Ответов:
    2
    Просмотров:
    936
  4. leklerk
    Ответов:
    7
    Просмотров:
    347
  5. Speaker1982
    Ответов:
    2
    Просмотров:
    457
Загрузка...

Поделиться этой страницей