8.х Дата запрета

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Rimm2, 2 апр 2008.

  1. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Ну да логично. У пользователя нет прав на изменения регистра сведений "ГраницыЗапретаИзмененияДанных".
    Тут или проверку впихивать на права перед исполнением поцедурки (выполнять ее только у пользователя с полными правами, что наверное не совсем правильно, поскольку этот пользователь по логике должен заходить в базу всегда первым. что наверное в реальной жизни невсегда осуществимо), или всем давать права на регистр.
    во втором случае надо будет еще тогда интерфейсы откорректировать. Что бы по простоте душевной никто туда (в регистр) не лазил. Подумай чего тебе выгоднее.
  2. sss
    Offline

    sss

    Регистрация:
    1 май 2007
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    В идеале - завести некую переменную ("КоличествоДнейДоТекущейДаты", ограничив значение диапазоном значений 0 - 5), менять которую может только админ с "полными правами". При старте 1С от текущей даты отнимается содержимое переменной и записывается в регистр как значение для всех ролей. При необходимости можно вручную изменить дату, в таком случае произведенное изменение будет действовать до следующего старта 1С.
  3. TopicStarter Overlay
    Rimm2
    Offline

    Rimm2 Опытный в 1С

    Регистрация:
    10 фев 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26

    А можно же так да, чтобы у пользователя с неполными правами был доступ только на изменение этой даты? Если так то лучше разрешить им менять дату и убрать у них из интерфейса эту кнопку.
    Нормально будет.
  4. TopicStarter Overlay
    Rimm2
    Offline

    Rimm2 Опытный в 1С

    Регистрация:
    10 фев 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    Вообщем я разрешил всем ролям менять дату запрета, потом планирую убрать кнопку.
    Но теперь программа пишет что установка должна проводиться в монопольном режиме,
    и тоже выкидывает. Как бы это обойти?


    И ещё, как же её убрать? Чегото я не найду в конфигураторе, в интерфейсах, эту кнопку чтобы убрать?
  5. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    Попытка
    УстановитьМонопольныйРежим(Истина);
    Исключение
    //   Предупреждение("Установка даты запрета изменения данных должна выполняться в монопольном режиме.");        
    Отказ = Истина;
    //  Возврат;
    КонецПопытки;
    
    
    Если НЕ Отказ Тогда
    Набор = РегистрыСведений.ГраницыЗапретаИзмененияДанных.СоздатьНаборЗаписей();
    Набор.Загрузить(ТЗ);
    Набор.Записать();
    УстановитьМонопольныйРежим(Ложь);
    КонецЕсли;
    
    
    
    Заведи константу. И храни там количество дней.
  6. TopicStarter Overlay
    Rimm2
    Offline

    Rimm2 Опытный в 1С

    Регистрация:
    10 фев 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    Код:
    Попытка
    УстановитьМонопольныйРежим(Истина);
    Исключение     
    //   Предупреждение("Установка даты запрета изменения данных должна выполняться в монопольном режиме.");                
    //Отказ = Истина;      
    //  Возврат;    
    КонецПопытки;  
    Если НЕ Отказ Тогда    
    Набор = РегистрыСведений.ГраницыЗапретаИзмененияДанных.СоздатьНаборЗаписей();    Набор.Загрузить(ТЗ);    Набор.Записать();
    УстановитьМонопольныйРежим(Ложь);
    КонецЕсли;
    
    
    Я Отказ=Истина тоже удалил (т.е. как коментарий сделал), потому что без этого 1с просто ничего не пишет, просто без слов выкидывает. А так всё нормально, на мой взгляд.

    Я ничего страшного не сделал? Мож изза этого могут быть ещё какие нибудь последствия?
  7. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Просто Отказ замени на другую переменную, не правильно его (Отказ) тут использовать.
    Например обзови ее УстановитьДатуЗапрета.
  8. TopicStarter Overlay
    Rimm2
    Offline

    Rimm2 Опытный в 1С

    Регистрация:
    10 фев 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26

    Только в этом месте исправить?
  9. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    УстановитьДату = Истина; 
    Попытка
    УстановитьМонопольныйРежим(Истина);
    Исключение     
    
    УстановитьДату = Ложь;      
    
    КонецПопытки;  
    Если УстановитьДату Тогда    
    Набор = РегистрыСведений.ГраницыЗапретаИзмененияДанных.СоздатьНаборЗаписей();    Набор.Загрузить(ТЗ);    Набор.Записать();
    УстановитьМонопольныйРежим(Ложь);
    КонецЕсли;
    
  10. TopicStarter Overlay
    Rimm2
    Offline

    Rimm2 Опытный в 1С

    Регистрация:
    10 фев 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    Не Так он ошибку пишет. А что, нормально же было, когда просто убрал, (или в одном месте переименовал), Ток нельзя оставить чтоли?

    Вложения:

  11. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Не установил значение для УстановитьДату
  12. TopicStarter Overlay
    Rimm2
    Offline

    Rimm2 Опытный в 1С

    Регистрация:
    10 фев 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    Скажите пожалуйста а как бы теперь мне убрать возможность добавления кнопок в интерфейс?
    Ведь если я просто уберу кнопку, её любой может назат поставить простым нажатием на правую кнопку, и зайти в настройки.
  13. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    [warn=Rimm2]Один вопрос - одна тема![/warn]
  14. SeregaVD
    Offline

    SeregaVD

    Регистрация:
    29 фев 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    А как сделать тоже самое только в версии 10.3.3.3 я пробывал изменить вашу обработку у меня не получилось. Пожалуйста напишите как сделать запред редактирование данных в УТ 10.3.3.3 надоело ставить в ручную
  15. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Лезь в общие формы. Ищи там "УстановкаДатыЗапретаИзмененияДанных" посмотри как дата устанавливается.
  16. SeregaVD
    Offline

    SeregaVD

    Регистрация:
    29 фев 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Спасибо отдет достойный специалиста. java script:emoticon(':cry_1:', 'smid_8')
  17. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    :unsure:
    Вам дали ответ, который решает вопрос при определенных знаниях программирования. Если у вас нет таких знаний - обратитесь к специалистам, которые решат вашу проблему. Обычно это платно :)
  18. К_Е
    Offline

    К_Е Опытный в 1С

    Регистрация:
    8 июл 2008
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    ситуация похожая, но прикол в том, что менеджеры теперь не могут исправить данные в проведенной реализации, НО! могут отменить проведение, исправить реализацию и провести заново.
    У вас такого нет?
  19. tip22
    Offline

    tip22

    Регистрация:
    22 окт 2011
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    у меня Ут 10,3 использую обработку автоматическая установка даты запрета изменения данных , могу скинуть ? работает уже года 2 полет нормальный

Поделиться этой страницей