7.7 Дата запрета редактирования документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем lorcus, 5 июл 2010.

  1. TopicStarter Overlay
    lorcus
    Offline

    lorcus

    Регистрация:
    6 окт 2009
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! подскажите, как в 1с 7.7 Бухгалтерия запретить всем пользователям менять дату запрета редактирования документов, и чтобы только один, например Администратор мог это делать?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В глобальном модуле добавить
    Код:
    Процедура ПриЗаписиКонстанты(ИмяКонстанты, Значение)
    Если ИмяКонстанты="ДатаЗапретаРедактирования" Тогда
    Если (ИмяПользователя()<>"Администратор") Тогда
    Предупреждение("У вас нет прав на запись константы");
    СтатусВозврата(0);
    КонецЕсли;
    КонецЕсли; 
    //далее стандартные условия
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    lorcus
    Offline

    lorcus

    Регистрация:
    6 окт 2009
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Спасибо за ответ! А если создать копию интерфейса бухгалтера и в ней просто напросто убрать пункт настройки параметров, а у Администратора оставить родной интерфейс? будет ли так работать??
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Можно пойти и этим путем. Создать копию набора прав и константу ДатаЗапретаРедактирования убрать галку запись. Оставить только чтение

Поделиться этой страницей