8.х Дата запрета отдельно управленческий и отдельно регламентированный учет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем IrinaLVN, 30 ноя 2009.

  1. TopicStarter Overlay
    IrinaLVN
    Offline

    IrinaLVN

    Регистрация:
    30 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    1с заявляет "Можно установить дату запрета редактирования для документов управленческого учета, а можно для документов регламентированного учета с указаниме организации" Но что то на практике не получается. Задача закрыть период редактирования для документов с бух и нал голкой и оставить для редактирования документы с упр галкой. Как это сделать????
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    УПП? Версия?
  3. TopicStarter Overlay
    IrinaLVN
    Offline

    IrinaLVN

    Регистрация:
    30 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    1С:Предприятие 8.1 (8.1.14.72)
    Управление производственным предприятием, редакция 1.2 (1.2.24.1)
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Дык там на закладке все и устанавливается. В чем сложность?
  5. TopicStarter Overlay
    IrinaLVN
    Offline

    IrinaLVN

    Регистрация:
    30 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    у когонибудь это работает? в этоь то и сложность! что не работает .если ставить ограничение по организациям и не ставить дату в на общей закладке-то документы по упр учету доступны, но не проводятся-ошибка записи.
    Ошибка при выполнении обработчика - '{ОбщийМодуль.ПолныеПрава(934)}: Ошибка при вызове метода контекста (Записать): Операция не выполнена!'
    по причине:
    {ОбщийМодуль.ПолныеПрава(934)}: Ошибка при вызове метода контекста (Записать): Операция не выполнена!

    по причине:
    Операция не выполнена!


    Процедура ЗаписатьНаборЗаписейНаСервере(ИмяРегистра, Регистратор, ТаблицаДвижений = Неопределено, ТипРегистра = "РегистрНакопления") Экспорт

    Если ТипРегистра = "РегистрНакопления" Тогда
    Набор = РегистрыНакопления[ИмяРегистра].СоздатьНаборЗаписей();

    Если ТаблицаДвижений <> Неопределено Тогда
    Набор.мТаблицаДвижений = ТаблицаДвижений;
    ОбщегоНазначения.ВыполнитьДвижениеПоРегистру(Набор);
    КонецЕсли;

    Иначе
    Если ТипРегистра = "РегистрБухгалтерии" Тогда
    Набор = РегистрыБухгалтерии[ИмяРегистра].СоздатьНаборЗаписей();
    ИначеЕсли ТипРегистра = "РегистрСведений" Тогда
    Набор = РегистрыСведений[ИмяРегистра].СоздатьНаборЗаписей();
    ИначеЕсли ТипРегистра = "РегистрРасчета" Тогда
    Набор = РегистрыРасчета[ИмяРегистра].СоздатьНаборЗаписей();
    КонецЕсли;

    Если ТаблицаДвижений <> Неопределено Тогда
    Набор.Загрузить(ТаблицаДвижений);
    КонецЕсли;
    КонецЕсли;

    Набор.Отбор.Регистратор.Установить(Регистратор);
    Набор.Записать();

    КонецПроцедуры

Поделиться этой страницей