7.7 Дата отчета

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natalia_k, 15 фев 2011.

  1. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Всем привет!
    Подскажите, пожалуйста, в чем причина неверной выгрузки данных в отчет.

    Есть выгрузка данных на определенную дату "Дата1".
    Я задаю выгрузку на конец года 31.12.2010, но данные выгружаются все, вплоть до сегодняшнего дня.

    В модуле прописано:


    Код:
    Функция ПроверитьСостояние(ПС) 
    Подходит = 1;
    Если ПустоеЗначение(СостДог) = 0 Тогда
    Если ПС.СостояниеДоговора.Получить(Дата1) <> СостДог Тогда
    Подходит = 0;
    КонецЕсли;
    КонецЕсли;
    Возврат Подходит;
    КонецФункции                                  
    
    
    
    //*******************************************
    Процедура ПриОткрытии() 
    
    Дата1=РабочаяДата();
    
    КонецПроцедуры 
    

    Думаю, что ошибка в строчке Дата1=РабочаяДата();
    Но как подправить не знаю.

    Помогите, пожалуйста!
  2. 1Cman
    Offline

    1Cman Опытный в 1С

    Регистрация:
    25 июл 2009
    Сообщения:
    308
    Симпатии:
    0
    Баллы:
    26
    Правильно думаете, сделайте так:
    Код:
    Дата1 = '31.12.2010'
    
    
  3. 2man
    Offline

    2man Опытный в 1С

    Регистрация:
    26 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Если отчет на конец года, то лучше поместить реквизит Дата1 на форму, чтобы не быть в дальнейшем жестко привязанным к конфигуратору

Поделиться этой страницей