8.х Цвет формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем akelllo, 11 авг 2009.

  1. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Всем привет!!! Ребят, можете подсказать?
    Хочу чтобы в справочнике Метро можно было менять цвет фона поля.....чтобы было так........
    Посмотреть вложение 2517

    ......для того чтобы было так....))
    Посмотреть вложение 2516

    Это реально?

    Заранее большое спасибо!!

    Вложения:

    • метро.JPG
      метро.JPG
      Размер файла:
      61,2 КБ
      Просмотров:
      59
    • Метро2.JPG
      Метро2.JPG
      Размер файла:
      19,6 КБ
      Просмотров:
      61
  2. wiranata
    Offline

    wiranata Опытный в 1С

    Регистрация:
    21 янв 2009
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    Реально, как я понимаю обработчик:
    Код:
    РезультатПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    
    Собственно там условия оформления и тип описываеш.

    Как вариант:
    Код:
    Процедура РезультатПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Если (ДанныеСтроки.Коэффициент <> 0) И (НЕ ДанныеСтроки.Коэффициент = Неопределено) 
    И (НЕ ПустаяСтрока(ДанныеСтроки.Коэффициент)) Тогда
    ОформлениеСтроки.ЦветФона = WebЦвета.СеребристоСерый;
    ОформлениеСтроки.Шрифт = Новый Шрифт(,, Истина);
    КонецЕсли;
    КонецПроцедуры
    
    
  3. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Вот тебе пример:

    Процедура ЗадачаСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Если НЕ ДанныеСтроки.Выполнена Тогда
    Если ДанныеСтроки.КонтрольныйСрок <= КонецДня(ТекущаяДата()) Тогда
    Если ДанныеСтроки.КонтрольныйСрок >= НачалоДня(ТекущаяДата()) Тогда
    ОформлениеСтроки.ЦветТекста = Новый Цвет(0, 0, 255);
    Иначе
    ОформлениеСтроки.ЦветТекста = Новый Цвет(255, 0, 0);
    КонецЕсли;
    ОформлениеСтроки.Шрифт = Новый Шрифт(ОформлениеСтроки.Шрифт,,,Истина);
    КонецЕсли;
    КонецЕсли;
    Если ДанныеСтроки.Выполнена Тогда
    ОформлениеСтроки.ЦветТекста = Новый Цвет(100, 100, 50);
    ОформлениеСтроки.Шрифт = Новый Шрифт(ОформлениеСтроки.Шрифт,,,Истина);
    КонецЕсли;

    КонецПроцедуры

Поделиться этой страницей